[ubuntu/trusty-updates] webkitgtk 2.4.3-1ubuntu2 (Accepted)

Scott Kitterman ubuntu at kitterman.com
Mon Jun 23 23:58:27 UTC 2014


webkitgtk (2.4.3-1ubuntu2) trusty; urgency=medium

  * Don't fail the build on gtk-doc warnings.

webkitgtk (2.4.3-1ubuntu1) trusty; urgency=medium

  * SRU upstream bugfix release to Trusty (LP: #1326359)
  * Merge with Debian. Remaining changes:
    - Build for ppc64el and arm64
    - bugzilla_clear_surface.patch: Take patch to fix upstream bug#123480
      which was a crash affecting software-center in Ubuntu.
    - Don't use COMPARE_AND_SWAP and other snippets of asm on arm64; the
      compiler complains that they are invalid.
  * Reverted unwanted changes from unstable:
    - debian/control:
      + Require make 4.0, which is the version that can make parallel builds
        of webkitgtk.
    - debian/patches/x32_support.patch:
      + Fix FTBFS in x32
    - debian/patches/local-label-string-hurd.patch:
      + Fix FTBFS in hurd-i386.
    - debian/control:
      + Switch to geoclue 2 (Closes: #743606).

webkitgtk (2.4.3-1) unstable; urgency=medium

  * New upstream release.
  * debian/control:
    + Switch to geoclue 2 (Closes: #743606).
  * debian/patches/fix-gtkdoc-error.patch:
    + Refresh.
  * debian/patches/fix-webprocess-leak.patch:
    + Cherry picked r169374 and r169375 to properly fix a leak.

Date: 2014-06-06 21:19:13.168973+00:00
Changed-By: Iain Lane <iain at orangesquash.org.uk>
Signed-By: Scott Kitterman <ubuntu at kitterman.com>
https://launchpad.net/ubuntu/trusty/+source/webkitgtk/2.4.3-1ubuntu2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Trusty-changes mailing list