[storm] Decimal rename
Adrian Klaver
aklaver at comcast.net
Mon Nov 26 15:32:35 GMT 2007
On Friday 23 November 2007 6:12 pm, Gustavo Niemeyer wrote:
> Hello Adrian,
>
> > A while back I started a conversation on IRC about the Decimal name
> > conflicting with the Python Decimal type. At some point a call was made
> > for alternate names for the storm type. I had to leave the IRC channel at
> > that time and never got a chance to find out if anything was resolved.
> > Just dropping a line to see if a change will be made or not.
>
> We won't *change* it for sure, as that'd introduce backward compatibility
> issues unnecessarily, but we're not against naming it as something more
> sensible and having Decimal as an alias for instance.
>
> OTOH, as you can see in the ticket [1], finding a good name is not as
> obvious as it may sound.
>
> [1] https://bugs.launchpad.net/storm/+bug/126171
As I remember the conversation my suggestions where Dec() or DecimalType(). I
also seconded your choice of DecimalFloat().
--
Adrian Klaver
aklaver at comcast.net
More information about the storm
mailing list