Sounder 7 usability notes

David Miller justdave at bugzilla.org
Fri Aug 27 11:46:17 CDT 2004


Miscellaneous notes thrown together as I worked with Warty the last two 
days...  in case of anything architecture-specific, this is on a Dual 
USB 500 MHz iBook.

- Suspending the machine goes to text mode and spits garbage at the 
screen.  End users won't care to see that (just like the boot process). 
  Just log the stuff somewhere so tech support can tell them where to 
find it when they call for help.  Something simple like "Suspending..." 
and "Waking up..." on the text screen would be plenty sufficient if it 
has to stay on the text screen.  A small dialog box saying so without 
switching VTs away from the X desktop would be even better.

- xscreensaver kicks in with the screensaver immediately after waking up 
if you've been suspended longer than the timeout on the screensaver. 
xscreensaver's timer should start over when you wake the machine.

- "Keep aligned" on the desktop makes the first row be one row to the 
left of the Computer and Trash icons, meaning new files created on the 
Desktop are in fact not aligned with the Computer and Trash icons, which 
will confuse people into thinking "Keep aligned" is broken.  The rows 
are also quite close to each other.  It should probably default to using 
every other row, and then start working across the odd rows if someone 
is unorganized enough to fill up the whole desktop in the even rows.

- I think we should have the "always open in browser" option on by 
default in nautilus.  I tried to find one of my source files in Malone 
starting from double-clicking the Computer icon and going through 
Computer > Filesystem > home > dave > Source > Warthogs > dists > 
launchpad > lib > canonical > malone and wound up with 11 nautilus 
windows open, which I now had to close one at a time.  In the browser 
version, you can always right-click on an item and do "Open in New 
Window" if you really want something in a new window.

- dia-gnome is installed, but double-clicking a .dia file in nautilus 
says "there was an error launching the application."  Besides the 
obvious (it has a custom icon, which indicates we should know what app 
it belongs to), should that dialog offer the user a chance to locate the 
app to open it with instead of just saying in effect "sorry, you can't 
do that" and giving up?

- if you right-click on a .dia file and choose Properties, then go to 
the Open With tab, it says "No application selected".  So I click Add 
and get a text box with a Browse button next to it.  Nobody but a power 
user is going to have a clue what the full path to an executable is, 
this should just go directly to a file browser.  I choose /usr/bin/dia 
from the file browser, which incidentally has an "Open" button instead 
of "Select" or "Choose", and then I'm presented with the text box again 
with /usr/bin/dia entered in the box.  I thought I already picked it, 
why do I have to confirm? ;)

- Anyhow, after OKing the textbox dialog, the panel still says "No 
application selected" even if I go to a different tab and come back.  If 
I close the entire properties dialog and then go choose properties 
again, now it shows /usr/bin/dia as the selected app.

- Drives and Media preferences: Mac OS X has always had their equivalent 
of the "autorun programs on new drives and media" preference disabled by 
default, citing security concerns (a malicious autorun program on a CD 
could install a virus or do other Bad Things without the user even being 
able to see what was there first).  OS X 10.1 and later don't even give 
you an option anymore, CDs just can't do autorun.  I see security 
articles all the time recommending to disable that option on Windows. 
Should we really leave this on by default?

- WhirlyGig screensaver terminates with a SIGSEGV.

- Network Settings: click a profile, click the delete button.  ''Are you 
sure you want to delete profile "foo"?  You will not be able to recover 
this profile after pressing "apply"''  But there is no button labeled 
"apply", the choices are Cancel and Delete.

- Battstat crashed once when I woke up from suspend.  I haven't been 
able to reproduce this though.

-- 
Dave Miller      Project Leader, Bugzilla Bug Tracking System
http://www.justdave.net/             http://www.bugzilla.org/




More information about the sounder mailing list