A full review of Warty test 7 (text-only)

Lionel (Ploum) Dricot ploum at frimouvy.org
Fri Aug 27 09:45:06 CDT 2004

as requested, here's the text only version 


Install of Ubuntu Warty - test7 ( 25 augustus 2004)
Lionel Dricot (aka Ploum)
ploum at frimouvy.org (Jabber & mail)

For this test, I put myself in a non-geek skin. So I don't use my debian
knowledge or anything else and try to be as dumb as possible.

Italic sentence are where my geek spirit was coming back.
I speak french (and a bit dutch) so I only hope that you can understand
my english.
If my taillor is rich, my english is poor. (to be honnest, most of my
english knowledge come from Free Software mailing-lists)

Config :
AMD Athlon(tm) XP 2500+
MemTotal:       515816 kB
MB : nVidia nForce2
Gfx :  GeForce4 MX 440 AGP 8x
Eth : RTL-8139/8139C/8139C+
Sound :  nVidia Corporation nForce2 AC97 Audio Controler (intel8x0)
Screen : neovo F-417 LCD (1280x1024)

Notes :

- The framebuffer has never worked with this graphic card (with whatever
distro or kernel). Seems to be a bug in the kernel. No surprise, it
doesn't work with Warty. But I don't blame Ubuntu for it.

- The sound has a very good quality but seems to be very buggy (no
volume control available, must use the OSS emulation because direct ALSA

It seems to be an ALSA bug (well, in fact, an hardware bug that ALSA
doesn't repair). So, I don't blame Ubuntu for this. 

lspci, dmesg or others command are available on request. Contact me by
mail, jabber or on #gnome-debian.


I've put the CD in my CD-rom and then booted the computer. I then just
hit enter without looking for any options. I'm no more a geek..

I choose my language and my country. Quite easy.

There was there the partionning of the disk. Well, it's not really easy,
and the tool is a bit difficult to understand, but once you are used to
it, it works perfectly. Nothing to say here : partionning will always
remain a difficult task. That's why installing an OS is not trivial.
Keep it like this.

Then, the install begins. You just have to watch the progress bar. It
cannot be easier.

Well, then it asks me about Grub (my dear Debian Sid was perfectly
detected). Here also, we see a non-trivial question. But we have to
remember that we are installing a new Operating System.

It asks me to remove the CD-rom before reboot.


Oh.. weird. Grub is not sexy at all : no skin, just black and white ! (I
will see after that it was just a "first time bug". All reboot that
followed this one were prettier).

Since I've no frame-buffer (see the note), I can see a lot of error.
It's too quick to read anything, but I was frightened. (hopefully
without reason, it seems)

Then, it asks me for the time zone. It remember that I choose french and
belgium, so the proposed default was Brussel. Really insightful.

It asks me for my user name, login and password.

Next step : no CD-rom detected ! Big error message ! Panic on board !
Please enter the path to the CD-rom ( /dev/cdrom was the proposition).
Oh.. It cannot ever find the CD-rom because it asked me to remove it
before the reboot. This path message is really bad because nobody would
understand it. Some people would certainly stop here !
Instead,  I suggest a simple : "Please insert the CD-rom".  

Well, a bit worried by the message (not really, it's for the dramatic
effect, here's must be the climax), I carefully touch the "enter" key
and then...

(what about this page break just for the suspens ? 
Now it's time for Intermission. Like the one at the bridge of the death
Don't ask "which movie", little silly English pig-dogs! Go and boil your
bottoms, sundry silly persons. )

Well.. it works..

The apt-get installation begins. Really great, you don't have to type
anything or to know which package you have to install.
But, I must admit it : it's not really sexy. not at all...

And it's a bit long...

(A year passed.)

Really long...

( Winter changed into Spring.  Summer changed back into Winter,... )

Really really long. And not sexy at all!

( ...and Winter gave Spring and Summer a miss and went straight on into
Autumn. )

A good thing would be a progress bar with an estimate remaining time or
something like this.

( Note that it was great for me. I was looking for package with "ubuntu"
in the name so I can see which package are debian's ones and wich were

It's the time for the first X boot. A lot of black and white lines
appears on my screen. Quickly followed by a lot of coloured boxes. Seems
to be a bit buggy. I've waited a few minutes before hitting Ctrl+alt
(To be honnest, I've used my Linux knowledge here. I think that normal
people will try to reboot to obtains the same result.)

X reboot without glitches this time. What a nice GDM theme. I just
prefer with the users selector. But the resolution is 1152x864 and this
is really ugly on my LCD.

I try to enter my user name (ploum) but I see quickly that the keyboard
is not the belgian azerty one. (I will learn later that I have a Deutch
Qwertz keymap).

So I try to guess where each letter of my password is and enter into the

The desktop

(Just a quick first view)

I don't see any gnome-panel at the bottom of the screen. It takes me a
few time to understand that, if the resolution is 1152x864, the desktop
itself is in 1280x1024 (like it must be).

I resolve the problem by selecting, in the advanced preferences, 1152
resolution and then 1280 again. All was done with graphical tools and
the problem could be solved easily by a windows power-user. That's
really great !

I also look in the preferences for the keyboard properties. I don't
understand why it was using the Deutch keymap instead of be_FR. Well,
easily resolved.

As you can see on the screenshot, there's no applications shortcuts on
the panel. A bit difficult to start..

Also, the wallpaper seems too thin for my screen. (see the two blue bar
above and at the bottom).


An error box suddenly popup on my screen : "could not start the printer
tray icon because cups could not be contacted"

This popup, very annoying, will comes three times in a few minutes.
Irritating, isn't ?

Also, there's a broken Wifi applet and a broken battery applet. Indeed,
I've no Wifi and no more battery... Not pretty to see N/D things at the

First, I try email with evolution. I use it every day so I know that evo
1.5 is a great software. Be just aware about this little displying bug
when warning you about using an experimental software.

(screenshot here)

Indeed, the warning is a bit wide ;-)

It's now time for web browsing ( interschrub.net to buy online
schrubbery). No quicklaunch icon so I must dive in the applications

I don't see any webbrowser, but "Mozilla Firefox" and "Mozilla". I
launch the first one and, yes, it's a web browser ! Guess how geek am
I !
(surpinsingly, there's no Epiphany ! and Firefox is only the 0.8 !
Laaaaame.. I want firefox 0.9.3 with the super-extra-heavy plugin
extension that allow you to plug your fridge on your webbrowser... 3l33t
p0w444 !)

I go to http://schombert.net/ to download some free music (as in beer
and as in speech. That's why the more you drink beer, the more you speak
freely. .. ? ... nevermind !)

Well, I click on http://dschombert.free.fr/ogg/neos_hymn2001.ogg and I
download the file. Perfect but...

WHERE IS THIS F*** FILE NOW ? I know that it is somewhere in there. But
where ?

( The solution in this case is to wait outside the computer, imitating
the ogg file female (if your are looking for an ogg file male). When it
appears, take it quickly.)

Well, after looking around, I find that the file was in my HOME folder.
But there's no HOME icon on the desktop. I know that it is a choice, but
it could be difficult to assume fully this choice since a lot of
applications will use the HOME as default.

I found that I can see my HOME by the "places" menu in nautilus. I
double-click on the ogg : nothing happens.

I go to Applications > Multimedia and then start the music player. It
asks me somes questions and then, double-clicking on a ogg play the

Not easy.

(Damn, I hate Rhythmbox, and I know why... I suggest that, by default,
the music player were Totem. It's only MHO)

I then download some free movies (as in speech and as.. PAF! Aie. They
don't have any humor at Canonical...) on http://frimouvy.org


I know that those films are free simply because I made them ;-)


the first one was "Spray" (I've always dreamed to flight in space. So I
did it in this short fake publicity. Don't laugh, it's only a bad
french-speaking only joke)

Then I've tried "Beuclub" and the "Une vie d'humain" trailer.

I didn't see any image on the first one and the sound was very fast. The
others werent playing at all : "Pad problem. File a bug".

I know that those file are maybe poorly encoded (sine I made it myself)
but the vast majority of files on the internet are poorly encoded too.
Since those files play without problems on Totem-xine, mplayer and VLC,
I think that this is a gstreamer bug. 

Next step : install a new software.

I know that I must use synaptic. But if I wasn't aware, I would never
found it, so deeply burried and with a so esoterical name...
 ( Install/Remove Software would be better)

I launch it : it asks me for the root password. What's that ?

( Worst : I've read on the mailing list that the user can use sudo.
that's a quite good idea but then gnome-system-tools, synaptic and
others must be launched with sudo, not gksu )

That's all for today folks.  I will test the desktop more deeply another
day. Actions -> Log out and Shut down.

( Wow ! I'm verry happy that it works to shutdown as a simple user,
since I've never managed to do it on my Debian box)


The base system and the whole idea is very very very good ! It's really
what we want, what we need. Thank you.

It's really very cool that I've solved all my problems without any
console or config file ! It's great !

But, as you can see from my review, there's a lot of bugs (too much !).
There's no critical bug, but those bugs can be irritating, annoying and
give a bad feeling about the whole system.

But, you're The Team and I believe that the final release with kick
somes empty headed animal food trough wiper! I fart in your general
direction! Your mother was a hamster and your father smelt of

I hope that you can understand this review and that it will help you.

Sincerly yours,

Ploum (Lionel Dricot)

Waterloo - Belgium

27 augustus 2004

PS : I don't read what I've wrote, never. So you may think that this
text is full of mispelled words and you will be true.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Ceci est une partie de message
	=?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=
Url : http://lists.ubuntu.com/archives/sounder/attachments/20040827/21ad5689/attachment.pgp

More information about the sounder mailing list