Network connection to install packages

Swami s.swamyn at
Sat Feb 13 04:49:04 UTC 2016

Yes, that's the problem. If I use the same ethernet or USB-Ethernet
connection and boot to Ubuntu Desktop, I am able to access network as well
as internet access. No, I am not able to connect to any other destinations
too, even though I have assigned a static IP address to the eth

On Fri, Feb 12, 2016 at 6:54 PM, Manik Taneja <manik at> wrote:

> On Fri, Feb 12, 2016 at 5:19 PM, Swami <s.swamyn at> wrote:
>> Hi Developers,
>> I tried snappy installation using a generic x86 image, where I created a
>> bootable disk in a USB disk and plugged into my linux machine I had. I
>> modified the BIOS menu to use USB, instead of internal HDD image and the
>> Ubuntu Snappy booted up and came. I was able to try few commands as
>> mentioned above, such as
>> $ sudo snappy --help
>> $ sudo snappy list -v
>> $ sudo snappy info
>> But, when I try connecting to network, it is not able to find a package
>> or install a package. I have a physical ethernet connection to the main
>> linux machine, as well as I tried connecting/configuring a USB-Ethernet
>> connector, as USB keyboard was working. I modified the
>> /etc/network/interfaces to add the eth2 connection information for the
>> USB2Ethernet connection to connect to the server, so I can quickly check if
>> there is an active internet connection, and install few packages. When I
>> tried those, I am getting this error and tried other options, which didn't
>> help solve the problem. Anybody, any insights to resolve this?
>> $sudo snappy install docker
>> shows
>> Installing docker
>> docker failed to install: snappy package not found
>> $sudo snappy list -u
>> shows
>> Get
>> dial tcp: lookup no such host
>> ping localhost was success, but ping to external ip address or servers,
>> it couldn't find. Example:
>> ping
>> ping: unknown host
> are you sure you have internet access? are you able to ping other public
> destinations?
> Thinking its a name resolution issue, looked at the resolv.conf file, but
>> it has nothing and empty. Can you please provide some insights or is it
>> possible to install packages using a generic x86 image that I got from:
>> or not, so I can
>> quickly try how a package installation looks like and will I be able to
>> invoke a package using this generic barebone x86 device, which is nothing
>> but my linux machine running Ubuntu.?
>> Thanks,
>> Swami
>> --
>> snappy-devel mailing list
>> snappy-devel at
>> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the snappy-devel mailing list