Consistency in field naming

Gustavo Niemeyer gustavo.niemeyer at
Wed Feb 3 21:10:37 UTC 2016

Hello again,

Here is one more for our consistency book: Zygmunt proposed today in PR#420
a fix for one of the fields in the HTTP client which was named stop-timeout
as stop_timeout, as that's the convention used in other fields in the same
type. That followed up with a long conversation about which direction to
move, and peeked at finding out classes that are lacking serialization
directives and end up marshaled as camel-case (those were unintended). So
we are all across the place, and will be cleaning that up, no questions
about that.

The more ambitious change I'd like to propose, though, is moving every
single field under the control of Snappy itself (YAML, JSON, config, etc)
to use dashes, uniquely and consistently. The bad side of this is that
underlines may be used as in obj.stop_timeout when in Javascript, and
dashes need the obj["stop-timeout"] style, but this seems to be a very
minor gain compared to having to keep track of where we are whenever we
mention "stop-timeout".

So, for consistency sake, dashes everywhere!

We have agreement within a few people in the core development team, so
unless there's major disagreement here with good rationale (this is a
bikeshed-prone topic, so trying to cut that out), we'll move towards that
in the next week or so.

gustavo @
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the snappy-devel mailing list