Versions

Gábor Paller gaborpaller at gmail.com
Fri Oct 30 19:36:56 UTC 2015


"What are you trying to do with the versions other than "current"? "

Having more than one version installed and invoking a specific version.
Basic requirement in OSGi.

Regards,
Gabor

On Fri, Oct 30, 2015 at 8:13 PM, Rick Spencer <rick.spencer at canonical.com>
wrote:

>
>
> On Fri, Oct 30, 2015 at 2:17 PM, Gábor Paller <gaborpaller at gmail.com>
> wrote:
>
>> I have a really simple package.yaml now:
>> name: cameraagent
>> version: 20150802
>> vendor: Gabor Paller <paller.gabor at sze.hu>
>> icon: meta/cameraagent.svg
>> binaries:
>>  - name: cameraagent
>>    exec: bin/cameraagent.sh
>>
>> I install it once and I get a version:
>> cameraagent   2015-10-30 IEQGXGJJgKSI sideload
>>
>> I install it next time and I get a new version:
>> cameraagent   2015-10-30 IEQJGfCICRDY sideload
>>
>> And indeed, all these versions are there:
>> root at localhost:/apps/cameraagent.sideload#
>> pwd
>> /apps/cameraagent.sideload
>>
>> root at localhost:/apps/cameraagent.sideload#
>> ls
>> IEQGXGJJgKSI  IEQJGfCICRDY  current
>>
>> Now this is not what I want. Is there any way to put all these versions
>> into the same directory, under a known name, like it was previously when
>> the directory name was the same as the "version:" in the manifest?
>>
>
> What are you trying to do with the versions other than "current"?
>
> Cheers, Rick
>
>
> --
> snappy-devel mailing list
> snappy-devel at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/snappy-devel
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/snappy-devel/attachments/20151030/f47aa930/attachment.html>


More information about the snappy-devel mailing list