Fwd: Member not found

Gábor Paller gaborpaller at gmail.com
Fri Oct 30 01:28:49 UTC 2015

OK, I got this resolved. My Ubuntu Core on the Beaglebone silently updated
the ubuntu-core package to version 9. Meanwhile my developer tools still
came from the earlier beta ppa. The package format obviously changed so the
new core couldn't digest the old tools' package.

Note that I don't like this. With an embedded device, all the updates
should be controlled. This time I got an update that I didn't request and
my package is still uninstallable (this time it is the AppArmor file, maybe
my mistake, it worked before).


---------- Forwarded message ----------
From: Gábor Paller <gaborpaller at gmail.com>
Date: Fri, Oct 30, 2015 at 12:15 AM
Subject: Member not found
To: Snappy Devel <snappy-devel at lists.ubuntu.com>


I tried to generate a snap file with a command I used before and when I
installed on BeagleBone, I got a cryptic error message:

cameraagent_20150802_all.snap failed to install: member not found

Looking at the code, I found that this error is related to some tar member
not being part of the archive. So I took apart the snap file and everything
seems to be okay. What can this be? Is it possible that my developer tools
and the snappy system on the device got de-synchronized?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/snappy-devel/attachments/20151030/f93d2a11/attachment.html>

More information about the snappy-devel mailing list