What's 'warning: could not review package (click-review not available)'

mauro at freedomotic.com mauro at freedomotic.com
Fri May 1 21:11:36 UTC 2015


Hi Ash
thanks for your suggestions. Now the ckeck is made and I found some
errors. But the package is created. Maybe should be better to stop the
creation when something is wrong.

Mauro

---------THIS IS THe COMPILATION REPORT----------------
Errors
------
 - security_policy_vendor_matches_framework (meta/start.sh.apparmor)
        ubuntu-core != ubuntu-snappy (ubuntu-core-15.04-dev1)
 - security_policy_version_matches_framework (meta/start.sh.apparmor)
        15.04 != 1.3 (ubuntu-core-15.04-dev1)
 - security_redflag_fields (meta/start.sh.apparmor)
        found redflagged fields (needs human review): policy_vendor
Warnings
--------
 - lint_DEBIAN_extra_files
        found extra files in DEBIAN/: hashes.yaml
 - lint_snappy_unknown
        unknown entries in package.yaml: 'architectures'
freedomotic_5.6.0_multi.snap: FAIL
Generated 'freedomotic_5.6.0_multi.snap' snap

On Fri, May 1, 2015 3:55 pm, Ash Charles wrote:
> Hi Mauro,
>
>
> I think this warning appears if you don't have the
> "click-reviewers-tools" package installed.  If it is installed, the
> generated snap package will be checked to make sure everything is as it is
> supposed to be.  If you upload a package to the store, it'll use a similar
> (the same?) check.
>
>
> --Ash
>
>
> On Fri, May 1, 2015 at 1:49 PM,  <mauro at freedomotic.com> wrote:
>
>> This warning appears after "snappy build ." but anyway the snap is
>> created. What about it?
>>
>>
>> Thanks
>> Mauro
>>
>>
>> --
>> snappy-devel mailing list snappy-devel at lists.ubuntu.com Modify settings or
>> unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/snappy-devel
>




More information about the snappy-devel mailing list