package architectures not compatible with system arch

mauro at mauro at
Thu Apr 30 06:32:56 UTC 2015

Hi all
I tried with Raspi2.
Now the package is installed using the option --allow-unauthenticated.
But I have other issues
(RaspberryPi2)ubuntu at localhost:~$
aa-exec: ERROR: profile 'freedomotic_freedomotic.sh_5.6.0' does not exist
(RaspberryPi2)ubuntu at localhost:~$ sudo aa-status
apparmor module is loaded.
4 profiles are loaded.
4 profiles are in enforce mode.
0 profiles are in complain mode.
1 processes have profiles defined.
1 processes are in enforce mode.
   /sbin/dhclient (646)
0 processes are in complain mode.
0 processes are unconfined but have a profile defined.

(RaspberryPi2)ubuntu at localhost:~$ cat /apps/bin/
# !!!never remove this line!!!

set -e

if [ ! -d "$TMPDIR" ]; then
    mkdir -p -m1777 "$TMPDIR"
export TMPDIR

# app paths (deprecated)
export SNAPP_APP_PATH="/apps/freedomotic/5.6.0"
export SNAPP_APP_DATA_PATH="/var/lib//apps/freedomotic/5.6.0"
export SNAPP_APP_USER_DATA_PATH="$HOME//apps/freedomotic/5.6.0"
export SNAPP_OLD_PWD="$(pwd)"

# app paths
export SNAP_APP_PATH="/apps/freedomotic/5.6.0"
export SNAP_APP_DATA_PATH="/var/lib//apps/freedomotic/5.6.0"
export SNAP_APP_USER_DATA_PATH="$HOME//apps/freedomotic/5.6.0"

# FIXME: this will need to become snappy arch or something
export SNAPPY_APP_ARCH="$(dpkg --print-architecture)"

if [ ! -d "$SNAP_APP_USER_DATA_PATH" ]; then
   mkdir -p "$SNAP_APP_USER_DATA_PATH"

# export old pwd
export SNAP_OLD_PWD="$(pwd)"
cd /apps/freedomotic/5.6.0
aa-exec -p freedomotic_freedomotic.sh_5.6.0 --
/apps/freedomotic/5.6.0/bin/ "$@"

Please consider that all problems appeared when I added oracle java 7 in a
folder app_root/java/bin and app_root/lib.
O course I changed the bin file to point to embedded java executable.

The same package without java doesn't have any problem except it can't run

Any ideas?


On Wed, April 29, 2015 9:26 am, mauro at wrote:
> Hi all,
> I created a package without specifying in package.yaml. So it considers
> "all" as architecture.
> I installed it on Raspi2 without problems.
> Now I added a java jre and tried to install on Udoo board (armhf).
> In this case I received
> "cannot install ..snap Package architectures "all" not compatible
> withsystem architecture "armhf".
> Is a problem related to java or not? No message about java.
> I found on google a way to force the installation with the option
> --force-architecture. But this is not recognized by snappy.
> Thanks
> Mauro
> --
> snappy-devel mailing list snappy-devel at Modify settings or
> unsubscribe at:

More information about the snappy-devel mailing list