BeagleBone Black images keep getting corrupted

Víctor Mayoral Vilches victor at
Tue Apr 28 18:25:43 UTC 2015

Hi there,

At Erle Robotics we've been doing quite a bit of testing with Snappy and we
honestly love it.

Unfortunately the images get corrupted from time to time and that makes it
really troublesome. The reason seems to be related to a bad shutdown
process where some files in the *system-boot* partition get corrupted (if
not the whole partition itself). When dealing with drones we connect and
disconnect the batteries as needed thereby we constantly reproduce this

After the image goes wrong the only noticeable change is that the
*system-boot* partition seems wrong. When booting with a corrupted image we
get this behavior <>
(it ends up switching into eMMC)

When inspecting the system-boot partition:

*cat snappy-system.txt *
*cat: snappy-system.txt: Input/output error*

And for some reason, the whole system-boot partition seems wrong since
there's no way to edit it (complains about permissions and read-only file
system, tested with root and tried also repairing the partition but it did
not help).

This is an issue that appeared a while ago and we hoped it'll get solved
eventually but keeps coming in newer images and many users might have
experienced it.

Has anyone looked into this? Help would be much appreciated.
Kind regards,

*Víctor Mayoral Vilches*
CTO & Co-Founder

*Erle Robotics* | victor at
+34 616151561
*skype*: v.mayoral
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the snappy-devel mailing list