vim snap issue with bad system call

Woodrow Shen woodrow.shen at
Fri Mar 24 08:10:34 UTC 2017


In order to fit my habit for better experiences (e.g. bundle), I tried to
snapcraft the vim snap [1], but after installing the snap and connecting
the home interface, I got the weird error of bad system call when vim was
closed with ":wq" for write. Another thing I noticed that .vim and .vimrc
should be placed in the $HOME/snap/demo-vim/current/, however, I still got
the same error there, even if I added undo/backup/swap dirs inside .vimrc.
So currently I don't find any clues from syslog about this. Just give me
some suggestions if anyone interests vim snap.

Here's my .vimrc (just simply test):
*set undodir=/home/admin/snap/demo-vim/current/.vim/.undo//*
*set backupdir=/home/admin/snap/demo-vim/current/.vim/.backup//*
*set directory=/home/admin/snap/demo-vim/current/.vim/.swp//*
*set viminfo="NONE"*



Snapcraft mailing list
Snapcraft at
Modify settings or unsubscribe at:

More information about the Snapcraft mailing list