Status of snapd on Arch Linux

Gustavo Niemeyer gustavo at
Mon Mar 20 20:39:23 UTC 2017

On Fri, Mar 17, 2017 at 8:32 PM, Joseph Rushton Wakeling <
joseph.wakeling at> wrote:

> Hello folks,
> Is there anyone here working on snapd on Arch?
> I ask because I recently tried it out on a fresh Arch install and ran into
> some issues.
> Installing snaps works fine in itself, and snap list is able to find the
> installed snaps.  However, these issues arose as soon as I started trying
> to use them:
>   * snap --version lists 'unknown' for snap, snapd and arch
>   * all snap-related stuff is placed in /var/lib/snapd/snap instead of
> /snap
>     (fine in itself), but the PATH still contains /snap/bin rather than
>     /var/lib/snapd/snap/bin.
>       - according to
> ,
>         installing a snap should cause it to be mounted to /snap/snapname
>         but this doesn't appear to be happening

Looks like the package changed recently then, after the rdocumentation was

Do we have details on who's done that and why?

/snap still feels so much better.

  * installing my ldc2 snap (`snap install --classic --candidate ldc2`)
> worked
>     fine (it shows up in `snap list` as expected) but if I try to run
>     /var/lib/snapd/snap/bin/ldc2 directly I get an error message:
>         execv failed: No such file or directory

What is it pointing to?

  * attempting to run the actual underlying binary within the snap, i.e.
>     /var/lib/snapd/snap/ldc2/current/bin/ldc2 (or any of the other
> binaries
>     there) results in a similar error message:
>         -bash: ./ldc2: No such file or directory

This was never supposed to be done. Exposed content is supposed to work as
done above.

Running `file ldc2` on the binary reveals what I would assume is correct
> information:
>     ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically
>     linked, interpreter /snap/core/current/lib/x86_64-linux/gnu/
> ,
>     for GNU/Linux 2.6.32, BuildID[sha1]=[I'm not typing this out], not
>     stripped, with debug_info
> ... and uname -m gives x86_64, so I don't think it can be an issue like
> trying to run a 32-bit package on a 64-bit system (or vice versa).
> For comparison I tried installing both hello-world and Michael
> Hudson-Doyle's go snap.  hello-world ran fine (but it is after all only a
> shell script underneath).  The go snap ran into the same issues as my ldc2
> snap.
> I assume these are known issues, but can anyone advise on what are the
> fundamental problems here and on whether it's expected to be addressed soon?

Most of these issues seem to be related to the move out of /snap, perhaps
done too quickly.

I'd suggest returning /snap to its place, at least until those issues are
sorted out there.

gustavo @

More information about the Snapcraft mailing list