Issues installing snap

Luther Goh Lu Feng elfgoh at yahoo.com
Thu Jan 26 08:16:36 UTC 2017


I have successfully created a snap using snapcraft. However, I encountered issues when trying to install the snap. The device is a Beaglebone black with a shield containing a temperature sensor. The program that has been snapped returns the temperature, and works correctly outside of the snap. Will appreciate if someone can give me pointers. Thanks. 


Distribution: Debian
SBC: BBB
Linux Kernel: 4.4.9-ti-r25
snapd(on debian): 2.20-2
snapcraft (ubuntu docker): 2.25

                                
C program: http://dpaste.com/2F1T39C
Makefile:

default:
gcc temperature.c -o temperature

install: temperature
install -m 0755 temperature  $(DESTDIR)/


Logs:

$ systemctl status snap-ambient-x1.mount
‚óŹ snap-ambient-x1.mount - Mount unit for ambient
Loaded: loaded (/etc/systemd/system/snap-ambient-x1.mount; enabled)
Active: failed (Result: signal) since Thu 2017-01-26 15:41:59 SGT; 1min 58s ago
Where: /snap/ambient/x1
What: /var/lib/snapd/snaps/ambient_x1.snap
Process: 4379 ExecMount=/bin/mount -n /var/lib/snapd/snaps/ambient_x1.snap /snap/ambient/x1 -t squashfs (code=killed, signal=SEGV)

Jan 26 15:41:59 beaglebone systemd[1]: snap-ambient-x1.mount mount process exited, code=killed status=11
Jan 26 15:41:59 beaglebone systemd[1]: Failed to mount Mount unit for ambient.
Jan 26 15:42:00 beaglebone systemd[1]: Unit snap-ambient-x1.mount entered failed state.


$ journalctl -xn
-- Logs begin at Sat 2000-01-01 08:00:03 SGT, end at Thu 2017-01-26 15:44:02 SGT. --
Jan 26 15:41:59 beaglebone systemd[1]: Failed to mount Mount unit for ambient.
-- Subject: Unit snap-ambient-x1.mount has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit snap-ambient-x1.mount has failed.
--
-- The result is failed.
Jan 26 15:42:00 beaglebone systemd[1]: Unit snap-ambient-x1.mount entered failed state.
Jan 26 15:42:00 beaglebone /usr/lib/snapd/snapd[410]: task.go:303: DEBUG: 2017-01-26T15:42:00+08:00 ERROR [start snap-ambient-x1.mount] fa
Jan 26 15:42:00 beaglebone /usr/lib/snapd/snapd[410]: taskrunner.go:353: DEBUG: Running task 77 on Undo: Prepare snap "/tmp/snapd-sideload
Jan 26 15:43:01 beaglebone main[1078]: % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Jan 26 15:43:01 beaglebone main[1078]: Dload  Upload   Total   Spent    Left  Speed
Jan 26 15:43:01 beaglebone main[1078]: 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (56) Recv failure
Jan 26 15:44:02 beaglebone main[1078]: % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Jan 26 15:44:02 beaglebone main[1078]: Dload  Upload   Total   Spent    Left  Speed
Jan 26 15:44:02 beaglebone main[1078]: 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (56) Recv failure




More information about the Snapcraft mailing list