Error using custom image

Luke Williams luke.williams at
Thu Jan 19 17:08:33 UTC 2017

That fixed it for the most part. Now we are getting dropped to a maintenance shell saying that our /lib/modules/ directory is empty. I feel this might have something to do with how we are building the kernel itself. 


Luke Williams - Technical Partner Manager, Open Networking/Ubuntu-Core
email: luke.williams at <mailto:luke.williams at> <> | <>

> On Jan 18, 2017, at 10:56 AM, Sergio Schvezov <sergio.schvezov at> wrote:
> On Wed, 18 Jan 2017 18:42:27 +0000, Luke Williams wrote:
>> Hello,
>> We are trying to build a custom image with a custom kernel. The 
>> kernel build and making the image goes without a hitch, however, 
>> when we try to run it in Virtual Box, we get the following 
>> error:
>> And it fails to load. 
>> We have tried an image built with the custom kernel, one built 
>> with a yaketty kernel, and one that we just build with all stock 
>> pieces. None of them can get past this part.
>> If we use the image that we download from cdimages, that one 
>> works. When we look at the images side by side, we can’t see any 
>> differences. 
>> Is there anything you recommend we check to see why it cannot 
>> see the writable partition?
> Without havig touched this in a while have you ensured you have vfat and squashfs either built-in or in initramfs?
> -- 
> Sent using Dekko from my Ubuntu device
> -- 
> Snapcraft mailing list
> Snapcraft at <mailto:Snapcraft at>
> Modify settings or unsubscribe at: <>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Snapcraft mailing list