snapcraft mir-kiosk-apps errno 21

Adam Heavens adam.heavens at
Wed Apr 5 17:54:37 UTC 2017

Thanks Pat,

I am using 16.10, I will build a 16.04 VM and try on that

I have version 2.28+16.10 of Snapcraft installed

I get the same error message if I do a fresh git clone or rerun and Snapcraft clean and then snapcraft produces the same error message.



-----Original Message-----
From: snapcraft-bounces at [mailto:snapcraft-bounces at] On Behalf Of Pat McGowan
Sent: 05 April 2017 18:34
To: Snapcraft <snapcraft at>
Subject: Re: snapcraft mir-kiosk-apps errno 21

It built fine here on Xenial.
Did it fail the same way on the previous run? What happens if you "snapcraft clean" and "snapcraft"?
Which version is your desktop?
What version of snapcraft?


On Wed, Apr 5, 2017 at 12:43 PM, Adam Heavens < adam.heavens at> wrote:

> Hi,
> Thanks to the mailing list and bug report I am now able to run mir-kiosk.
> Thank you again for your help with that.
> I am now working on the next step of our POC which is developing a Qt 
> based app running on mir-kiosk. I am looking to modify the 
> mir-kiosk-apps demo to start with to learn more about Qt, mir and creating/updating snaps.
> First I wanted to create a snap without any modifications, However I 
> can't get the snap to generate using the following instructions
> $ git clone -b master
> $ cd mir-kiosk-apps
> $ snapcraft
> This results in the following errno21 message rather than generating a 
> .snap
> Skipping stage mir-demos (already ran) Skipping pull qmldemo (already 
> ran) Skipping build qmldemo (already ran) Skipping stage qmldemo 
> (already ran) Skipping prime qmldemo (already ran) Skipping pull 
> qtubuntu (already ran) Skipping build qtubuntu (already ran) Skipping 
> stage qtubuntu (already ran) Skipping pull qt-examples (already ran) 
> Skipping build qt-examples (already ran) Skipping stage qt-examples 
> (already ran) Skipping pull qtchooser-config (already ran) Skipping 
> build qtchooser-config (already ran) Skipping stage qtchooser-config 
> (already ran) Skipping prime qtchooser-config (already ran) Skipping 
> pull glue (already ran) Skipping build glue (already ran) Skipping 
> stage glue (already ran) Priming inotify-tools Priming app-wrappers 
> Priming mir-demos Priming qtubuntu [Errno 21] Is a directory: 
> '/home/adamheavens/mir-kiosk- apps/prime/etc/xdg'
> What am I doing wrong?
> Thanks
> Adam
> --
> Snapcraft mailing list
> Snapcraft at
> Modify settings or unsubscribe at: 
> mailman/listinfo/snapcraft
Snapcraft mailing list
Snapcraft at
Modify settings or unsubscribe at:

More information about the Snapcraft mailing list