Pi3 - Ubuntu Core - mir-kiosk

Kevin Gunn kevin.gunn at canonical.com
Tue Apr 4 16:18:43 UTC 2017

Hey Adam,
First, Thanks for trying it out! sorry you're having trouble.

Myself and some other folks have just tried out the pi3 with mir-kiosk and
all seems to be working without issue on our end. Our one guess is
potentially related to your display setup... But the best way to proceed
would be to file a bug & attach your whole syslog there. Email threads tend
to be messy for debugging.

You can log a bug for us at https://bugs.launchpad.net/mir/+filebug

Then we can capture all the discussion, logs, etc to see what might be the
Thanks, kg

On Tue, Apr 4, 2017 at 4:54 AM, Adam Heavens <
adam.heavens at falconelectric.co.uk> wrote:

> Hello,
> Looking for a little help, I am trying to install mir-kiosk on Ubuntu core
> running on a Raspberry Pi3, however I can't get the black window and cursor
> to start. I pretty sure it is the Raspberry Pi build as I can get it to
> work in a VM using these instructions
> https://developer.ubuntu.com/en/snappy/guides/mir-snaps/
> After reading the archives of this mailing list I have tried updating all
> snaps to Edge and re-installed but always get the same error.
> "Mir returned: Failed to connect to server socket: No such file or
> directory"
> Screenshot of syslog below
> [cid:image001.png at 01D2AD31.CBDE9350]
> [cid:image002.png at 01D2AD31.CBDE9350]
> Any help or guidance appreciated
> Thanks
> Adam
> --
> Snapcraft mailing list
> Snapcraft at lists.snapcraft.io
> Modify settings or unsubscribe at: https://lists.ubuntu.com/
> mailman/listinfo/snapcraft

More information about the Snapcraft mailing list