Problems trying to create a snap package for bioinformatics tools

Jamie Strandboge jamie at
Tue Oct 25 13:25:56 UTC 2016

On Mon, 2016-10-24 at 16:54 +0200, Didier Roche wrote:
> Le 24/10/2016 à 16:13, Gordon Ball a écrit :
> > 
> > Hello
> Hey Gordon,
> > 
> > I have been trying to create a snap package for the `cufflinks` [1]
> > biofinformatics tools. These are packaged for debian/ubuntu, but the
> > package is not built for xenial due to issues with boost 1.56-1.59. [2]
> Nice way to ship latest to xenial users! Thanks for this 
> > 
> > I tried building a snap package (see snapcraft.yaml below - just a
> > simple `stage-packages` build) on yakkety in order to bundle the
> > relevant dependencies and then install it on xenial, but I ran into the
> > following issues:
> > 
> > 
> >  * Trying to run any of the binaries gives the error
> > 
> >     failed to create user data directory. errmsg: Permission denied
> > 
> >    This is presumably related to #1592696, but in this case $HOME is on
> > an NFS mount under /mnt. Probably an uncommon case, but this probably
> > isn't the only such configuration.
> Interesting use case 
> In that case, I would say open a separate bugs for it. The issue can be
> encryptfs, or profiles not supporting $HOME set to /mnt (or something
> else to /home/*). It worthes tracking it!
This has come up before in this bug:

See comments:

in particular for how to configure apparmor for an alternate home location. Note
that snapd could be adjusted to manage the home apparmor tunable (which is why
the bug is still open).


> Also, I don't see any reason why we are preventing underscores in app
> name (nothing in yaml prevents key to be underscores). I don't link such
> command name in general, but I don't see any good reasons for this.
> Gustavo, is that deliberate?
Yes because the udev security backend uses underscores as delimiters for udev
tags. The allowed character set for udev tagging is extremely limited and we
must continue to use underscores for this. That said, since it is only the
command name that has underscores, it is possible (though more brittle) to
adjust things to only split on the first two underscores (eg, it would still be
possible to parse 'snap_name_command_name' so long as 'name' isn't allowed to
have underscores). A change like this would require more investigation and
approval from Gustavo.

Jamie Strandboge             |

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the Snapcraft mailing list