Shared content example - ubuntu-app-platform

Timo Jyrinki timo.jyrinki at
Sat Nov 26 19:18:39 UTC 2016

Hi Enwei,

I think you might be running into bugs, given how in this and other threads
people are bumping into bugs with the content interface.

I haven't tried write, but I did have ubuntu-app-platform using paths at
first and that did work fine, aside from the mounting bug discussed in this
thread. However there are very subtle details like you shouldn't use / at
the end - see I filed.

I can't test now since I'm on a long leave and only using my Ubuntu Phone.


keskiviikko 23. marraskuuta 2016 Enwei Zhang <enwei.zhang at>
> Hello,
> Thanks Timo for the good example.
> While I tried to write two snaps(server to share paths to client) that
use content interface to share files, I found "write" slot doesn't work.
> The code snippet from server side snapcraft.yaml
> slots:
> test-share:
> content: test-content-server
> interface: content
> write:
> - .
> When accessing from client side snap, it shows "permission denied".
> Also, I found only "." path can work, other path like below "./bin"
cannot work. When you run "snap interfaces", below slot "test-share" will
not show up.
> slots:
> test-share:
> content: test-content-server
> interface: content
> read:
> - ./bin
> Are these bugs or my misunderstanding? I tested on both 2.16 and 2.17
> Thanks for your answer.
> Br
> Enwei
>> --
>> Snapcraft mailing list
>> Snapcraft at
>> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Snapcraft mailing list