snappy: Command not found [solved]

peter.chen at peter.chen at
Tue Jun 7 13:35:37 UTC 2016

Hi, All
Thanks for your help, The problem which the uboot can't load the kernel has been fixed, and the snappy ubuntu 16  is ported to the Lemaker Guitar successfully now.
The problem mainly related to uboot and i have committed the patch to our github at ,
Hope this can help others.

Best Regards

Peter Chen

LeMaker Developer Team

Making Innovation Easy. 
support at (Technical Support) 
product at (Product Distribution) 
From: Oliver Grawert
Date: 2016-06-07 17:17
To: Woodrow Shen
CC: peter.chen at; snapcraft
Subject: Re: Re: snappy: Command not found
Am Dienstag, den 07.06.2016, 11:17 +0800 schrieb Woodrow Shen:
> boot_fix.bin is workaround to make booting normally without active
> boot flag.
> I suspect above uboot error messages is missing the value
> of ${snappy_kernel} when uboot needs to load the files, like:
> loadkernel=fatload mmc ${mmcdev}:${mmcpart} ${kernel_addr}
> ${snappy_kernel}/${kernel_file}
exactly, u-d-f creates an image and then installs the kernel snap
inside. after it installed it knows the exact path to the binaries,
which is /snap/$packagename/$revision and this path is set to
snappy_kernel= inside the uboot.env file. every time you upgrade or
roll-back the kernel this variable is adjusted alongside, if a boot
fails the value automatically falls back to the last revision that
worked and it reboots.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Snapcraft mailing list