[ubuntu/saucy-proposed] alsa-lib 1.0.27.2-1ubuntu1 (Accepted)

Luke Yelavich themuso at ubuntu.com
Fri Jul 26 01:05:14 UTC 2013


alsa-lib (1.0.27.2-1ubuntu1) saucy; urgency=low

  [ Luke Yelavich ]
  * Merge from debian unstable.  Remaining changes:
    - debian/control: Add Vcs-Bzr URI
    - Show hints for non-standard devices that lack configuration files
    - Add a compile/run autopkg test
    - Add config file for the tegra alc5632 chip found in the AC100 netbook.

alsa-lib (1.0.27.2-1) unstable; urgency=low

  * New upstream release.
  * Drop fix_return_value_of_snd_pcm_rewind.patch and fix_docs_typo.patch:
    applied upstream.

alsa-lib (1.0.27.1-2) unstable; urgency=low

  * Add fix_return_value_of_snd_pcm_rewind.patch: this fixes several
    problems with plugins, and fixes a Pulseaudio crash.
  * Add tests_lm_ftbfs.patch: add -lm where needed, to fix two build
    failures in tests (closes: #709900).

alsa-lib (1.0.27.1-1) unstable; urgency=low

  * New upstream release.
  * Drop all patches: all merged upstream.
  * Add fix_docs_typo.patch: fix typo in constant name (closes: #675960).
  * Only install the card data and alsa.conf for the udeb. The smixer and
    ucm configuration files are useless in debian-installer.

alsa-lib (1.0.27-4) unstable; urgency=low

  [ Jordi Mallach ]
  * Add double_dlclose.patch: from Git; avoid a double call of dlclose()
    in dlobj caching code.
  * inline_headers.patch: from Git; use __inline__ for exported headers.
    Fixes builds for packages using C90.
  * Add ucm_profiles.patch: from Git; include UCM profiles from Chromebook
    and Ubuntu.
  * Introduce a new binary libasound2-data, and install all driver
    configuration files and UCM profiles there.

  [ Cyril Brulebois ]
  * Fix dh_makeshlibs call:
    - Reintroduce --add-udeb=libasound2-udeb (broken dependencies for debs
      otherwise: #708353 for alsa-utils-udeb).
    - Restore -V'libasound2 (>= 1.0.27)' as well, since symbols files don't
      work for udebs. Regular debs will keep on picking the most relaxed
      dependency, as usual. Closes: #708357.

alsa-lib (1.0.27-3) unstable; urgency=low

  * Brown paper bag: use override_dh_auto_build-indep and
    dh_auto_install-indep to handle doxygen docs, to correctly avoid
    building docs on binary-arch-only builds. Thanks to Adam Conrad
    for the suggestion.
  * Pass --disable-static to configure.

alsa-lib (1.0.27-2) unstable; urgency=low

  * Upload to unstable.
  * Move doxygen to Build-Depends-Indep (closes: #706800).

alsa-lib (1.0.27-1) experimental; urgency=low

  * New upstream release.
  * Drop sys_types_include.patch: fixed upstream.
  * Update libasound2.symbols with new API additions.
  * Mark libasound2-dbg Multi-Arch: same, so it is coinstallable.
  * Disable silent rules.
  * Bump Standards-Version to 3.9.4, with no further changes.

alsa-lib (1.0.26-1) experimental; urgency=low

  [ Elimar Riesebieter ]
  * Add sys_types_include.patch: Explicitly include <sys/types.h>, Thanks to
    Adam Conrad. (closes: #700230)

  [ Jordi Mallach ]
  * New upstream release.
  * It is with great pleasure that we drop the lib32asound binary package
    and all the unmanageable cruft that accompanied it (closes: #614242).
  * Rewrite debian/rules using dh.
  * Pass --list-missing to dh_install.
  * Install smixer objects, but avoid installing the python component to
    avoid an extra libpython dep on libasound2. If anyone requests it,
    we might reconsider in the future.
  * Drop htcl_remove_useless_assert.patch, applied upstream.
  * Drop libasound2.{postinst,postrm}: it was code to handle an upgrade
    case from 1999. Likewise for libasound2-dev.postinst.
  * Drop pointless dependency on libc6-dev.
  * Remove old and unused dmix example.
  * Stop symlinking doc dirs for libasound2-dev and -dbg. The amount of
    disk space saved is negligible.
  * Use default compression for source package.

Date: Fri, 26 Jul 2013 10:54:32 +1000
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/saucy/+source/alsa-lib/1.0.27.2-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 26 Jul 2013 10:54:32 +1000
Source: alsa-lib
Binary: libasound2 libasound2-dev libasound2-dbg libasound2-data libasound2-udeb libasound2-doc
Architecture: source
Version: 1.0.27.2-1ubuntu1
Distribution: saucy
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Description: 
 libasound2 - shared library for ALSA applications
 libasound2-data - Configuration files and profiles for ALSA drivers
 libasound2-dbg - debugging symbols for libasound2
 libasound2-dev - shared library for ALSA applications -- development files
 libasound2-doc - documentation for user-space ALSA application programming
 libasound2-udeb - shared library for ALSA applications (udeb) (udeb)
Closes: 614242 675960 700230 706800 708357 709900
Changes: 
 alsa-lib (1.0.27.2-1ubuntu1) saucy; urgency=low
 .
   [ Luke Yelavich ]
   * Merge from debian unstable.  Remaining changes:
     - debian/control: Add Vcs-Bzr URI
     - Show hints for non-standard devices that lack configuration files
     - Add a compile/run autopkg test
     - Add config file for the tegra alc5632 chip found in the AC100 netbook.
 .
 alsa-lib (1.0.27.2-1) unstable; urgency=low
 .
   * New upstream release.
   * Drop fix_return_value_of_snd_pcm_rewind.patch and fix_docs_typo.patch:
     applied upstream.
 .
 alsa-lib (1.0.27.1-2) unstable; urgency=low
 .
   * Add fix_return_value_of_snd_pcm_rewind.patch: this fixes several
     problems with plugins, and fixes a Pulseaudio crash.
   * Add tests_lm_ftbfs.patch: add -lm where needed, to fix two build
     failures in tests (closes: #709900).
 .
 alsa-lib (1.0.27.1-1) unstable; urgency=low
 .
   * New upstream release.
   * Drop all patches: all merged upstream.
   * Add fix_docs_typo.patch: fix typo in constant name (closes: #675960).
   * Only install the card data and alsa.conf for the udeb. The smixer and
     ucm configuration files are useless in debian-installer.
 .
 alsa-lib (1.0.27-4) unstable; urgency=low
 .
   [ Jordi Mallach ]
   * Add double_dlclose.patch: from Git; avoid a double call of dlclose()
     in dlobj caching code.
   * inline_headers.patch: from Git; use __inline__ for exported headers.
     Fixes builds for packages using C90.
   * Add ucm_profiles.patch: from Git; include UCM profiles from Chromebook
     and Ubuntu.
   * Introduce a new binary libasound2-data, and install all driver
     configuration files and UCM profiles there.
 .
   [ Cyril Brulebois ]
   * Fix dh_makeshlibs call:
     - Reintroduce --add-udeb=libasound2-udeb (broken dependencies for debs
       otherwise: #708353 for alsa-utils-udeb).
     - Restore -V'libasound2 (>= 1.0.27)' as well, since symbols files don't
       work for udebs. Regular debs will keep on picking the most relaxed
       dependency, as usual. Closes: #708357.
 .
 alsa-lib (1.0.27-3) unstable; urgency=low
 .
   * Brown paper bag: use override_dh_auto_build-indep and
     dh_auto_install-indep to handle doxygen docs, to correctly avoid
     building docs on binary-arch-only builds. Thanks to Adam Conrad
     for the suggestion.
   * Pass --disable-static to configure.
 .
 alsa-lib (1.0.27-2) unstable; urgency=low
 .
   * Upload to unstable.
   * Move doxygen to Build-Depends-Indep (closes: #706800).
 .
 alsa-lib (1.0.27-1) experimental; urgency=low
 .
   * New upstream release.
   * Drop sys_types_include.patch: fixed upstream.
   * Update libasound2.symbols with new API additions.
   * Mark libasound2-dbg Multi-Arch: same, so it is coinstallable.
   * Disable silent rules.
   * Bump Standards-Version to 3.9.4, with no further changes.
 .
 alsa-lib (1.0.26-1) experimental; urgency=low
 .
   [ Elimar Riesebieter ]
   * Add sys_types_include.patch: Explicitly include <sys/types.h>, Thanks to
     Adam Conrad. (closes: #700230)
 .
   [ Jordi Mallach ]
   * New upstream release.
   * It is with great pleasure that we drop the lib32asound binary package
     and all the unmanageable cruft that accompanied it (closes: #614242).
   * Rewrite debian/rules using dh.
   * Pass --list-missing to dh_install.
   * Install smixer objects, but avoid installing the python component to
     avoid an extra libpython dep on libasound2. If anyone requests it,
     we might reconsider in the future.
   * Drop htcl_remove_useless_assert.patch, applied upstream.
   * Drop libasound2.{postinst,postrm}: it was code to handle an upgrade
     case from 1999. Likewise for libasound2-dev.postinst.
   * Drop pointless dependency on libc6-dev.
   * Remove old and unused dmix example.
   * Stop symlinking doc dirs for libasound2-dev and -dbg. The amount of
     disk space saved is negligible.
   * Use default compression for source package.
Checksums-Sha1: 
 e25776cb2551a19f5774b8d9bd4693533ae9a775 1884 alsa-lib_1.0.27.2-1ubuntu1.dsc
 9cd50f4b5f07d5e7213dd1277b8673e677804cf8 906844 alsa-lib_1.0.27.2.orig.tar.bz2
 01edf2d88ead02f4507e4bcda6e135b83b47e012 60810 alsa-lib_1.0.27.2-1ubuntu1.debian.tar.gz
Checksums-Sha256: 
 4ecf6383551082793821fe7c8b537f0271f615f62f36175abdd0a5046c4278d1 1884 alsa-lib_1.0.27.2-1ubuntu1.dsc
 690ed393e7efd4fc7e3a2d2cda5449298ca0c895197e5914e350882012430d19 906844 alsa-lib_1.0.27.2.orig.tar.bz2
 7c33215a53449d3debd73024769b790a157e3527d543e0046cf3134ecf5b24af 60810 alsa-lib_1.0.27.2-1ubuntu1.debian.tar.gz
Files: 
 d6dc7f71825a89316bb6a17775915296 1884 libs optional alsa-lib_1.0.27.2-1ubuntu1.dsc
 69129a7c37697f81ac092335e9fa452b 906844 libs optional alsa-lib_1.0.27.2.orig.tar.bz2
 307714a6cc19e094bc9a249135d70aea 60810 libs optional alsa-lib_1.0.27.2-1ubuntu1.debian.tar.gz
Original-Maintainer: Debian ALSA Maintainers <pkg-alsa-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlHxyR8ACgkQjVefwtBjIM5sjgCeMtuczdHdWJZ7I7QaS3v2Op2b
T8wAn2tO9VNZ7ojdNkL35AqX0noCv6iC
=uHup
-----END PGP SIGNATURE-----


More information about the Saucy-changes mailing list