[ubuntu/resolute-proposed] linux-nvidia 7.0.0-1015.15 (Accepted)
Timo Aaltonen
tjaalton at ubuntu.com
Thu Jul 2 15:02:19 UTC 2026
linux-nvidia (7.0.0-1015.15) resolute; urgency=medium
* resolute/linux-nvidia: 7.0.0-1015.15 -proposed tracker (LP: #2158924)
* Packaging resync (LP: #1786013)
- [Packaging] debian.nvidia/dkms-versions -- update from kernel-versions
(adhoc/d2026.06.30)
* Backport mana support for PF device 0x00C1 (LP: #2156821)
- net: mana: Add support for PF device 0x00C1
* Backport the arm-smmu-v3 kdump adoption series (LP: #2156531)
- iommu/arm-smmu-v3: Add arm_smmu_kdump_adopt_strtab() for kdump
- iommu/arm-smmu-v3: Implement is_attach_deferred() for kdump
- iommu/arm-smmu-v3: Do not enable EVTQ/PRIQ interrupts in kdump kernel
- iommu/arm-smmu-v3: Skip EVTQ/PRIQ setup in kdump kernel
- iommu/arm-smmu-v3: Retain CR0_SMMUEN during kdump device reset
- iommu/arm-smmu-v3: Skip RMR bypass for kdump adoption
- iommu/arm-smmu-v3: Detect ARM_SMMU_OPT_KDUMP_ADOPT in probe()
* Backport: fuse: back uncached readdir buffers with pages (LP: #2156632)
- fuse: back uncached readdir buffers with pages
* Backport: Mitigate TLBI errata on various Arm CPUs (LP: #2156557) // CVE-
Enable ARM64_ERRATUM_4118414 to mitigate 2025-10263 on NVIDIA platforms.
- NVIDIA: [Config] Enable ARM64_ERRATUM_4118414
* Backport: Mitigate TLBI errata on various Arm CPUs (LP: #2156557) //
CVE-2025-10263. The existing ARM64_ERRATUM_4118414 handling already uses
- arm64: errata: Mitigate TLBI errata on NVIDIA Olympus CPU
* Backport: Mitigate TLBI errata on various Arm CPUs (LP: #2156557)
- arm64: cputype: Add C1-Ultra definitions
- arm64: cputype: Add C1-Premium definitions
- arm64: errata: Mitigate TLBI errata on various Arm CPUs
* linux-nvidia: Port MPAM Functionality into Kernel (LP: #2154527)
- arm_mpam: Ensure in_reset_state is false after applying configuration
- arm_mpam: Reset when feature configuration bit unset
- arm64/sysreg: Add MPAMSM_EL1 register
- KVM: arm64: Preserve host MPAM configuration when changing traps
- KVM: arm64: Make MPAMSM_EL1 accesses UNDEF
- arm64: mpam: Context switch the MPAM registers
- arm64: mpam: Re-initialise MPAM regs when CPU comes online
- arm64: mpam: Drop the CONFIG_EXPERT restriction
- arm64: mpam: Advertise the CPUs MPAM limits to the driver
- arm64: mpam: Add cpu_pm notifier to restore MPAM sysregs
- arm64: mpam: Initialise and context switch the MPAMSM_EL1 register
- arm64: mpam: Add helpers to change a task or cpu's MPAM PARTID/PMG
values
- arm_mpam: resctrl: Add boilerplate cpuhp and domain allocation
- arm_mpam: resctrl: Pick the caches we will use as resctrl resources
- arm_mpam: resctrl: Implement resctrl_arch_reset_all_ctrls()
- arm_mpam: resctrl: Add resctrl_arch_get_config()
- arm_mpam: resctrl: Implement helpers to update configuration
- arm_mpam: resctrl: Add plumbing against arm64 task and cpu hooks
- arm_mpam: resctrl: Add CDP emulation
- arm_mpam: resctrl: Hide CDP emulation behind CONFIG_EXPERT
- arm_mpam: resctrl: Convert to/from MPAMs fixed-point formats
- arm_mpam: resctrl: Add rmid index helpers
- arm_mpam: resctrl: Wait for cacheinfo to be ready
- arm_mpam: resctrl: Add support for 'MB' resource
- arm_mpam: resctrl: Add kunit test for control format conversions
- arm_mpam: resctrl: Add monitor initialisation and domain boilerplate
- arm_mpam: resctrl: Add support for csu counters
- arm_mpam: resctrl: Allow resctrl to allocate monitors
- arm_mpam: resctrl: Add resctrl_arch_rmid_read()
- arm_mpam: resctrl: Update the rmid reallocation limit
- arm_mpam: resctrl: Add empty definitions for assorted resctrl functions
- ALSA: usb-audio: Replace hard-coded number with MAX_CHANNELS
- arm64: mpam: Select ARCH_HAS_CPU_RESCTRL
- arm_mpam: resctrl: Call resctrl_init() on platforms that can support
resctrl
- arm_mpam: Add quirk framework
- arm_mpam: Add workaround for T241-MPAM-1
- arm_mpam: Add workaround for T241-MPAM-4
- arm_mpam: Add workaround for T241-MPAM-6
- arm_mpam: Quirk CMN-650's CSU NRDY behaviour
- arm64: mpam: Add initial MPAM documentation
- fs/resctrl: Report invalid domain ID when parsing io_alloc_cbm
- fs/resctrl: Add "*" shorthand to set io_alloc CBM for all domains
- MAINTAINERS: Update resctrl entry
- fs/resctrl: Add missing return value descriptions
- arm_mpam: resctrl: Fix MBA CDP alloc_capable handling on unmount
- arm_mpam: resctrl: Fix the check for no monitor components found
- arm_mpam: resctrl: Make resctrl_mon_ctx_waiters static
- NVIDIA: SAUCE: Update annotations to set CONFIG_RESCTRL_FS
- NVIDIA: SAUCE: fs/resctrl: Tidy up the error path in
resctrl_mkdir_event_configs()
- NVIDIA: SAUCE: x86,fs/resctrl: Create 'event_filter' files read only if
they're not configurable
- NVIDIA: SAUCE: fs/resctrl: Disallow the software controller when MBM
counters are assignable
- NVIDIA: SAUCE: fs/resctrl: Add monitor property 'mbm_cntr_assign_fixed'
- NVIDIA: SAUCE: fs/resctrl: Continue counter allocation after failure
- NVIDIA: SAUCE: fs/resctrl: Document that automatic counter assignment is
best effort
- NVIDIA: SAUCE: fs/resctrl: Document tasks file behaviour for task id 0
and idle tasks
- NVIDIA: SAUCE: arm_mpam: resctrl: Pick classes for use as MBM counters
- NVIDIA: SAUCE: arm_mpam: resctrl: Pre-allocate assignable monitors
- NVIDIA: SAUCE: arm_mpam: resctrl: Add resctrl_arch_config_cntr() for
ABMC use
- NVIDIA: SAUCE: arm_mpam: resctrl: Add resctrl_arch_cntr_read() &
resctrl_arch_reset_cntr()
- NVIDIA: SAUCE: arm64: mpam: Add memory bandwidth usage (MBWU)
documentation
- NVIDIA: SAUCE: arm_mpam: Add resctrl_arch_round_bw()
- NVIDIA: SAUCE: fs/resctrl,x86/resctrl: Factor mba rounding to be per-
arch
- NVIDIA: SAUCE: x86/resctrl: Add stub to allow other architecture to
disable monitor overflow
- NVIDIA: SAUCE: arm_mpam: resctrl: Determine if any exposed counter can
overflow
- NVIDIA: SAUCE: fs/restrl: Allow the overflow handler to be disabled
- NVIDIA: SAUCE: arm_mpam: Allow cmax/cmin to be configured
- NVIDIA: SAUCE: arm_mpam: Rename mbw conversion to 'fract16' for code re-
use
- NVIDIA: SAUCE: fs/resctrl: Group all the MBA specific properties in a
separate struct
- NVIDIA: SAUCE: fs/resctrl: Abstract duplicate domain test to a helper
- NVIDIA: SAUCE: fs/resctrl: Move MBA supported check to parse_line()
instead of parse_bw()
- NVIDIA: SAUCE: fs/resctrl: Rename resctrl_get_default_ctrl() to include
resource
- NVIDIA: SAUCE: fs/resctrl: Add a schema format to the schema, allowing
it to be different
- NVIDIA: SAUCE: fs/resctrl: Add specific schema types for 'range'
- NVIDIA: SAUCE: x86/resctrl: Move over to specifying MBA control formats
- NVIDIA: SAUCE: fs/resctrl: Add additional files for percentage and
bitmap controls
- NVIDIA: SAUCE: fs/resctrl: Add fflags_from_schema() for files based on
schema format
- NVIDIA: SAUCE: fs/resctrl: Expose the schema format to user-space
- NVIDIA: SAUCE: fs/resctrl: Add L2 and L3 'MAX' resource schema
- NVIDIA: SAUCE: arm_mpam: resctrl: Add the glue code to convert to/from
cmax
- NVIDIA: SAUCE: resctrl/mpam: reset RIS by applying explicit default
config
- NVIDIA: SAUCE: arm_mpam: Fix MPAMCFG_MBW_PBM register setting
* fs/ntfs3: fix mount failure on 64K page-size kernels (LP: #2155467)
- fs/ntfs3: fix mount failure on 64K page-size kernels
* linux-nvidia: backport FF-A partition info descriptor size fix
(LP: #2154045)
- firmware: arm_ffa: Bound PARTITION_INFO_GET_REGS copies
- firmware: arm_ffa: Honor partition info descriptor size
Date: 2026-07-01 19:15:12.082804+00:00
Changed-By: Jacob Martin <jacob.martin at canonical.com>
Signed-By: Andy Whitcroft <apw at canonical.com>
https://launchpad.net/ubuntu/+source/linux-nvidia/7.0.0-1015.15
-------------- next part --------------
Sorry, changesfile not available.
More information about the Resolute-changes
mailing list