[ubuntu/quantal] update-manager 1:0.163 (Accepted)

Colin Watson cjwatson at ubuntu.com
Thu Jun 14 00:20:24 UTC 2012


update-manager (1:0.163) quantal; urgency=low

  [ Colin Watson ]
  * Isolate tests from local configuration in
    /etc/update-manager/release-upgrades.d/.
  * Use Python attributes rather than GObject.get_data and GObject.set_data,
    which have been removed upstream (LP: #1009859).
  * Switch default view class to Gtk3 and replace python-gobject dependency
    with python-gi.
  * Port away from old-style apt.Package candidateFoo and installedFoo
    properties, preferring candidate.foo and installed.foo.  In a number of
    cases we have to check whether candidate/installed is non-None first.
  * Use apt_pkg.version_compare rather than apt_pkg.VersionCompare.
  * Use apt_pkg.uri_to_filename rather than apt_pkg.URItoFileName.
  * Use apt_pkg.TagFile (and related new-style API) rather than
    apt_pkg.ParseTagFile.
  * Use apt_pkg.PackageManager rather than apt_pkg.GetPackageManager.
  * Use apt_pkg.Acquire rather than apt_pkg.GetAcquire.
  * Use mark_foo/marked_foo rather than markFoo/markedFoo.
  * Use apt_pkg.ActionGroup rather than apt_pkg.GetPkgActionGroup.
  * Use apt_pkg.ProblemResolver rather than apt_pkg.GetPkgProblemResolver.
  * Use apt_pkg.read_config_file rather than apt_pkg.ReadConfigFile.
  * Use new spelling of apt_pkg.DepCache methods.
  * Rename several local cache methods to PEP-8 style to avoid showing up in
    the output of /usr/share/python-apt/migrate-0.8.py.
  * Use apt_pkg.size_to_str rather than apt_pkg.SizeToStr.
  * Use apt_pkg.PackageManager.get_archives rather than
    apt_pkg.PackageManager.GetArchives.
  * Use apt_pkg.Acquire.fetch_needed rather than
    apt_pkg.Acquire.FetchNeeded.
  * Use new spelling of apt_pkg.Package/Version/Dependency methods.
  * Use apt_pkg.pkgsystem_lock rather than apt_pkg.PkgSystemLock.
  * Use new spelling of apt_pkg dependency parsing methods.
  * Use new spelling of apt_pkg.SourceList methods.
  * Bump python-apt (build-)dependency to >= 0.8.0.
  * Add a scheme for excluding false positives from the pyflakes test, and
    enable it by default.
  * Rearrange the OptionParser workaround from 1:0.154.5 to work with Python
    3, using gettext or ugettext as appropriate.
  * Always pass bytes to hashlib.md5.update.
  * Fix DistUpgradeAptCdrom to account for gzip files being opened in binary
    mode.
  * Convert the last use of os.popen to subprocess.check_output, which makes
    it easier to read str rather than bytes.  (This requires Python 2.7.)
  * Decode bytes read from urlopened file objects.
  * UpdateManager/backend/InstallBackendSynaptic.py
    - Keep a reference to the data tuple passed to GObject.child_watch_add
      to avoid attempts to destroy it without a thread context
      (LP: #724687).
    - Open temporary synaptic selections file in text mode.
  * Define __bool__ rather than __nonzero__ method in Python 3.
  * sort(cmp=) and sorted(cmp=) no longer work in Python 3.  Use appropriate
    key= arguments instead.
  * Fix ResourceWarning while reading /proc/mounts.
  * Make update-manager-kde depend on psmisc, for killall.
  * DistUpgrade/DistUpgradeView.py:
    - Use floor division in FuzzyTimeToStr.
  * DistUpgrade/DistUpgradeViewText.py:
    - Flush stdout after printing confirmation message, since it doesn't
      have a trailing newline.
  * Use the appropriate Unicode gettext methods in both Python 2 and 3, and
    drop lots of Python-3-unfriendly Unicode mangling as a result.
  * DistUpgrade/DistUpgradeViewKDE.py:
    - Open the terminal log in binary mode.
  * data/do-release-upgrade.8:
    - Provide a more useful NAME section.
  * DistUpgrade/DistUpgradeCache.py:
    - Tolerate SyntaxError from attempting to import NvidiaDetector, until
      such time as a complete ubuntu-drivers-common Python 3 port is in the
      archive.
  * Switch #! lines over to python3, apart from dist-upgrader which needs to
    stay as Python 2 for a while longer (and have some special arrangement
    for running with Python 3 for upgrades from >= quantal).
  * Run tests under both Python 2 and 3.

  [ Adam Conrad ]
  * Merge branch from Michael Terry to drop auto-upgrade-tester
    from update-manager and move it into its own source package

  [ Barry Warsaw ]
  * Begin refactoring of Computer Janitor code by renaming and
    re-situating all of it to janitor/plugincore.  This will eventually be
    removed from here into its own separate branch.
  * Merge the temporary Python 3 sprint branch back into trunk, and close
    the py3 sprint branch.
  * Moved UpdateManager/backend and UpdateManager/UnitySupport.py to the
    python*-update-manager packages for apturl.

  [ Michael Vogt ]
  * UpdateManager/GtkProgress.py:
    - fix python-apt 0.8 API crash

  [ Stéphane Graber ]
  * Drop fdsend as it's not used and doesn't build with python3.
  * Make update-manager-core a binary all packages (everything is python).
  * Split update-manager-core into python-update-manager,
    python3-update-manager and update-manager-core.
  * Build-depend and depend on python-apt >= 0.8.5~ as we need proper
    python3 support.

  [ Steve Langasek ]
  * tests/test_country_mirror.py: the test suite shouldn't fail if $LANG
    isn't set in the environment.
  * update-manager is now using python3 as an interpreter, so fix these up
    to actually be python3 packages.

Date: Thu, 14 Jun 2012 00:57:42 +0100
Changed-By: Colin Watson <cjwatson at ubuntu.com>
Maintainer: Michael Vogt <michael.vogt at ubuntu.com>
https://launchpad.net/ubuntu/quantal/+source/update-manager/1:0.163
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Thu, 14 Jun 2012 00:57:42 +0100
Source: update-manager
Binary: update-manager-core python-update-manager python3-update-manager update-manager update-manager-text update-manager-kde
Architecture: source
Version: 1:0.163
Distribution: quantal
Urgency: low
Maintainer: Michael Vogt <michael.vogt at ubuntu.com>
Changed-By: Colin Watson <cjwatson at ubuntu.com>
Description: 
 python-update-manager - python 2.x module for update-manager
 python3-update-manager - python 3.x module for update-manager
 update-manager - GNOME application that manages apt updates
 update-manager-core - manage release upgrades
 update-manager-kde - Support modules for Muon Notifier and Apper
 update-manager-text - Text application that manages apt updates
Launchpad-Bugs-Fixed: 724687 1009859
Changes: 
 update-manager (1:0.163) quantal; urgency=low
 .
   [ Colin Watson ]
   * Isolate tests from local configuration in
     /etc/update-manager/release-upgrades.d/.
   * Use Python attributes rather than GObject.get_data and GObject.set_data,
     which have been removed upstream (LP: #1009859).
   * Switch default view class to Gtk3 and replace python-gobject dependency
     with python-gi.
   * Port away from old-style apt.Package candidateFoo and installedFoo
     properties, preferring candidate.foo and installed.foo.  In a number of
     cases we have to check whether candidate/installed is non-None first.
   * Use apt_pkg.version_compare rather than apt_pkg.VersionCompare.
   * Use apt_pkg.uri_to_filename rather than apt_pkg.URItoFileName.
   * Use apt_pkg.TagFile (and related new-style API) rather than
     apt_pkg.ParseTagFile.
   * Use apt_pkg.PackageManager rather than apt_pkg.GetPackageManager.
   * Use apt_pkg.Acquire rather than apt_pkg.GetAcquire.
   * Use mark_foo/marked_foo rather than markFoo/markedFoo.
   * Use apt_pkg.ActionGroup rather than apt_pkg.GetPkgActionGroup.
   * Use apt_pkg.ProblemResolver rather than apt_pkg.GetPkgProblemResolver.
   * Use apt_pkg.read_config_file rather than apt_pkg.ReadConfigFile.
   * Use new spelling of apt_pkg.DepCache methods.
   * Rename several local cache methods to PEP-8 style to avoid showing up in
     the output of /usr/share/python-apt/migrate-0.8.py.
   * Use apt_pkg.size_to_str rather than apt_pkg.SizeToStr.
   * Use apt_pkg.PackageManager.get_archives rather than
     apt_pkg.PackageManager.GetArchives.
   * Use apt_pkg.Acquire.fetch_needed rather than
     apt_pkg.Acquire.FetchNeeded.
   * Use new spelling of apt_pkg.Package/Version/Dependency methods.
   * Use apt_pkg.pkgsystem_lock rather than apt_pkg.PkgSystemLock.
   * Use new spelling of apt_pkg dependency parsing methods.
   * Use new spelling of apt_pkg.SourceList methods.
   * Bump python-apt (build-)dependency to >= 0.8.0.
   * Add a scheme for excluding false positives from the pyflakes test, and
     enable it by default.
   * Rearrange the OptionParser workaround from 1:0.154.5 to work with Python
     3, using gettext or ugettext as appropriate.
   * Always pass bytes to hashlib.md5.update.
   * Fix DistUpgradeAptCdrom to account for gzip files being opened in binary
     mode.
   * Convert the last use of os.popen to subprocess.check_output, which makes
     it easier to read str rather than bytes.  (This requires Python 2.7.)
   * Decode bytes read from urlopened file objects.
   * UpdateManager/backend/InstallBackendSynaptic.py
     - Keep a reference to the data tuple passed to GObject.child_watch_add
       to avoid attempts to destroy it without a thread context
       (LP: #724687).
     - Open temporary synaptic selections file in text mode.
   * Define __bool__ rather than __nonzero__ method in Python 3.
   * sort(cmp=) and sorted(cmp=) no longer work in Python 3.  Use appropriate
     key= arguments instead.
   * Fix ResourceWarning while reading /proc/mounts.
   * Make update-manager-kde depend on psmisc, for killall.
   * DistUpgrade/DistUpgradeView.py:
     - Use floor division in FuzzyTimeToStr.
   * DistUpgrade/DistUpgradeViewText.py:
     - Flush stdout after printing confirmation message, since it doesn't
       have a trailing newline.
   * Use the appropriate Unicode gettext methods in both Python 2 and 3, and
     drop lots of Python-3-unfriendly Unicode mangling as a result.
   * DistUpgrade/DistUpgradeViewKDE.py:
     - Open the terminal log in binary mode.
   * data/do-release-upgrade.8:
     - Provide a more useful NAME section.
   * DistUpgrade/DistUpgradeCache.py:
     - Tolerate SyntaxError from attempting to import NvidiaDetector, until
       such time as a complete ubuntu-drivers-common Python 3 port is in the
       archive.
   * Switch #! lines over to python3, apart from dist-upgrader which needs to
     stay as Python 2 for a while longer (and have some special arrangement
     for running with Python 3 for upgrades from >= quantal).
   * Run tests under both Python 2 and 3.
 .
   [ Adam Conrad ]
   * Merge branch from Michael Terry to drop auto-upgrade-tester
     from update-manager and move it into its own source package
 .
   [ Barry Warsaw ]
   * Begin refactoring of Computer Janitor code by renaming and
     re-situating all of it to janitor/plugincore.  This will eventually be
     removed from here into its own separate branch.
   * Merge the temporary Python 3 sprint branch back into trunk, and close
     the py3 sprint branch.
   * Moved UpdateManager/backend and UpdateManager/UnitySupport.py to the
     python*-update-manager packages for apturl.
 .
   [ Michael Vogt ]
   * UpdateManager/GtkProgress.py:
     - fix python-apt 0.8 API crash
 .
   [ Stéphane Graber ]
   * Drop fdsend as it's not used and doesn't build with python3.
   * Make update-manager-core a binary all packages (everything is python).
   * Split update-manager-core into python-update-manager,
     python3-update-manager and update-manager-core.
   * Build-depend and depend on python-apt >= 0.8.5~ as we need proper
     python3 support.
 .
   [ Steve Langasek ]
   * tests/test_country_mirror.py: the test suite shouldn't fail if $LANG
     isn't set in the environment.
   * update-manager is now using python3 as an interpreter, so fix these up
     to actually be python3 packages.
Checksums-Sha1: 
 3af910e792ec23bbad3b64bf229937481eb81c28 2140 update-manager_0.163.dsc
 c315c3bbe44e4caad2c93638e7ceac08ba2f2a90 3247743 update-manager_0.163.tar.gz
Checksums-Sha256: 
 12b74f64ee10cdae156f45dd24348632353491934a2dbb6b15bd9ec7896856be 2140 update-manager_0.163.dsc
 97f49964e7780328ca596d7c908ae94dd9706b82e69b76066b4092c601d2f80d 3247743 update-manager_0.163.tar.gz
Files: 
 37af270edd3e4bae5cd90ca6a1ae2bcf 2140 gnome optional update-manager_0.163.dsc
 348ec587d9876ef14afa9b721355d6b6 3247743 gnome optional update-manager_0.163.tar.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Colin Watson <cjwatson at debian.org> -- Debian developer

iQIVAwUBT9kq/jk1h9l9hlALAQh7Yw//dIcabfwptzeV2C0Fp7epBMsjcAgRZuKs
QHMyjB9VmECSADmlCP+Bv3J9Cnu9gKfNyMS9hFyOqSs99K+Cogl6u5kHxaYwBsHP
h8DhtaxxGp6/mEWGmVs22In/8dPCOi3AsjWywm7RegIMAkuv6iECU1INSv8gjkSi
DK3Cf1pqUI22s/3HlxAT9LnhCk46AfPaO6TbTfdzgVtvIOjhDnT2gnHayvJUAsrT
HgI9cSgkp4/ofzykRBNZMd6Orfwes7BW8Kqver0KsSSMNHsyJxTelRVGWybPoctH
OrbhaqqESR2+UiKBOZd5Xueb5UA0l2bKPpslyaWhK0Ki16wPMTxCIdnUjqu3YeWS
wQoPu4s9xDNPRVFzlZ9Se1RHY477EBJDoy7svUNI4oVo6bFuWi5Bf629lSma8+Lg
Sj9wYoKZnVFy+Iq7PsD/9XbUQOCMbxvqu5wTS9i/ALe9Umwk7E/aZp7HQTOCMo/c
EVOb3L71hyiK5s3HIJTMeQc7pdzFMwkG16AnJY5Wt+/zwXhK2fcrg3uHtZhrtCWP
kjANFkdWqOyEzu+ZbJYzFox17ToulvpDYC0EA0glkK5dAvcWdwO4xLhP2Iy9mmIi
oUlrGrf1lkTy5k00x6KMCATZWBllyh64lJbXeS6duApAElGw6NuoqxKPb/QrpvrA
YShuWMqr8Mo=
=alwU
-----END PGP SIGNATURE-----


More information about the Quantal-changes mailing list