[ubuntu/quantal] sssd 1.8.4-1ubuntu1 (Accepted)

Timo Aaltonen tjaalton at ubuntu.com
Mon Jun 4 07:10:24 UTC 2012


sssd (1.8.4-1ubuntu1) quantal; urgency=low

  * Merge from Debian unstable, remaining changes:
    - control, rules: Drop libsemanage-dev from build-depends, it's not
      in main. Configure --with-semanage=no.

sssd (1.8.4-1) unstable; urgency=low

  * New upstream bugfix release 1.8.2.
    - Several fixes to case-insensitive domain functions
    - Fix for GSSAPI binds when the keytab contains unrelated
      principals
    - Fixed several segfaults
    - Workarounds added for LDAP servers with unreadable RootDSE
    - SSH knownhostproxy will no longer enter an infinite loop
      preventing login
    - The provided SYSV init script now starts SSSD earlier at startup
      and stops it later during shutdown
    - Assorted minor fixes for issues discovered by static analysis
      tools
  * New upstream bugfix release 1.8.3.
    - Numerous manpage and translation updates
    - LDAP: Handle situations where the RootDSE isn't available anonymously
    - LDAP: Fix regression for users using non-standard LDAP attributes for
      user information
  * New upstream bugfix release 1.8.4. (LP: #981125, #985031)
    - Fix a bug causing AD servers not to fail over properly when the KDC
      on the primary server is down
    - Fix an endianness bug on big-endian systems when looking up services
    - Fix a segfault dealing with nested groups (LP: #981125)
    - Make the nowait cache updates work for netgroups
    - Fix a regression that broke domains with use_fully_qualified_names = True
      (LP: #985031)
  * control: Move the dependency of libsasl2-modules-gssapi-mit to
    Recommends.
  * control: sssd works with Heimdal gssapi modules too, add
    libsasl2-modules-gssapi-mit as an option for the Recommends.
    (LP: #966146)
  * libpam-sss.pam-auth-update:
    - Drop the dependency to 128, since pam_sss should always be below
      pam_unix. (LP: #957486)
    - Drop 'use_authtok' from the password stack, since it only works when
      pam_cracklib is installed. This will allow password changes on the
      default install.
  * sssd.postrm: Try to remove /etc/sssd only if it exists.
    (Closes: #666226)
  * Add disabled by default Apparmor profile (LP: #933342)
    - debian/sssd.upstart.in: load the profile during pre-start
    - add debian/apparmor-profile, install to /etc/apparmor.d
    - debian/rules: use dh_apparmor to install profile before sssd is
      restarted
    - debian/control: sssd Suggests apparmor (>= 2.3)
    - debian/control: Add dh-apparmor to build-depends
    - debian/sssd.preinst: disable profile on clean install or upgrades
      from earlier than when we shipped the profile
  * rules: Mangle the date stamp on pam_sss.8 so that the compressed file is
    identical across all archs. (Closes: #670019)
  * control: Add build-depends on libnl-dev to enable Netlink support.
  * control: Add build-depends on libkeyutil-dev to enable support for
    kernel keyring manipulation.
  * sssd.logrotate: Rotate logs weekly, keep four previous rotations.
    (Closes: #672984)
  * sssd.upstart.in: Delete an invisible control character from the pre-start
    script. (LP: #1003845)

Date: Mon, 04 Jun 2012 09:51:20 +0300
Changed-By: Timo Aaltonen <tjaalton at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel at lists.ubuntu.com>
https://launchpad.net/ubuntu/quantal/+source/sssd/1.8.4-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 04 Jun 2012 09:51:20 +0300
Source: sssd
Binary: sssd sssd-tools libnss-sss libpam-sss libipa-hbac0 libipa-hbac-dev libsss-sudo0 libsss-sudo-dev python-libipa-hbac python-sss
Architecture: source
Version: 1.8.4-1ubuntu1
Distribution: quantal
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel at lists.ubuntu.com>
Changed-By: Timo Aaltonen <tjaalton at ubuntu.com>
Description: 
 libipa-hbac-dev - FreeIPA HBAC Evaluator library
 libipa-hbac0 - FreeIPA HBAC Evaluator library
 libnss-sss - Nss library for the System Security Services Daemon
 libpam-sss - Pam module for the System Security Services Daemon
 libsss-sudo-dev - Communicator library for sudo -- development files
 libsss-sudo0 - Communicator library for sudo
 python-libipa-hbac - Python bindings for the FreeIPA HBAC Evaluator library
 python-sss - Python module for the System Security Services Daemon
 sssd       - System Security Services Daemon
 sssd-tools - System Security Services Daemon -- tools
Closes: 666226 670019 672984
Launchpad-Bugs-Fixed: 933342 957486 966146 981125 985031 1003845
Changes: 
 sssd (1.8.4-1ubuntu1) quantal; urgency=low
 .
   * Merge from Debian unstable, remaining changes:
     - control, rules: Drop libsemanage-dev from build-depends, it's not
       in main. Configure --with-semanage=no.
 .
 sssd (1.8.4-1) unstable; urgency=low
 .
   * New upstream bugfix release 1.8.2.
     - Several fixes to case-insensitive domain functions
     - Fix for GSSAPI binds when the keytab contains unrelated
       principals
     - Fixed several segfaults
     - Workarounds added for LDAP servers with unreadable RootDSE
     - SSH knownhostproxy will no longer enter an infinite loop
       preventing login
     - The provided SYSV init script now starts SSSD earlier at startup
       and stops it later during shutdown
     - Assorted minor fixes for issues discovered by static analysis
       tools
   * New upstream bugfix release 1.8.3.
     - Numerous manpage and translation updates
     - LDAP: Handle situations where the RootDSE isn't available anonymously
     - LDAP: Fix regression for users using non-standard LDAP attributes for
       user information
   * New upstream bugfix release 1.8.4. (LP: #981125, #985031)
     - Fix a bug causing AD servers not to fail over properly when the KDC
       on the primary server is down
     - Fix an endianness bug on big-endian systems when looking up services
     - Fix a segfault dealing with nested groups (LP: #981125)
     - Make the nowait cache updates work for netgroups
     - Fix a regression that broke domains with use_fully_qualified_names = True
       (LP: #985031)
   * control: Move the dependency of libsasl2-modules-gssapi-mit to
     Recommends.
   * control: sssd works with Heimdal gssapi modules too, add
     libsasl2-modules-gssapi-mit as an option for the Recommends.
     (LP: #966146)
   * libpam-sss.pam-auth-update:
     - Drop the dependency to 128, since pam_sss should always be below
       pam_unix. (LP: #957486)
     - Drop 'use_authtok' from the password stack, since it only works when
       pam_cracklib is installed. This will allow password changes on the
       default install.
   * sssd.postrm: Try to remove /etc/sssd only if it exists.
     (Closes: #666226)
   * Add disabled by default Apparmor profile (LP: #933342)
     - debian/sssd.upstart.in: load the profile during pre-start
     - add debian/apparmor-profile, install to /etc/apparmor.d
     - debian/rules: use dh_apparmor to install profile before sssd is
       restarted
     - debian/control: sssd Suggests apparmor (>= 2.3)
     - debian/control: Add dh-apparmor to build-depends
     - debian/sssd.preinst: disable profile on clean install or upgrades
       from earlier than when we shipped the profile
   * rules: Mangle the date stamp on pam_sss.8 so that the compressed file is
     identical across all archs. (Closes: #670019)
   * control: Add build-depends on libnl-dev to enable Netlink support.
   * control: Add build-depends on libkeyutil-dev to enable support for
     kernel keyring manipulation.
   * sssd.logrotate: Rotate logs weekly, keep four previous rotations.
     (Closes: #672984)
   * sssd.upstart.in: Delete an invisible control character from the pre-start
     script. (LP: #1003845)
Checksums-Sha1: 
 9d0b55538c54e8bac3f2a20c412cd6f95e157fd4 2811 sssd_1.8.4-1ubuntu1.dsc
 0ce53f121db741c1baaa11f645b9a83ee7b369f4 2161696 sssd_1.8.4.orig.tar.gz
 b7237288bfc59d60f2abd040073bf51d9e98372a 26267 sssd_1.8.4-1ubuntu1.diff.gz
Checksums-Sha256: 
 7305c57610178e7cd20d3445dc466313ddd6d130513b35427eaf0fd0a89bc3b8 2811 sssd_1.8.4-1ubuntu1.dsc
 d20845928c91fd66fadc404967089b21b6b64801b1288c789812be51521476a2 2161696 sssd_1.8.4.orig.tar.gz
 3ce2cb5939745668ba7d62c300f2869dcefafb0fe5bd78dee762c735464d0da4 26267 sssd_1.8.4-1ubuntu1.diff.gz
Files: 
 40e94b37cd4889c64eb728074bdacc92 2811 utils extra sssd_1.8.4-1ubuntu1.dsc
 196cc355f74a1a431f9bd5dcd2c6cc41 2161696 utils extra sssd_1.8.4.orig.tar.gz
 9362b47a762130a7605783f253f8b8f0 26267 utils extra sssd_1.8.4-1ubuntu1.diff.gz
Original-Maintainer: Debian SSSD Team <pkg-sssd-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBAgAGBQJPzF5eAAoJEMtwMWWoiYTc9SMP/38sILC2eEkZvw9Ws6rWxuMH
9hTmc5v8i4rc49vHNdU8WL7zi6u19r15wkbL56c09lw2ceHg8CzdHzhxl1hIGbqL
nmTijZPGiwaM2qBa7NR8AQYcRWnXIwsdWDf7rOXnJLnjTU/eB4C3VRG48ph90jrM
QVMQ6FRO6BOaCd9KiELpxrmJzeQv951NwetWXdECfCRTtxz71iDxX/BGUJz38j2z
7UxY1cCleWTzUnAMlNteN8zkodMtRLVUTW00U3CHAIk1CoBfQ7y+uJRg5EW79tUk
hcUkUrGm8+ziQD6ImRFaMRQ5nqAD+dRQ4CTvHPMNJImtnx8dUrUrVlzvhMvI2mRs
ELg5iE37KQAfDWEJxMZI6/YDfeBtUOWtoGEyNbd5w2vEPYnRyoFEw4Vbkmn5zvtk
ZSaIY9mVRxTb0NbJwKdD4InFpPIhopZmSTpWm4lTpZoFxgL6D4SMrZqMrfTrmNoL
g1phGT2zNiEvHg2fly4j3HNRWBZyDFmU/bCNG2MjV0R+uD7hUnapmbM34za7jCxI
d6HS2fxdMKsQCeQnph7a1r/FjzBrtLeg5GinbQC4bSaYzMQeg9tuA9UJdWopdC7E
1aHrg+9pmHrBF/0AZZx4GBrQifxWhZegwPjKr8vhTjkxt6t/LDHzt79BgihY2x7F
/PWIY1v6gzKzgozNewTr
=11DH
-----END PGP SIGNATURE-----


More information about the Quantal-changes mailing list