[ubuntu/precise-security] cpio 2.11-7ubuntu3.2 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Mon Feb 22 18:00:27 UTC 2016


cpio (2.11-7ubuntu3.2) precise-security; urgency=medium

  * SECURITY UPDATE: file overwrite via symlink attack
    - debian/patches/CVE-2015-1197.patch: don't write files over symlinks
      unless --extract-over-symlinks is used in doc/cpio.1, src/copyin.c,
      src/extern.h, src/global.c, src/main.c.
    - CVE-2015-1197
  * SECURITY UPDATE: out-of-bounds write
    - debian/patches/CVE-2016-2037.patch: make sure there is at least two
      bytes available in src/copyin.c, added comment to src/util.c.
    - CVE-2016-2037
  * debian/patches/fix-symlink-test.patch: fix date-sensitive test.

Date: 2016-02-18 16:07:18.293272+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/cpio/2.11-7ubuntu3.2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Precise-changes mailing list