[ubuntu/precise] php5 5.3.10-1ubuntu1 (Accepted)

Clint Byrum clint at ubuntu.com
Thu Feb 16 11:25:25 UTC 2012


php5 (5.3.10-1ubuntu1) precise; urgency=low

  * Merge from Debian testing.  Remaining changes:
    - d/control: build-depend on mysql 5.5 instead of 5.1 for running tests.
    - d/setup-mysql.sh: modify to work with mysql 5.5 differences
    - debian/rules: export DEB_HOST_MULTIARCH properly.
    - Only build php5-sqlite for sqlite3, dropping the obsolete sqlite2.
    - Add build-dependency on lemon, which we now need.
    - Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
    - Dropped libcurl-dev not in the archive.
    - debian/control: replace build-depends on mysql-server with
      mysql-server-core-5.5 and mysql-client-5.5 to avoid upstart and
      mysql-server-5.5 postinst confusion with starting up multiple
      mysqlds listening on the same port.
    - Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions
      already in universe.
    - Suggest php5-suhosin rather than recommends.
    - Dropped libonig-dev and libqgdbm since its in universe. (libonig MIR
      has been declined due to an inactive upstream. So this is probably
      a permanent change).
    - modulelist: Drop imap, interbase, sybase, and mcrypt.
    - debian/rules:
      * Dropped building of mcrypt, imap, and interbase.
      * Install apport hook for php5.
      * stop mysql instance on clean just in case we failed in tests
    - debian/control: Recommend php5-dev for php-pear.
  * Dropped Changes:
    - d/patches/CVE-2011-4566.patch: Applied upstream
    - debian/rules: --enable-pcntl for cgi as well. (Applied in Debian)
  * d/rules: enable Suhosin patch with PHP5_SUHOSIN=yes
  * d/NEWS: add note explaining that SUHOSIN *is* enabled in the Ubuntu
    package.
  * d/rules: Simplify apache config settings since we never build
    interbase or firebird.

php5 (5.3.10-1) unstable; urgency=high

  [ Raphael Geissert ]
  * Remove myself from uploaders
  * Randomly choose the mysql server's port

  [ Ondřej Surý ]
  * Fix use_embedded_timezonedb.patch in custom builds (Courtesy of
    Dominic Scheirlinck) (Closes: #652599)
  * Fix typo in firebird2.1-dev build dependency
  * Update gbp.conf for 5.3.x branch
  * Imported Upstream version 5.3.10
    + CVE-2012-0830: Fixed arbitrary remote code execution vulnerability
      reported by Stefan Esser.

php5 (5.3.9-6) unstable; urgency=low

  * Build MySQL extensions with Native Driver as an alternative
    (Closes: #576412)
  * Set default mysql socket location to /var/run/mysqld/mysqld.sock
  * Move php5-sqlite postinst code to postinst.extra
  * Cherry-pick patches from Fedora:
    + Fix mysqlnd socket location fix
    + Define _GNU_SOURCE in the configure.in
    + Typing fixes in dba extension
    + Don't add RPATH to extensions
  * Add missing check for dpkg-maintscript-helper in sqlite preinst
    and postrm
  * Add code to specify priority of modules to load mysqlnd.so before
    mysql.so and mysqli.so in php5-mysqlnd package
  * Alter version in rm_conffile call to 5.3.9~ to handle all possible
    versions due binNMUs (Closes: #656495)
  * Add more condition when to remove empty postinst script

php5 (5.3.9-5) unstable; urgency=low

  * Use DEB_HOST_ARCH, not DEB_HOST_ARCH_OS to check where to build
    firebird module (Closes: #645401)
  * Add back firebird2.5-dev and firebird2.1-dev to allow backports
  * Disable tests on hurd-i386 for now, because it FTBFS
  * Don't fail if suhosin is not enabled (Closes: #657808)

php5 (5.3.9-4) unstable; urgency=low

  * Remove suhosin patch from description and add short NEWS about
    disabling Suhosin patch (Closes: #657697)
  * Re-enable firebird extension build on armhf and powerpcspe
    (Closes: #657691)

php5 (5.3.9-3) unstable; urgency=low

  * Don't build firebird extension on hurd, m68k, hppa, ppc64, armhf and
    powerpcspe (Closes: #651070)
  * Avoid ptrace hungs when building on hurd
  * Check for dpkg-maintscript-helper existence instead of hard dpkg
    dependency to allow backported packaged on older (Ubuntu lucid)
    systems
  * Remove Suhosin patch, but add PHP5_SUHOSIN=no/yes option to
    debian/rules
  * Update patches after suhosin.patch removal and update suhosin.patch to
    cleanly apply as a last patch in the series
  * Replace firebird2.[15]-dev (transitional) dependencies with
    firebird-dev
  * More Firebird adjustments, don't build the extension on more ports,
    where firebird-dev is not available

php5 (5.3.9-2) unstable; urgency=low

  * Handle sqlite.so removal (remove conffile) (Closes: #656495)
  * Add Breaks: roundcube-sqlite since we no longer ship sqlite.so

php5 (5.3.9-1) unstable; urgency=low

  * Remove obsolete sqlite(2) module from php5-sqlite
  * Use correct signals in php5-fpm init script (Closes: #645934)
  * Imported Upstream version 5.3.9
  * Adapt debian/patches to 5.3.9 release

Date: Thu, 16 Feb 2012 03:17:18 -0800
Changed-By: Clint Byrum <clint at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/precise/+source/php5/5.3.10-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 16 Feb 2012 03:17:18 -0800
Source: php5
Binary: php5 php5-common libapache2-mod-php5 libapache2-mod-php5filter php5-cgi php5-cli php5-fpm php5-dev php5-dbg php-pear php5-curl php5-enchant php5-gd php5-gmp php5-intl php5-ldap php5-mysql php5-mysqlnd php5-odbc php5-pgsql php5-pspell php5-recode php5-snmp php5-sqlite php5-sybase php5-tidy php5-xmlrpc php5-xsl
Architecture: source
Version: 5.3.10-1ubuntu1
Distribution: precise
Urgency: high
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Clint Byrum <clint at ubuntu.com>
Description: 
 libapache2-mod-php5 - server-side, HTML-embedded scripting language (Apache 2 module)
 libapache2-mod-php5filter - server-side, HTML-embedded scripting language (apache 2 filter mo
 php-pear   - PEAR - PHP Extension and Application Repository
 php5       - server-side, HTML-embedded scripting language (metapackage)
 php5-cgi   - server-side, HTML-embedded scripting language (CGI binary)
 php5-cli   - command-line interpreter for the php5 scripting language
 php5-common - Common files for packages built from the php5 source
 php5-curl  - CURL module for php5
 php5-dbg   - Debug symbols for PHP5
 php5-dev   - Files for PHP5 module development
 php5-enchant - Enchant module for php5
 php5-fpm   - server-side, HTML-embedded scripting language (FPM-CGI binary)
 php5-gd    - GD module for php5
 php5-gmp   - GMP module for php5
 php5-intl  - internationalisation module for php5
 php5-ldap  - LDAP module for php5
 php5-mysql - MySQL module for php5
 php5-mysqlnd - MySQL module for php5 (Native Driver)
 php5-odbc  - ODBC module for php5
 php5-pgsql - PostgreSQL module for php5
 php5-pspell - pspell module for php5
 php5-recode - recode module for php5
 php5-snmp  - SNMP module for php5
 php5-sqlite - SQLite module for php5
 php5-sybase - Sybase / MS SQL Server module for php5
 php5-tidy  - tidy module for php5
 php5-xmlrpc - XML-RPC module for php5
 php5-xsl   - XSL module for php5
Closes: 576412 645401 645934 651070 652599 656495 657691 657697 657808
Changes: 
 php5 (5.3.10-1ubuntu1) precise; urgency=low
 .
   * Merge from Debian testing.  Remaining changes:
     - d/control: build-depend on mysql 5.5 instead of 5.1 for running tests.
     - d/setup-mysql.sh: modify to work with mysql 5.5 differences
     - debian/rules: export DEB_HOST_MULTIARCH properly.
     - Only build php5-sqlite for sqlite3, dropping the obsolete sqlite2.
     - Add build-dependency on lemon, which we now need.
     - Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
     - Dropped libcurl-dev not in the archive.
     - debian/control: replace build-depends on mysql-server with
       mysql-server-core-5.5 and mysql-client-5.5 to avoid upstart and
       mysql-server-5.5 postinst confusion with starting up multiple
       mysqlds listening on the same port.
     - Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions
       already in universe.
     - Suggest php5-suhosin rather than recommends.
     - Dropped libonig-dev and libqgdbm since its in universe. (libonig MIR
       has been declined due to an inactive upstream. So this is probably
       a permanent change).
     - modulelist: Drop imap, interbase, sybase, and mcrypt.
     - debian/rules:
       * Dropped building of mcrypt, imap, and interbase.
       * Install apport hook for php5.
       * stop mysql instance on clean just in case we failed in tests
     - debian/control: Recommend php5-dev for php-pear.
   * Dropped Changes:
     - d/patches/CVE-2011-4566.patch: Applied upstream
     - debian/rules: --enable-pcntl for cgi as well. (Applied in Debian)
   * d/rules: enable Suhosin patch with PHP5_SUHOSIN=yes
   * d/NEWS: add note explaining that SUHOSIN *is* enabled in the Ubuntu
     package.
   * d/rules: Simplify apache config settings since we never build
     interbase or firebird.
 .
 php5 (5.3.10-1) unstable; urgency=high
 .
   [ Raphael Geissert ]
   * Remove myself from uploaders
   * Randomly choose the mysql server's port
 .
   [ Ondřej Surý ]
   * Fix use_embedded_timezonedb.patch in custom builds (Courtesy of
     Dominic Scheirlinck) (Closes: #652599)
   * Fix typo in firebird2.1-dev build dependency
   * Update gbp.conf for 5.3.x branch
   * Imported Upstream version 5.3.10
     + CVE-2012-0830: Fixed arbitrary remote code execution vulnerability
       reported by Stefan Esser.
 .
 php5 (5.3.9-6) unstable; urgency=low
 .
   * Build MySQL extensions with Native Driver as an alternative
     (Closes: #576412)
   * Set default mysql socket location to /var/run/mysqld/mysqld.sock
   * Move php5-sqlite postinst code to postinst.extra
   * Cherry-pick patches from Fedora:
     + Fix mysqlnd socket location fix
     + Define _GNU_SOURCE in the configure.in
     + Typing fixes in dba extension
     + Don't add RPATH to extensions
   * Add missing check for dpkg-maintscript-helper in sqlite preinst
     and postrm
   * Add code to specify priority of modules to load mysqlnd.so before
     mysql.so and mysqli.so in php5-mysqlnd package
   * Alter version in rm_conffile call to 5.3.9~ to handle all possible
     versions due binNMUs (Closes: #656495)
   * Add more condition when to remove empty postinst script
 .
 php5 (5.3.9-5) unstable; urgency=low
 .
   * Use DEB_HOST_ARCH, not DEB_HOST_ARCH_OS to check where to build
     firebird module (Closes: #645401)
   * Add back firebird2.5-dev and firebird2.1-dev to allow backports
   * Disable tests on hurd-i386 for now, because it FTBFS
   * Don't fail if suhosin is not enabled (Closes: #657808)
 .
 php5 (5.3.9-4) unstable; urgency=low
 .
   * Remove suhosin patch from description and add short NEWS about
     disabling Suhosin patch (Closes: #657697)
   * Re-enable firebird extension build on armhf and powerpcspe
     (Closes: #657691)
 .
 php5 (5.3.9-3) unstable; urgency=low
 .
   * Don't build firebird extension on hurd, m68k, hppa, ppc64, armhf and
     powerpcspe (Closes: #651070)
   * Avoid ptrace hungs when building on hurd
   * Check for dpkg-maintscript-helper existence instead of hard dpkg
     dependency to allow backported packaged on older (Ubuntu lucid)
     systems
   * Remove Suhosin patch, but add PHP5_SUHOSIN=no/yes option to
     debian/rules
   * Update patches after suhosin.patch removal and update suhosin.patch to
     cleanly apply as a last patch in the series
   * Replace firebird2.[15]-dev (transitional) dependencies with
     firebird-dev
   * More Firebird adjustments, don't build the extension on more ports,
     where firebird-dev is not available
 .
 php5 (5.3.9-2) unstable; urgency=low
 .
   * Handle sqlite.so removal (remove conffile) (Closes: #656495)
   * Add Breaks: roundcube-sqlite since we no longer ship sqlite.so
 .
 php5 (5.3.9-1) unstable; urgency=low
 .
   * Remove obsolete sqlite(2) module from php5-sqlite
   * Use correct signals in php5-fpm init script (Closes: #645934)
   * Imported Upstream version 5.3.9
   * Adapt debian/patches to 5.3.9 release
Checksums-Sha1: 
 a2a3cbae07a29921ef63cb41641f575eb7582805 3716 php5_5.3.10-1ubuntu1.dsc
 e36b75b6193ad593377a9ff5bad8945136a4d57b 15390163 php5_5.3.10.orig.tar.gz
 472e6ae929a46339cb99eeef1b98a8240c80b657 327961 php5_5.3.10-1ubuntu1.diff.gz
Checksums-Sha256: 
 1882539702fe2e8cb89acf19cb11a9b94fe4ecc62a7ce7fbaf5b1181a099332e 3716 php5_5.3.10-1ubuntu1.dsc
 ee26ff003eaeaefb649735980d9ef1ffad3ea8c2836e6ad520de598da225eaab 15390163 php5_5.3.10.orig.tar.gz
 662cab5be2d985326679eaebdf81905398695c56ba549a59c38a8f141c824fdf 327961 php5_5.3.10-1ubuntu1.diff.gz
Files: 
 6da3ef91e088d3ac2b59b6564db68865 3716 php optional php5_5.3.10-1ubuntu1.dsc
 2b3d2d0ff22175685978fb6a5cbcdc13 15390163 php optional php5_5.3.10.orig.tar.gz
 14a153e4e80022d387e81460d93e54d4 327961 php optional php5_5.3.10-1ubuntu1.diff.gz
Original-Maintainer: Debian PHP Maintainers <pkg-php-maint at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAEBAgAGBQJPPOarAAoJEFOMB2b0vLOOGSsH/jx8ufKhDHP8gs050ldq+Oip
2fZWvpn+rmTj0RqrwqzGuWfJwCmurShC9VJZX2GdJkpG+r8MkM6XHQ02UxckDtsK
8nEm+vicSJP1RWOwirHfSvipqrpPjP0OBgMFk9XA8wepV04xJwGDW2MgzFJsxV3q
IL2eEqrvgM/lQkSivaRKRwkI7slXFEXJsuTfmHYEV2BqZIM3LJFh7FnHOaWeglZq
IPMp0/uMKPsk4nmwzhSeNdavXVaSNLKATbf60p6XofnPfPc9vrR3d0WNwVZJDE8B
NXK/2qWkfAYc9qUKVKts/nRSuv/p3x4PjlpjsTPEVSmLZEV54wC8FD/zGgv95jk=
=DURL
-----END PGP SIGNATURE-----


More information about the Precise-changes mailing list