[ubuntu/precise] cdbs 0.4.99ubuntu1 (Accepted)

Martin Pitt martin.pitt at ubuntu.com
Thu Oct 13 17:26:01 UTC 2011


cdbs (0.4.99ubuntu1) precise; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - 1/rules/utils.mk.in: add some text before listing missing file to make
      it easier to see from the build log (LP #509249, Debian #565771)
    - 1/class/gnome.mk.in: Call dh_translations.
    - test/testsuite_functions: Set NO_PKG_MANGLE so that tests do not fail
      with pkgstriptranslations installed. (Ubuntu specific)
    - 1/rules/debhelper.mk.in: Call dh_scour. debian/control.in: Add scour
      build and binary dependency (build dep for test suite).
    - 1/class/python-distutils.mk.in, 1/class/python-module.mk.in: Add
      --prefix support for pysupport by DEB_PYTHON_PREFIX_ARG (LP #625581)

cdbs (0.4.99) unstable; urgency=low

  * Fix suppress accidental build-dependency on ourself.
  * Relax autoresolving for utils.mk to build-depend unversioned on
    devscripts: Needed version 2.10.7 satisfied even in oldstable.
  * Stop suppressing copyright-check. Build-depend on devscripts.
  * Update copyright file:
    + Fix typo in license shortname.
  * Add lintian override for build-dependency on python-dev (needed for
    regression tests).
  * Bump debhelper compatibility level to 7.

cdbs (0.4.98) unstable; urgency=low

  * Fix (properly this time) support for *-any and any-* archs in
    list-packages script:
    + Sync with debhelper 7.3.16+.
    + Stop depending on libdpkg-perl.
    Closes: bug#641658, #641678.
  * Stop depending on debhelper (needed only to avoid older versions
    than 5.0.30, which is satisfied even in oldstable).
    See bug#405413.
  * Update copyright file:
    + Extend copyright for scripts/list-packages.
    + Fix include verbatim Expat(-like) license.
    + Fix use exceptions (not separate licenses).
    + Rename some license shortnames to better indicate being derived.
    + Shorten license comments.
    + Wrap licenses at 72 chars.

cdbs (0.4.97) unstable; urgency=low

  * Fix treat DEB_BUILD_OPTIONS as whole word (use filter not
    findstring) in perl-build.mk.
  * Fix support for *-any and any-* archs in list-packages script.
    Closes: Bug#616501, 637282. Thanks to Emilio Pozuelo Monfort,
    Nobuhiro Iwamatsu and José Manuel Santamaría Lema for helping out,
    and to Aurelien Jarno for an elegant fix.
  * Improve dependency autoresolving for debhelper.mk:
    + Build-depend unversioned when satisfied even in unstable.
    + Tie build-dependency directly to debian/compat and DH_COMPAT, to
      support debhelper 8 and newer.
    Closes: bug#641253. Thanks to Geoffrey Thomas.
  * Introduce DEB_PYTHON_DISTUTILS_SRCDIR to allow mixing
    python-distutils.mk with e.g. autotools.mk using different source
    roots.
    Closes: bug#504346. Thanks to Sune Vuorela.
  * Fix invoke python packaging helper twice(!) as documented, when
    using new dh_python2/dh_python2 and private modules.
  * Deprecate DEB_PYTHON_PRIVATE_MODULES_DIRS. Use *_DEFAULT, *_ALL or
    *_<package> variants instead.
  * Tighten autoresolved build-dependency on cdbs when using either
    DEB_PYTHON_PRIVATE_MODULES_DIRS* or DEB_DH_PYTHONHELPER_ARGS*.

cdbs (0.4.96) unstable; urgency=low

  * Fix cdbs_expand_curvar expansion to use VAR_pkg (not VAR_DEFAULT)
    when VAR_pkg is explicitly set to empty string.
    Closes: bug#629156. Thanks to Michael Biebl.

cdbs (0.4.95) unstable; urgency=low

  * Introduce new variables DEB_DH_PYTHONHELPER_ARGS_{DEFAULT,ALL,pkg}.
  * Tighten build-dependency on cdbs when used.
    Closes: bug#633820. Thanks to Felipe Sateler.
  * Fix tighten build-dependency on cdbs when binary package relation
    variables is used.

Date: Tue, 11 Oct 2011 07:32:03 +0200
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/precise/+source/cdbs/0.4.99ubuntu1
-------------- next part --------------
Format: 1.8
Date: Tue, 11 Oct 2011 07:32:03 +0200
Source: cdbs
Binary: cdbs
Architecture: source
Version: 0.4.99ubuntu1
Distribution: precise
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Description: 
 cdbs       - common build system for Debian packages
Closes: 504346 616501 629156 633820 637282 641253 641658 641678
Changes: 
 cdbs (0.4.99ubuntu1) precise; urgency=low
 .
   * Merge with Debian unstable. Remaining Ubuntu changes:
     - 1/rules/utils.mk.in: add some text before listing missing file to make
       it easier to see from the build log (LP #509249, Debian #565771)
     - 1/class/gnome.mk.in: Call dh_translations.
     - test/testsuite_functions: Set NO_PKG_MANGLE so that tests do not fail
       with pkgstriptranslations installed. (Ubuntu specific)
     - 1/rules/debhelper.mk.in: Call dh_scour. debian/control.in: Add scour
       build and binary dependency (build dep for test suite).
     - 1/class/python-distutils.mk.in, 1/class/python-module.mk.in: Add
       --prefix support for pysupport by DEB_PYTHON_PREFIX_ARG (LP #625581)
 .
 cdbs (0.4.99) unstable; urgency=low
 .
   * Fix suppress accidental build-dependency on ourself.
   * Relax autoresolving for utils.mk to build-depend unversioned on
     devscripts: Needed version 2.10.7 satisfied even in oldstable.
   * Stop suppressing copyright-check. Build-depend on devscripts.
   * Update copyright file:
     + Fix typo in license shortname.
   * Add lintian override for build-dependency on python-dev (needed for
     regression tests).
   * Bump debhelper compatibility level to 7.
 .
 cdbs (0.4.98) unstable; urgency=low
 .
   * Fix (properly this time) support for *-any and any-* archs in
     list-packages script:
     + Sync with debhelper 7.3.16+.
     + Stop depending on libdpkg-perl.
     Closes: bug#641658, #641678.
   * Stop depending on debhelper (needed only to avoid older versions
     than 5.0.30, which is satisfied even in oldstable).
     See bug#405413.
   * Update copyright file:
     + Extend copyright for scripts/list-packages.
     + Fix include verbatim Expat(-like) license.
     + Fix use exceptions (not separate licenses).
     + Rename some license shortnames to better indicate being derived.
     + Shorten license comments.
     + Wrap licenses at 72 chars.
 .
 cdbs (0.4.97) unstable; urgency=low
 .
   * Fix treat DEB_BUILD_OPTIONS as whole word (use filter not
     findstring) in perl-build.mk.
   * Fix support for *-any and any-* archs in list-packages script.
     Closes: Bug#616501, 637282. Thanks to Emilio Pozuelo Monfort,
     Nobuhiro Iwamatsu and José Manuel Santamaría Lema for helping out,
     and to Aurelien Jarno for an elegant fix.
   * Improve dependency autoresolving for debhelper.mk:
     + Build-depend unversioned when satisfied even in unstable.
     + Tie build-dependency directly to debian/compat and DH_COMPAT, to
       support debhelper 8 and newer.
     Closes: bug#641253. Thanks to Geoffrey Thomas.
   * Introduce DEB_PYTHON_DISTUTILS_SRCDIR to allow mixing
     python-distutils.mk with e.g. autotools.mk using different source
     roots.
     Closes: bug#504346. Thanks to Sune Vuorela.
   * Fix invoke python packaging helper twice(!) as documented, when
     using new dh_python2/dh_python2 and private modules.
   * Deprecate DEB_PYTHON_PRIVATE_MODULES_DIRS. Use *_DEFAULT, *_ALL or
     *_<package> variants instead.
   * Tighten autoresolved build-dependency on cdbs when using either
     DEB_PYTHON_PRIVATE_MODULES_DIRS* or DEB_DH_PYTHONHELPER_ARGS*.
 .
 cdbs (0.4.96) unstable; urgency=low
 .
   * Fix cdbs_expand_curvar expansion to use VAR_pkg (not VAR_DEFAULT)
     when VAR_pkg is explicitly set to empty string.
     Closes: bug#629156. Thanks to Michael Biebl.
 .
 cdbs (0.4.95) unstable; urgency=low
 .
   * Introduce new variables DEB_DH_PYTHONHELPER_ARGS_{DEFAULT,ALL,pkg}.
   * Tighten build-dependency on cdbs when used.
     Closes: bug#633820. Thanks to Felipe Sateler.
   * Fix tighten build-dependency on cdbs when binary package relation
     variables is used.
Checksums-Sha1: 
 fbd0b19dd24816ae91bf25cabe1e3feb16b0a81b 1948 cdbs_0.4.99ubuntu1.dsc
 a6f5ec89266b351f34b1e79de949500320efafed 271642 cdbs_0.4.99ubuntu1.tar.gz
Checksums-Sha256: 
 51ab5e73e8572da2f59aead5e8a862709aab27182a785a3f7831d0655f443c93 1948 cdbs_0.4.99ubuntu1.dsc
 e854bd1105e37856f4a10ecf72c565767dd32127e03366da93a21bdb49d4b982 271642 cdbs_0.4.99ubuntu1.tar.gz
Files: 
 814f73ccfc1005bdd50a6f449135dbf8 1948 devel optional cdbs_0.4.99ubuntu1.dsc
 2b1169463380f6ae94be2aabd7bf474a 271642 devel optional cdbs_0.4.99ubuntu1.tar.gz
Original-Maintainer: CDBS Hackers <build-common-hackers at lists.alioth.debian.org>


More information about the Precise-changes mailing list