[ubuntu/oneiric-updates] openjdk-6 6b24-1.11.3-1ubuntu0.11.10.1 (Accepted)

Micah Gersten launchpad at micahscomputing.com
Fri Jul 13 01:16:16 UTC 2012

openjdk-6 (6b24-1.11.3-1ubuntu0.11.10.1) oneiric-security; urgency=low

  * Backport OpenJDK 6b24/IcedTea 1.11.3 to oneiric.
  * debian/patches/java-access-bridge-security.patch: updated
  * debian/control.zero-jre: add powerpc arch back, to get empty
    transitional package
  * debian/rules: install README.Debian for openjdk-6-jre-zero to create
    empty transitional package and create package
  * debian/README.Debian: explain openjdk-6-jre-zero went away
  * regenerate debian/control
  * add back build depends on g++-4.5 for armel/armhf

openjdk-6 (6b24-1.11.3-1ubuntu0.12.04.1) precise-security; urgency=low

  * SECURITY UPDATE: update to IcedTea 6 1.11.3
    - Security fixes:
      - S7079902, CVE-2012-1711: Refine CORBA data models
      - S7110720: Issue with vm config file loadingIssue with vm
        config file loading
      - S7143606, CVE-2012-1717: File.createTempFile should be improved
        for temporary files created by the platform.
      - S7143614, CVE-2012-1716: SynthLookAndFeel stability improvement
      - S7143617, CVE-2012-1713: Improve fontmanager layout lookup
      - S7143851, CVE-2012-1719: Improve IIOP stub and tie generation
        in RMIC
      - S7143872, CVE-2012-1718: Improve certificate extension
      - S7145239: Finetune package definition restriction
      - S7152811, CVE-2012-1723: Issues in client compiler
      - S7157609, CVE-2012-1724: Issues with loop
      - S7160677: missing else in fix for 7152811
      - S7160757, CVE-2012-1725: Problem with hotspot/runtime_classfile
    - Bug fixes:
      - PR1018: JVM fails due to SEGV during rendering some Unicode
        characters (part of 6886358)
  * Changelog, Makefile.am, aclocal.m4,
    drop inline changes, applied upstream
  * debian/patches/atk-wrapper-security.patch: updated
  * Makefile.{am,in}: don't apply patches/jtreg-LastErrorString.patch as
    it causes the testsuite runner to fail.

openjdk-6 (6b24-1.11.1-4ubuntu3) precise-proposed; urgency=low

  * Do not apply patches/revert-6885123.patch. Closes: #638805. LP: #981037.
  * Move hotspot-7020521.patch and hotspot-7026307.patch to debian/patches
    and reapply (accidentally disabled).

openjdk-6 (6b24-1.11.1-4ubuntu2) precise; urgency=low

  * Use the /usr/bin path for the policytool desktop file. LP: #980205.

openjdk-6 (6b24-1.11.1-4ubuntu1) precise; urgency=low

  * Regenerate the control file.

openjdk-6 (6b24-1.11.1-4) unstable; urgency=low

  * Install desktop files again, using the common /usr/bin/java
    interpreter name. LP: #969322. Closes: #668213.
  * Build-depend on libpng-dev for newer releases. Closes: #662452.
  * Let dlopen handle finding the libpcsclite library. LP: #898689.
    Closes: #668356.
  * Build-depend on fonts-ipafont-mincho, fixing a build failure in the
    fontconfig compiler (find out why it breaks ...).
  * Build using gcc-4.7/gcj-4.7 for sid/wheezy.

openjdk-6 (6b24-1.11.1-3ubuntu4) precise; urgency=low

  * Don't install the binary fontconfig file.

openjdk-6 (6b24-1.11.1-3ubuntu3) precise; urgency=low

  * Revert the ARM inline math functions change, ony meant for a PPA build.

openjdk-6 (6b24-1.11.1-3ubuntu2) precise; urgency=low

  * Disable running the jdk tests.

openjdk-6 (6b24-1.11.1-3) unstable; urgency=low

  * Use NanumMyeongjo as the preferred korean font. LP: #792471.
    Closes: #655167.
  * Fix java path in jexec for multiarch builds.
  * Fix crash in java.net.NetworkInterface.getNetworkInterfaces() when
    ifr_ifindex exceeds 255. LP: #925218. S7078386.
  * Remove javaws and pluginappletviewer alternatives on upgrade from
    squeeze. Closes: #660604.
  * Use IPAfont as the preferred japanesse font. Closes: #646054.
  * Build using gcj on alpha and armel. Closes: #655750.
  * Drop build dependency on libxp-dev. Closes: #623667.

openjdk-6 (6b24-1.11.1-2ubuntu2) precise; urgency=low

  * Make sure that the nss.cfg doesn't mention any library path.
    LP: #939361, #939419.
  * Disable the accessibility wrapper, doesn't work yet. LP: #935296.
  * ARM: Inline math functions, where asm instructions exist (taken from
    the trunk).

openjdk-6 (6b24-1.11.1-2ubuntu1) precise; urgency=low

  * Regenerate the control file.

openjdk-6 (6b24-1.11.1-2) unstable; urgency=medium

  * Update from the IcedTea6-1.12 branch (20120222).
  * Build using gcc/gcj-4.4 on mips and sparc again.
  * Remove build dependency on libxp-dev.

openjdk-6 (6b24-1.11.1-1) unstable; urgency=medium

  * Build using gcj-4.4 on mips and mipsel again (raised on debian-mips).

openjdk-6 (6b24-1.11.1-0ubuntu1) precise; urgency=low

  * IcedTea 1.11.1 release.
  * Security fixes:
    - S7082299, CVE-2011-3571: Fix in AtomicReferenceArray.
    - S7088367, CVE-2011-3563: Fix issues in java sound.
    - S7110683, CVE-2012-0502: Issues with some KeyboardFocusManager method.
    - S7110687, CVE-2012-0503: Issues with TimeZone class.
    - S7110700, CVE-2012-0505: Enhance exception throwing mechanism
      in ObjectStreamClass.
    - S7110704, CVE-2012-0506: Issues with some method in corba.
    - S7112642, CVE-2012-0497: Incorrect checking for graphics rendering object.
    - S7118283, CVE-2012-0501: Better input parameter checking
      in zip file processing.
    - S7126960, CVE-2011-5035: (httpserver) Add property to limit number
      of request headers to the HTTP Server.
  * Backport fixes for S7066307, S7020521 from OpenJDK7 (Xerxes Rånby).

openjdk-6 (6b24-1.11-4) unstable; urgency=low

  * Build using gcj-4.6 on mips, mipsel, sparc, sparc64.

openjdk-6 (6b24-1.11-3) unstable; urgency=low

  * Make doc files multi-arch installable.
  * JB-archive.applications.in: Use /usr/bin/java by default. Maybe
    should be moved to the default-jdk package.

openjdk-6 (6b24-1.11-2ubuntu1) precise; urgency=low

  * Regenerate the control file.

openjdk-6 (6b24-1.11-2) unstable; urgency=low

  * Make upgrades from non-multiarch to multiarch builds more silent.
  * Fix order of grant decls in java.policy.
  * Default to zero again on ARM with the update ARM assembler interpreter.

openjdk-6 (6b24-1.11-1) unstable; urgency=low

  * Upload to unstable.

openjdk-6 (6b24-1.11-0ubuntu1) precise; urgency=low

  * IcedTea6 1.11 release.

  [ Luke Yelavich ]
  * Use java-atk-wrapper instead of java-access-bridge for accessibility.
    LP: #790240.

  [ Matthias Klose ]
  * nss.cfg: Remove nssLibraryDirectory property, rely on the system
    library path.
  * Make the java.policy file multi-arch installable. LP: #924096.
  * Don't install desktop and menu files for multiarch builds.
    Needs a better solution. Closes: #658321
  * Pass -n to gzip when compressing manpages to be Multi-Arch: same safe.
  * Don't install an alternative for the deprecated apt tool.
  * Make the upgrade from a non-multiarch installation location more
    robust; don't depend on version numbers, but check the path of the
    alternatives. LP: #887077.
  * Always use the internal copy of liblcms1; only OpenJDK 7 has the
    support to use a system liblcms2.
  * Build jamvm on powerpc.

openjdk-6 (6b24~pre4-1ubuntu1) precise; urgency=low

  * Disable the jtreg tests for JamVM on ARM, issues on the buildds.

openjdk-6 (6b24~pre4-1) unstable; urgency=low

  * Upload to unstable.

openjdk-6 (6b24~pre4-0ubuntu1) precise; urgency=low

  * Update from the IcedTea6-1.11 branch (20120120).
  * Disable shark builds, broken for this release.
  * Fix some lintian warnings.

openjdk-6 (6b24~pre3-0ubuntu1) precise; urgency=low

  * Update from the IcedTea6 branch (20120103).
  * Build shark using llvm-3.0.

openjdk-6 (6b24~pre2-1) unstable; urgency=low

  * Regenerate the control file.

openjdk-6 (6b24~pre2-0ubuntu2) precise; urgency=low

  * Build-depend on binutils-dev on armel and armhf.

openjdk-6 (6b24~pre2-0ubuntu1) precise; urgency=low

  * Update from the IcedTea6 branch (20111216).
  * Enable CACAO on armhf.
  * Fix build flags for cppInterpreter_arm.o.
  * openjdk-6-jre-lib: Mark as Multi-Arch: foreign.
  * Fix plugin name in jinfo file. Closes: #650928.

openjdk-6 (6b24~pre1-1) unstable; urgency=low

  * OpenJDK 6b24 release.
  * Update from the IcedTea6 branch (20111130).

openjdk-6 (6b23~pre11-1) unstable; urgency=high

  * Build with jpeg8. Closes: #644070.
  * Tighten inter-package dependencies for Debian builds. Closes: #641240.

Date: 2012-06-28 20:20:45.530334+00:00
Changed-By: Steve Beattie <sbeattie at ubuntu.com>
Signed-By: Micah Gersten <launchpad at micahscomputing.com>
-------------- next part --------------
Sorry, changesfile not available.

More information about the Oneiric-changes mailing list