[ubuntu/oneiric-security] libreoffice 1:3.4.4-0ubuntu1.2 (Accepted)

Jamie Strandboge jamie at ubuntu.com
Mon Jul 2 20:44:45 UTC 2012

libreoffice (1:3.4.4-0ubuntu1.2) oneiric-security; urgency=low

  * SECURITY UPDATE: fix integer overflows in graphic loading code
    - debian/patches/CVE-2012-1149.patch: adjust vcl/source/gdi/pngread.cxx to
      fail earlier on oversized images and properly verify chunks. Also adjust
      basebmp/source/bitmapdevice.cxx to to properly verify height and width.
      Properly verify width and height in
    - CVE-2012-1149
  * SECURITY UPDATE: fix integer overflow when processing Escher graphics
    records in PowerPoint documents
    - debian/patches/CVE-2012-2334.patch: properly verify record lengths in
      filter/source/msfilter/msdffimp.cxx and msdffimp.hxx
    - CVE-2012-2334

Date: 2012-06-20 22:05:33.852697+00:00
Changed-By: Jamie Strandboge <jamie at ubuntu.com>
-------------- next part --------------
Sorry, changesfile not available.

More information about the Oneiric-changes mailing list