[ubuntu/oneiric] pidgin 1:2.9.0-3ubuntu1 (Accepted)

Mathieu Trudel-Lapierre mathieu-tl at ubuntu.com
Fri Jul 29 14:50:24 UTC 2011


pidgin (1:2.9.0-3ubuntu1) oneiric; urgency=low

  * Merge with Debian; remaining changes: (LP: #802374)
    - debian/libpurple0.symbols: update symbols for epoch.
    - debian/patches/02_lpi.patch: add Launchpad integration support.
    - debian/patches/04_let_crasher_for_apport.patch: stop catching the SIGSEGV
      signal and let apport handle it.
    - debian/patches/05_default_to_irc_ubuntu_com.patch: set the default IRC
      server to irc.ubuntu.com.
    - debian/patches/10_docklet_default_off.patch: default behavior to have no
      notification area icon.
    - debian/patches/11_buddy_list_really_show.patch: the buddy list tries
      harder to appear.  This fixes some issues with it not appearing.
    - debian/patches/13_sounds_and_timers.patch: mute notification sounds for
      15 seconds at login time.
    - debian/patches/60_1024x600_gtk*.c.patch: add scrollbars into preferences
      and pounce dialogs
    - debian/prefs.xml: ship extra default settings for notifications, add
      the notification plugin by default and turn on logging by default.
    - debian/rules:
      - use autoreconf.
      - add translation domain for desktop file / update translations.
      - add launcher desktop file for indicator-messages.
    - debian/control:
      - add launchpad-integration, libtool, dh-autoreconf to Build-Depends.
      - drop pidgin-data Depends from libpurple0.
      - drop libpurple0 Depends from libpurple-bin.
      - add pidgin-libnotify as Recommends for pidgin binary.

pidgin (2.9.0-3) unstable; urgency=low

  * Oops, really enable hardening-wrapper

pidgin (2.9.0-2) unstable; urgency=low

  * Fix missing epoch in libgadu-dev build-depends (Closes: #630654 again)
  * Build-depend on fixed version of libgadu-dev that depends on libgnutls-dev
    (Closes: #631979)
  * Use hardening-wrapper (Closes: #632515)

pidgin (2.9.0-1) unstable; urgency=high

  * Imported Upstream version 2.9.0
    - Fixes denial-of-service vulnerability in buddy icon handling
      (CVE-2011-2485)
  * Re-enable GG and update libgadu-dev version

pidgin (2.8.0-2) unstable; urgency=low

  * Explicitly disable GG protocol since we don't have libgadu-dev 1.11.0 in
    Debian yet (Closes: #630654)

Date: Fri, 29 Jul 2011 10:45:37 -0400
Changed-By: Mathieu Trudel-Lapierre <mathieu-tl at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/oneiric/+source/pidgin/1:2.9.0-3ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 29 Jul 2011 10:45:37 -0400
Source: pidgin
Binary: libpurple0 pidgin pidgin-data pidgin-dev pidgin-dbg finch finch-dev libpurple-dev libpurple-bin
Architecture: source
Version: 1:2.9.0-3ubuntu1
Distribution: oneiric
Urgency: high
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Mathieu Trudel-Lapierre <mathieu-tl at ubuntu.com>
Description: 
 finch      - text-based multi-protocol instant messaging client
 finch-dev  - text-based multi-protocol instant messaging client - development
 libpurple-bin - multi-protocol instant messaging library - extra utilities
 libpurple-dev - multi-protocol instant messaging library - development files
 libpurple0 - multi-protocol instant messaging library
 pidgin     - graphical multi-protocol instant messaging client for X
 pidgin-data - multi-protocol instant messaging client - data files
 pidgin-dbg - Debugging symbols for Pidgin
 pidgin-dev - multi-protocol instant messaging client - development files
Closes: 630654 631979 632515
Launchpad-Bugs-Fixed: 802374
Changes: 
 pidgin (1:2.9.0-3ubuntu1) oneiric; urgency=low
 .
   * Merge with Debian; remaining changes: (LP: #802374)
     - debian/libpurple0.symbols: update symbols for epoch.
     - debian/patches/02_lpi.patch: add Launchpad integration support.
     - debian/patches/04_let_crasher_for_apport.patch: stop catching the SIGSEGV
       signal and let apport handle it.
     - debian/patches/05_default_to_irc_ubuntu_com.patch: set the default IRC
       server to irc.ubuntu.com.
     - debian/patches/10_docklet_default_off.patch: default behavior to have no
       notification area icon.
     - debian/patches/11_buddy_list_really_show.patch: the buddy list tries
       harder to appear.  This fixes some issues with it not appearing.
     - debian/patches/13_sounds_and_timers.patch: mute notification sounds for
       15 seconds at login time.
     - debian/patches/60_1024x600_gtk*.c.patch: add scrollbars into preferences
       and pounce dialogs
     - debian/prefs.xml: ship extra default settings for notifications, add
       the notification plugin by default and turn on logging by default.
     - debian/rules:
       - use autoreconf.
       - add translation domain for desktop file / update translations.
       - add launcher desktop file for indicator-messages.
     - debian/control:
       - add launchpad-integration, libtool, dh-autoreconf to Build-Depends.
       - drop pidgin-data Depends from libpurple0.
       - drop libpurple0 Depends from libpurple-bin.
       - add pidgin-libnotify as Recommends for pidgin binary.
 .
 pidgin (2.9.0-3) unstable; urgency=low
 .
   * Oops, really enable hardening-wrapper
 .
 pidgin (2.9.0-2) unstable; urgency=low
 .
   * Fix missing epoch in libgadu-dev build-depends (Closes: #630654 again)
   * Build-depend on fixed version of libgadu-dev that depends on libgnutls-dev
     (Closes: #631979)
   * Use hardening-wrapper (Closes: #632515)
 .
 pidgin (2.9.0-1) unstable; urgency=high
 .
   * Imported Upstream version 2.9.0
     - Fixes denial-of-service vulnerability in buddy icon handling
       (CVE-2011-2485)
   * Re-enable GG and update libgadu-dev version
 .
 pidgin (2.8.0-2) unstable; urgency=low
 .
   * Explicitly disable GG protocol since we don't have libgadu-dev 1.11.0 in
     Debian yet (Closes: #630654)
Checksums-Sha1: 
 2fbd3e228b5f870c1271919ceb1b41ec5f03138b 2675 pidgin_2.9.0-3ubuntu1.dsc
 632c681030304443a911c9eeca6d582df0a24fbb 9925589 pidgin_2.9.0.orig.tar.bz2
 ce01890f332c04ddcdf7e4723b02e0ca1656f2aa 66057 pidgin_2.9.0-3ubuntu1.debian.tar.gz
Checksums-Sha256: 
 1824f1e504683993cdd598252a88df06739f62199653f4c5e79a1aa5b0165e75 2675 pidgin_2.9.0-3ubuntu1.dsc
 28ee8ece47d94ee1b708a78d613832ea88b56d879a93fa934d532d76ae52cfd7 9925589 pidgin_2.9.0.orig.tar.bz2
 6300cda7652c57d9b4bf18d07f076f8edad33b1b29c90eccf9c0cf4a1578cc2f 66057 pidgin_2.9.0-3ubuntu1.debian.tar.gz
Files: 
 2ac1547c54e2465357d204abca806ed3 2675 net optional pidgin_2.9.0-3ubuntu1.dsc
 2cd285c7a40f93b7a51bfe733971d3a6 9925589 net optional pidgin_2.9.0.orig.tar.bz2
 dceb9da2fe5b97ee05231f9c207a130e 66057 net optional pidgin_2.9.0-3ubuntu1.debian.tar.gz
Original-Maintainer: Ari Pollak <ari at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBAgAGBQJOMsfLAAoJEMEmM+HuAYyTWNAQAKZUkop50LJjL3EfsLCIPzbT
bNCzRkz7udD3DjpoIuIfJjs22fa67qmdj0L/8xGN6WzL6/W+LmAAaGtTNAYzec5R
xGFKw1PsNLkjsIcJM7ecCzM2bjPzu6p/TpHokDNVM4te0z1wn+SlzpE1aci3VjKY
lisWzm5+6HOBSxG3sN0BymB8fvDXdAwpT6UP1nP06NxC0d+LpJQ1OD/MVjWU0T0E
4hP5r221fSVr3DCzRSLFJ+ZIOsYkR10a8csRZO+7PKFNnpaLU92TH2rw97gbi0Md
jt/bLoShpAYP98ignrea8QQGyJVcRs+TdNQjlT1bGniPHALH8PwWB3IAQePqmEK8
uaAa4mII0FfPyGtpp15E4kwwkJyKXiTFcjV9hipF5jsZSxxf1oHnfe4e3HD5u0Kz
Kfq0cy/RUgdnKzPFcWt/EIH/J8ZtYlq+9wQozwzLBU6NLPeaZD7Glfgst7NGqPcR
CWZPWPs3Hl5Gxe5XjQ0PuZs9oIqbKYh5YVN+xqvnoXJz+e0Vqey84E05IhmC1TC9
iz815chIecRZ7foxPiB+oRKlGw4X9Qfkt5nU/eC4zdr6Sb67nGm3IaOwSIrFJOWV
jO4l2mPC7pPyBr74UkJMO0mkFRu6A7fFpDTbdu2EOvpIMgxWvU7JfI32Sly2eCaI
jfn9w4kEZPNO++eEgwWW
=JPpz
-----END PGP SIGNATURE-----


More information about the Oneiric-changes mailing list