[ubuntu/oneiric] cups 1.4.7-1ubuntu4 (Accepted)

Martin Pitt martin.pitt at ubuntu.com
Fri Jul 22 06:10:20 UTC 2011


cups (1.4.7-1ubuntu4) oneiric; urgency=low

  Reupload Debian packaging trunk for the FTBFS fix (missing ghostscript build
  dep).

  [ Till Kamppeter ]
  * debian/filters/pstopdf: Added "-dNOINTERPOLATE" to the Ghostscript command
    line, this makes Ghostscript vastly faster.
  * debian/patches/use-ps2write-ghostscript-device-for-pdftops-filter.patch:
    Regenerated the patch, as we actually use it now. The "ps2write" output
    device produces finally DSC-conforming PostScript and so we can use
    Ghostscript for the pdftops filter. Made the patch also adding the
    "-dNOINTERPOLATE" to the Ghostscript command line.
  * debian/patches/series: Reactivated
    use-ps2write-ghostscript-device-for-pdftops-filter.patch and promoted it
    to the patches which should be submitted upstream.
  * debian/rules: Build CUPS with a Ghostscript-based pdftops filter.
  * debian/rules: Do not rename the pdftoraster filter of the PDF filter
    add-on any more as Ghostscript has the unified gstoraster filter now.
    Change the cost factor to make Ghostscript's filter being preferred.
  * debian/control: Let the "cups" package require at least version 9.02
    of Ghostscript, as this version does not ship a filter named pdftoraster
    any more.

  [ Jamie Strandboge ]
  * debian/local/apparmor-profile: we need to allow both /var/run and /run
    for upgrades (LP: #810687)

  [ Martin Pitt ]
  * debian/local/apparmor-profile: Explicitly deny cupsd to write /run/samba,
    to avoid dmesg errors. (LP: #812035)
  * debian/control: Slightly relax ghostscript dependency to also match
    current Debian version.
  * debian/control: Add missing ghostscript build dependency.

Date: Fri, 22 Jul 2011 08:04:49 +0200
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/oneiric/+source/cups/1.4.7-1ubuntu4
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Fri, 22 Jul 2011 08:04:49 +0200
Source: cups
Binary: libcups2 libcupsimage2 libcupscgi1 libcupsdriver1 libcupsmime1 libcupsppdc1 cups cups-client libcups2-dev libcupsimage2-dev libcupscgi1-dev libcupsdriver1-dev libcupsmime1-dev libcupsppdc1-dev cups-bsd cups-common cups-ppdc cups-dbg cupsddk
Architecture: source
Version: 1.4.7-1ubuntu4
Distribution: oneiric
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Description: 
 cups       - Common UNIX Printing System(tm) - server
 cups-bsd   - Common UNIX Printing System(tm) - BSD commands
 cups-client - Common UNIX Printing System(tm) - client programs (SysV)
 cups-common - Common UNIX Printing System(tm) - common files
 cups-dbg   - Common UNIX Printing System(tm) - debugging symbols
 cups-ppdc  - Common UNIX Printing System(tm) - PPD manipulation utilities
 cupsddk    - Common UNIX Printing System (transitional package)
 libcups2   - Common UNIX Printing System(tm) - Core library
 libcups2-dev - Common UNIX Printing System(tm) - Development files CUPS library
 libcupscgi1 - Common UNIX Printing System(tm) - CGI library
 libcupscgi1-dev - Common UNIX Printing System(tm) - Development files for CGI libra
 libcupsdriver1 - Common UNIX Printing System(tm) - Driver library
 libcupsdriver1-dev - Common UNIX Printing System(tm) - Development files driver librar
 libcupsimage2 - Common UNIX Printing System(tm) - Raster image library
 libcupsimage2-dev - Common UNIX Printing System(tm) - Development files CUPS image li
 libcupsmime1 - Common UNIX Printing System(tm) - MIME library
 libcupsmime1-dev - Common UNIX Printing System(tm) - Development files MIME library
 libcupsppdc1 - Common UNIX Printing System(tm) - PPD manipulation library
 libcupsppdc1-dev - Common UNIX Printing System(tm) - Development files PPD library
Launchpad-Bugs-Fixed: 810687 812035
Changes: 
 cups (1.4.7-1ubuntu4) oneiric; urgency=low
 .
   Reupload Debian packaging trunk for the FTBFS fix (missing ghostscript build
   dep).
 .
   [ Till Kamppeter ]
   * debian/filters/pstopdf: Added "-dNOINTERPOLATE" to the Ghostscript command
     line, this makes Ghostscript vastly faster.
   * debian/patches/use-ps2write-ghostscript-device-for-pdftops-filter.patch:
     Regenerated the patch, as we actually use it now. The "ps2write" output
     device produces finally DSC-conforming PostScript and so we can use
     Ghostscript for the pdftops filter. Made the patch also adding the
     "-dNOINTERPOLATE" to the Ghostscript command line.
   * debian/patches/series: Reactivated
     use-ps2write-ghostscript-device-for-pdftops-filter.patch and promoted it
     to the patches which should be submitted upstream.
   * debian/rules: Build CUPS with a Ghostscript-based pdftops filter.
   * debian/rules: Do not rename the pdftoraster filter of the PDF filter
     add-on any more as Ghostscript has the unified gstoraster filter now.
     Change the cost factor to make Ghostscript's filter being preferred.
   * debian/control: Let the "cups" package require at least version 9.02
     of Ghostscript, as this version does not ship a filter named pdftoraster
     any more.
 .
   [ Jamie Strandboge ]
   * debian/local/apparmor-profile: we need to allow both /var/run and /run
     for upgrades (LP: #810687)
 .
   [ Martin Pitt ]
   * debian/local/apparmor-profile: Explicitly deny cupsd to write /run/samba,
     to avoid dmesg errors. (LP: #812035)
   * debian/control: Slightly relax ghostscript dependency to also match
     current Debian version.
   * debian/control: Add missing ghostscript build dependency.
Checksums-Sha1: 
 c71cf0530b053db207219d7ccf01618d5b1a5907 2878 cups_1.4.7-1ubuntu4.dsc
 8c8680640cb3efeb33a4e31b540cb1daa54e0c78 526634 cups_1.4.7-1ubuntu4.debian.tar.gz
Checksums-Sha256: 
 c7a1e6879e9ac92b8e24401895adf6323469f67b29839e4f2db7c96056780586 2878 cups_1.4.7-1ubuntu4.dsc
 289cece2edb28078002e1f66934bf1b1a2ed9b68a900a68f2336f050f9eae0f8 526634 cups_1.4.7-1ubuntu4.debian.tar.gz
Files: 
 041203fbdf6b7ed8e93c2eccd8a77a1c 2878 net optional cups_1.4.7-1ubuntu4.dsc
 8bd6311978cc8d6ae07f2aa318fd726c 526634 net optional cups_1.4.7-1ubuntu4.debian.tar.gz
Original-Maintainer: Debian CUPS Maintainers <pkg-cups-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCAAGBQJOKRNEAAoJEPmIJawmtHufbQ4P/RLVUNeKh8JcKP/n6kI8mfEA
JtOhxhPSx8OzOIyzRgHJEUviO6qXg1YeqWGnUJG9hS9cixBHRNBotZ7LMrTRPrvR
Mxa/TR4ZPgIlupihFEMOHv+n7gtO5UkcrY0Fu6nHARzzTDjbRcbh29ZkdPDw+sDv
9fwm8U+4eN4JIJyLlCntYGo/bWr+MPBZeiIGKQ2lzL+WV9bDrKMBcotgFHm1I6xu
WocwroR369FuHoutdtM4wsXB74sh7jQmCgKZrDTumrtPCol/VtJ/5uXNXcVXshj/
bwV9PyXv9Elh6gKgGtIgV1i8NQLHMpLHXkxP3ZR8Ky2DPxz/1Ow+/H3eCFa3wFTr
pvvBbLMFEuiBnfxKUnF7kVLmF+BPkl9B7ItJ3PQ8MkeMCetMuwVaFzYPkWaq+UVz
1ybFqquppbQ+sDN5BgnFzQN0DGiMjS3okf6tILtwW1a2jzAQNVw09JlvFbJMk6/1
kGJYk+uNaNpTCqGfjHgI+YWsapHe5lCuL4ZkDLpB6w0heJOi+MbfA+Z9FBn1YgCn
SOkowi3qqJ1IyRx3PJAYDFUbGfOHzdEbWdnvAj8IHjMIWNFk1/Onjx0z6mXPxNli
m23Vg5iukM28kVvAA1amWS6KVKB/AlIHFizrv676chj5XlBN9ih2iBwAZSRnvwrS
WHGOyx89N8i2pC88i76q
=Hfaf
-----END PGP SIGNATURE-----


More information about the Oneiric-changes mailing list