[ubuntu/oneiric] postgresql-pljava 1.4.2-4 (Accepted)

Matthias Klose doko at ubuntu.com
Mon Aug 29 19:37:01 UTC 2011


postgresql-pljava (1.4.2-4) unstable; urgency=low

  * Apparently, ia64 and hppa need an explicit include path to find jni_md.h.
    Closes: #559993.

postgresql-pljava (1.4.2-3) unstable; urgency=low

  * Use /usr/lib/jvm/java-1.5.0-gcj/include as include path; build-depend
    on gcj-jdk only. Closes: #633591. Thanks to Niels Thykier.
  * Use readlink to expand /usr/lib/jvm/java-1.5.0-gcj to the real location;
    the RPATH set needs it. (Still working around #488989.)
  * Drop build-dependency on fastjar.
  * Move examples to correct directory.

postgresql-pljava (1.4.2-2) unstable; urgency=low

  * Upload to unstable; drop 8.4 package.
  * Section: database.
  * Find libjvm in /usr/lib/jvm/java-1.5.0-gcj/lib instead of
    /java-1.5.0-gcj-4.4.
  * Declare our libjvm workaround good enough for now.
    Closes: #390661, #475069.
  * jni_md.h failures are not observed anymore. Closes: #559993.
  * Replace default-jdk-builddep by gcj-native-helper.
  * Dependencies are already fixed. Closes: #629618.
  * Install deploy.jar and examples.jar files. Closes: #388625.

postgresql-pljava (1.4.2-1) experimental; urgency=low

  * New upstream release.
  * Add myself as co-maintainer.
  * Convert to plain debhelper to add multi-version support using pg_buildext.
  * Update to build with PG 8.4 and 9.0.  Closes: #559591.
  * Use explicit -L/usr/lib/jvm/java-1.5.0-gcj-4.4/lib for now and link
    against libjvm (workaround for #390661, #475069, a proper fix is requested
    in #488989).
  * Despite being redundant, link against libgcj so we have a Depends on it.
  * Also add an RPATH for /usr/lib/jvm/java-1.5.0-gcj-4.4/lib (there's no good
    public location, see also #488989).
  * Update download location.  Closes: #600658.

postgresql-pljava (1.4.0-2) UNRELEASED; urgency=low

  * Added Vcs-* control fields
  * Updated standards version

Date: Mon,  29 Aug 2011 19:35:15 +0000
Changed-By: Matthias Klose <doko at ubuntu.com>
Maintainer: Peter Eisentraut <petere at debian.org>
Origin: Debian/unstable
https://launchpad.net/ubuntu/oneiric/+source/postgresql-pljava/1.4.2-4
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Mon,  29 Aug 2011 19:35:15 +0000
Source: postgresql-pljava
Binary: postgresql-9.0-pljava-gcj
Architecture: source
Version: 1.4.2-4
Distribution: oneiric
Urgency: low
Maintainer: Peter Eisentraut <petere at debian.org>
Changed-By: Matthias Klose <doko at ubuntu.com>
Closes: 388625 390661 475069 559591 559993 559993 600658 629618 633591
Files:
 329ab57a8fb4b3227b54a6cc277e3704 234825 database optional postgresql-pljava_1.4.2.orig.tar.gz
 d694fbc1ac787787fe633fd56adcc4a0 1994 database optional postgresql-pljava_1.4.2-4.dsc
 a769236a0d301b37b056366c641f0fef 5492 database optional postgresql-pljava_1.4.2-4.debian.tar.gz
Changes:
 postgresql-pljava (1.4.2-4) unstable; urgency=low
 .
   * Apparently, ia64 and hppa need an explicit include path to find jni_md.h.
     Closes: #559993.
 .
 postgresql-pljava (1.4.2-3) unstable; urgency=low
 .
   * Use /usr/lib/jvm/java-1.5.0-gcj/include as include path; build-depend
     on gcj-jdk only. Closes: #633591. Thanks to Niels Thykier.
   * Use readlink to expand /usr/lib/jvm/java-1.5.0-gcj to the real location;
     the RPATH set needs it. (Still working around #488989.)
   * Drop build-dependency on fastjar.
   * Move examples to correct directory.
 .
 postgresql-pljava (1.4.2-2) unstable; urgency=low
 .
   * Upload to unstable; drop 8.4 package.
   * Section: database.
   * Find libjvm in /usr/lib/jvm/java-1.5.0-gcj/lib instead of
     /java-1.5.0-gcj-4.4.
   * Declare our libjvm workaround good enough for now.
     Closes: #390661, #475069.
   * jni_md.h failures are not observed anymore. Closes: #559993.
   * Replace default-jdk-builddep by gcj-native-helper.
   * Dependencies are already fixed. Closes: #629618.
   * Install deploy.jar and examples.jar files. Closes: #388625.
 .
 postgresql-pljava (1.4.2-1) experimental; urgency=low
 .
   * New upstream release.
   * Add myself as co-maintainer.
   * Convert to plain debhelper to add multi-version support using pg_buildext.
   * Update to build with PG 8.4 and 9.0.  Closes: #559591.
   * Use explicit -L/usr/lib/jvm/java-1.5.0-gcj-4.4/lib for now and link
     against libjvm (workaround for #390661, #475069, a proper fix is requested
     in #488989).
   * Despite being redundant, link against libgcj so we have a Depends on it.
   * Also add an RPATH for /usr/lib/jvm/java-1.5.0-gcj-4.4/lib (there's no good
     public location, see also #488989).
   * Update download location.  Closes: #600658.
 .
 postgresql-pljava (1.4.0-2) UNRELEASED; urgency=low
 .
   * Added Vcs-* control fields
   * Updated standards version



More information about the Oneiric-changes mailing list