[ubuntu/oneiric] lightspark 0.5.0-1 (Accepted)

Jani Monoses jani at ubuntu.com
Thu Aug 18 19:12:37 UTC 2011


lightspark (0.5.0-1) experimental; urgency=low

  * New 0.5.0 "Bacchus" upstream release.
    - Bump shlibs' version to 0.5.

  * Update Build-Depends:
    - for Ubuntu: add firefox-dev as alternative to xulrunner-dev.
    - add libjpeg-dev.
    - drop libftgl-dev and libsdl-dev.

lightspark (0.4.8.1-1) experimental; urgency=low

  * New 0.4.8.1 upstream release.

lightspark (0.4.8~rc1-1) experimental; urgency=low

  * 0.4.8 first Release Candidate:
    - Add libavformat-dev Build-Dependency.
  * Update debian/watch.

lightspark (0.4.7.1-2) experimental; urgency=low

  * Brown-paper bag upload: previous one went to unstable by mistake: upload
    to experimental for real now.

lightspark (0.4.7.1-1) experimental; urgency=low

  * New 0.4.7.1 upstream release. 
  * Refresh patches.
  * Bump Standards-Version to 3.9.2 without changes needed.

lightspark (0.4.6.1-2) experimental; urgency=low

  * Drop architecture restrictions by patching the buildsystem
    (all_arches.patch).
  * Rephrase descriptions to s/mozilla/browser/.

lightspark (0.4.6.1-1) experimental; urgency=low

  * New 0.4.6.1 upstream release.
  * Patches:
    - Remove armel.patch (included upstream).
    × Refresh hurd.patch.

lightspark (0.4.6-1) experimental; urgency=low

  * New 0.4.6 upstream release.

  [ Luca Falavigna ]
  * debian/control:
    - Remove myself from Uploaders.

  [ Didier Raboud ]
  * Merge changes done in Ubuntu, thanks Jani!
  * Re-indent Build-Depends.
  * Add lintian override for empty mozilla/plugins directory.

  [ Jani Monoses ]
  * Build on armel:
    - debian/patches/armel.patch: Add arm target to CMakeLists.txt.
    - debian/control: Allow build on armel architecture.
  * Drop libffi-dev B-D.

lightspark (0.4.5.3-1) experimental; urgency=low

  * New upstream release.
    - Fix YouTube breakage

lightspark (0.4.5.2-1) experimental; urgency=low

  * New upstream release
    - Fix YouTube breakage

  * Add new /etc/xdg/lightspark.conf file to -common.

lightspark (0.4.5.1-2) experimental; urgency=low

  * Bump B-D on libxml++2.6-dev to >= 2.33.1 (see #605773)
  * Change my e-mail address to @d.o and remove the DMUA flag.

lightspark (0.4.5.1-1) experimental; urgency=low

  * New upstream release.
  * debian/patches/hurd.patch:
    - Refresh due to new upstream release.
  * debian/control:
    - Allow build on powerpc architecture.

lightspark (0.4.4.3-1) experimental; urgency=low

  [ Didier Raboud ]
  * New upstream release.
  * debian/control:
    - Build-depend on libxml++2.6-dev.
  * debian/lightspark-{,common}.install:
    - Install localization, icon, and .desktop files.

  [ Luca Falavigna ]
  * debian/browser-plugin-lightspark.dirs:
    - Make sure /usr/lib/mozilla/plugins is created before trying to
      provide alternatives for flash-mozilla.so (Closes: #601019).

lightspark (0.4.4.2-1) experimental; urgency=low

  * New upstream release.
  * debian/patches/hurd.patch:
    - Refresh due to new upstream release.
  * debian/control:
    - Build-depend on libboost-{filesystem,system,regex}-dev.
    - Recommend gnash for lightspark package (Closes: #597200).
  * debian/copyright:
    - Update with latest copyright information.

lightspark (0.4.4.1-1) experimental; urgency=low

  * New upstream bugfix release.

  * Putting under Debian Flash Maintainers <pkg-flash-devel at l.a.d.o> umbrella:
    - git repository moved from collab-maint to pkg-flash
    - Vcs-* Fields updated accordingly
    - Maintainer changed, moved myself to Uploaders.

lightspark (0.4.4-1) experimental; urgency=low

  * New upstream release

  * debian/patches/hurd.patch: Refresh.

lightspark (0.4.3-1) experimental; urgency=low

  * New upstream release (Closes: #593367).

  [ Didier Raboud ]
  * debian/watch: Manage rc versions.

  [ Luca Falavigna ]
  * debian/patches/hurd.patch:
    - Basic GNU/Hurd support.
  * debian/browser-plugin-lightspark.*:
    - Implement alternatives on flash-mozilla.so (Closes: #590565).
  * debian/control:
    - Limit architectures to any-i386 and any-amd64 (Closes: #591357).

lightspark (0.4.2.2-1) experimental; urgency=low

  * New upstream release.
  * debian/control:
    - Build-depend on gnash-common, and add it as recommended package
      for browser-plugin-lightspark to enable fallback support.
    - Build depend on xulrunner-dev (>= 1.9.2).

lightspark (0.4.2.1-1) experimental; urgency=low

  * New upstream bugfix release.

  [ Luca Falavigna ]
  * debian/patches/avoidManpageErrors.patch
    - Removed, adopted upstream.
  *  debian/patches/privateLibrary.patch
    - Removed, adopted upstream.
  * debian/control:
    - Limit architectures to i386 amd64 kfreebsd-any (Closes: #590267).
    - Bump Standards-Version to 3.9.1, no changes required.

  [ Didier Raboud ]
  * debian/control:
    - Add pulseaudio recommends to lightspark-common, for real.

lightspark (0.4.2-1) experimental; urgency=low

  [ Didier Raboud ]
  * Initial upload to Debian (Closes: #582120).
    - Re-use upstream's PPA packaging. Thanks to Alessandro Pignotti !
  * debian/control:
    - Set myself as Maintainer, put DMUA.
    - Adapt Vcs-* fields to Debian's collab-maint.
    - Arch is any.
    - Use llvm-2.7-dev in addition to llvm-dev (> 2.7).
    - Correct "we" typos.
    - Add pulseaudio recommends.
  * New packages: 
    - -dbg package.
    - -common package with the private library and data.
  * Add lintian overrides for the use of rpath for the private library.
  * debian/copyright: Update.
  * debian/watch: Update using Launchpad.net.
  * Move from cdbs to dh7 tiny style.
  * Cleanup:
    - Remove empty README.Debian.
  * Use 3.0 (quilt) source package format.
  * Patch manpage to correct hyphen-used-as-minus error.

  [ Luca Falavigna ]
  * debian/control:
    - Add myself to Uploaders.
    - Rename mozilla-plugin-lightspark to browser-plugin-lightspark to
      match naming scheme by Mozilla team.
  * debian/copyright:
    - Add missing license information.

lightspark (0.4.1-0ubuntu1) lucid; urgency=low

  * New release

lightspark (0.4.0~rc3-0ubuntu1) lucid; urgency=low

  * New release

lightspark (0.4.0~rc2-0ubuntu1) lucid; urgency=low

  * New release

lightspark (0.4.0~rc1-ubuntu1) lucid; urgency=low

  * New release

lightspark (0.3.9-ubuntu1) lucid; urgency=low

  * New release

lightspark (0.3.8-ubuntu1) lucid; urgency=low

  * New release

lightspark (0.3.7-ubuntu1) lucid; urgency=low

  * New release

lightspark (0.3.6-ubuntu1) lucid; urgency=low

  * New release

lightspark (0.3.5-ubuntu1) lucid; urgency=low

  * A fix in SWF parsing
  * Show debug message also in standalone version

lightspark (0.3.4-ubuntu1) lucid; urgency=low

  * Fixed a bug triggered by compiler optimizations

lightspark (0.3.3-ubuntu1) lucid; urgency=low

  * Enable assertions in release builds

lightspark (0.3.2-ubuntu1) lucid; urgency=low

  * Enable debug output in release

lightspark (0.3.1-ubuntu3) lucid; urgency=low

  * Beta release
  * Improved robustness
  * Apply filtering to video

lightspark (0.2.1-ubuntu1) lucid; urgency=low

  * Mouse input support
  * Better tesselation
  * Plugin packaged

lightspark (0.2.0-ubuntu1) lucid; urgency=low

  * Youtube support

lightspark (0.techdemo2) unstable; urgency=low

  * Initial Release.

Date: Mon,  08 Aug 2011 16:48:57 +0000
Changed-By: Jani Monoses <jani at ubuntu.com>
Maintainer: Debian Flash Maintainers <pkg-flash-devel at lists.alioth.debian.org>
Origin: Debian/experimental
https://launchpad.net/ubuntu/oneiric/+source/lightspark/0.5.0-1
-------------- next part --------------
Origin: Debian/experimental
Format: 1.7
Date: Mon,  08 Aug 2011 16:48:57 +0000
Source: lightspark
Binary: lightspark, browser-plugin-lightspark, lightspark-common, lightspark-dbg
Architecture: source
Version: 0.5.0-1
Distribution: oneiric
Urgency: low
Maintainer: Debian Flash Maintainers <pkg-flash-devel at lists.alioth.debian.org>
Changed-By: Jani Monoses <jani at ubuntu.com>
Description:
 lightspark - High-performance SWF player (experimental)
Closes: 582120 590267 590565 591357 593367 597200 601019
Files:
 7d42c8e92c3c3b318076393a7e9508fb 554280 utils optional lightspark_0.5.0.orig.tar.gz
 8215212a62fca8192ee22cb3aeb87c3b 7173 utils optional lightspark_0.5.0-1.debian.tar.gz
 81d1e91266e8ecc35cdb88b80a2a1969 1834 utils optional lightspark_0.5.0-1.dsc
Changes:
 lightspark (0.5.0-1) experimental; urgency=low
 .
   * New 0.5.0 "Bacchus" upstream release.
     - Bump shlibs' version to 0.5.
 .
   * Update Build-Depends:
     - for Ubuntu: add firefox-dev as alternative to xulrunner-dev.
     - add libjpeg-dev.
     - drop libftgl-dev and libsdl-dev.
 .
 lightspark (0.4.8.1-1) experimental; urgency=low
 .
   * New 0.4.8.1 upstream release.
 .
 lightspark (0.4.8~rc1-1) experimental; urgency=low
 .
   * 0.4.8 first Release Candidate:
     - Add libavformat-dev Build-Dependency.
   * Update debian/watch.
 .
 lightspark (0.4.7.1-2) experimental; urgency=low
 .
   * Brown-paper bag upload: previous one went to unstable by mistake: upload
     to experimental for real now.
 .
 lightspark (0.4.7.1-1) experimental; urgency=low
 .
   * New 0.4.7.1 upstream release. 
   * Refresh patches.
   * Bump Standards-Version to 3.9.2 without changes needed.
 .
 lightspark (0.4.6.1-2) experimental; urgency=low
 .
   * Drop architecture restrictions by patching the buildsystem
     (all_arches.patch).
   * Rephrase descriptions to s/mozilla/browser/.
 .
 lightspark (0.4.6.1-1) experimental; urgency=low
 .
   * New 0.4.6.1 upstream release.
   * Patches:
     - Remove armel.patch (included upstream).
     × Refresh hurd.patch.
 .
 lightspark (0.4.6-1) experimental; urgency=low
 .
   * New 0.4.6 upstream release.
 .
   [ Luca Falavigna ]
   * debian/control:
     - Remove myself from Uploaders.
 .
   [ Didier Raboud ]
   * Merge changes done in Ubuntu, thanks Jani!
   * Re-indent Build-Depends.
   * Add lintian override for empty mozilla/plugins directory.
 .
   [ Jani Monoses ]
   * Build on armel:
     - debian/patches/armel.patch: Add arm target to CMakeLists.txt.
     - debian/control: Allow build on armel architecture.
   * Drop libffi-dev B-D.
 .
 lightspark (0.4.5.3-1) experimental; urgency=low
 .
   * New upstream release.
     - Fix YouTube breakage
 .
 lightspark (0.4.5.2-1) experimental; urgency=low
 .
   * New upstream release
     - Fix YouTube breakage
 .
   * Add new /etc/xdg/lightspark.conf file to -common.
 .
 lightspark (0.4.5.1-2) experimental; urgency=low
 .
   * Bump B-D on libxml++2.6-dev to >= 2.33.1 (see #605773)
   * Change my e-mail address to @d.o and remove the DMUA flag.
 .
 lightspark (0.4.5.1-1) experimental; urgency=low
 .
   * New upstream release.
   * debian/patches/hurd.patch:
     - Refresh due to new upstream release.
   * debian/control:
     - Allow build on powerpc architecture.
 .
 lightspark (0.4.4.3-1) experimental; urgency=low
 .
   [ Didier Raboud ]
   * New upstream release.
   * debian/control:
     - Build-depend on libxml++2.6-dev.
   * debian/lightspark-{,common}.install:
     - Install localization, icon, and .desktop files.
 .
   [ Luca Falavigna ]
   * debian/browser-plugin-lightspark.dirs:
     - Make sure /usr/lib/mozilla/plugins is created before trying to
       provide alternatives for flash-mozilla.so (Closes: #601019).
 .
 lightspark (0.4.4.2-1) experimental; urgency=low
 .
   * New upstream release.
   * debian/patches/hurd.patch:
     - Refresh due to new upstream release.
   * debian/control:
     - Build-depend on libboost-{filesystem,system,regex}-dev.
     - Recommend gnash for lightspark package (Closes: #597200).
   * debian/copyright:
     - Update with latest copyright information.
 .
 lightspark (0.4.4.1-1) experimental; urgency=low
 .
   * New upstream bugfix release.
 .
   * Putting under Debian Flash Maintainers <pkg-flash-devel at l.a.d.o> umbrella:
     - git repository moved from collab-maint to pkg-flash
     - Vcs-* Fields updated accordingly
     - Maintainer changed, moved myself to Uploaders.
 .
 lightspark (0.4.4-1) experimental; urgency=low
 .
   * New upstream release
 .
   * debian/patches/hurd.patch: Refresh.
 .
 lightspark (0.4.3-1) experimental; urgency=low
 .
   * New upstream release (Closes: #593367).
 .
   [ Didier Raboud ]
   * debian/watch: Manage rc versions.
 .
   [ Luca Falavigna ]
   * debian/patches/hurd.patch:
     - Basic GNU/Hurd support.
   * debian/browser-plugin-lightspark.*:
     - Implement alternatives on flash-mozilla.so (Closes: #590565).
   * debian/control:
     - Limit architectures to any-i386 and any-amd64 (Closes: #591357).
 .
 lightspark (0.4.2.2-1) experimental; urgency=low
 .
   * New upstream release.
   * debian/control:
     - Build-depend on gnash-common, and add it as recommended package
       for browser-plugin-lightspark to enable fallback support.
     - Build depend on xulrunner-dev (>= 1.9.2).
 .
 lightspark (0.4.2.1-1) experimental; urgency=low
 .
   * New upstream bugfix release.
 .
   [ Luca Falavigna ]
   * debian/patches/avoidManpageErrors.patch
     - Removed, adopted upstream.
   *  debian/patches/privateLibrary.patch
     - Removed, adopted upstream.
   * debian/control:
     - Limit architectures to i386 amd64 kfreebsd-any (Closes: #590267).
     - Bump Standards-Version to 3.9.1, no changes required.
 .
   [ Didier Raboud ]
   * debian/control:
     - Add pulseaudio recommends to lightspark-common, for real.
 .
 lightspark (0.4.2-1) experimental; urgency=low
 .
   [ Didier Raboud ]
   * Initial upload to Debian (Closes: #582120).
     - Re-use upstream's PPA packaging. Thanks to Alessandro Pignotti !
   * debian/control:
     - Set myself as Maintainer, put DMUA.
     - Adapt Vcs-* fields to Debian's collab-maint.
     - Arch is any.
     - Use llvm-2.7-dev in addition to llvm-dev (> 2.7).
     - Correct "we" typos.
     - Add pulseaudio recommends.
   * New packages: 
     - -dbg package.
     - -common package with the private library and data.
   * Add lintian overrides for the use of rpath for the private library.
   * debian/copyright: Update.
   * debian/watch: Update using Launchpad.net.
   * Move from cdbs to dh7 tiny style.
   * Cleanup:
     - Remove empty README.Debian.
   * Use 3.0 (quilt) source package format.
   * Patch manpage to correct hyphen-used-as-minus error.
 .
   [ Luca Falavigna ]
   * debian/control:
     - Add myself to Uploaders.
     - Rename mozilla-plugin-lightspark to browser-plugin-lightspark to
       match naming scheme by Mozilla team.
   * debian/copyright:
     - Add missing license information.
 .
 lightspark (0.4.1-0ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.4.0~rc3-0ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.4.0~rc2-0ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.4.0~rc1-ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.3.9-ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.3.8-ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.3.7-ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.3.6-ubuntu1) lucid; urgency=low
 .
   * New release
 .
 lightspark (0.3.5-ubuntu1) lucid; urgency=low
 .
   * A fix in SWF parsing
   * Show debug message also in standalone version
 .
 lightspark (0.3.4-ubuntu1) lucid; urgency=low
 .
   * Fixed a bug triggered by compiler optimizations
 .
 lightspark (0.3.3-ubuntu1) lucid; urgency=low
 .
   * Enable assertions in release builds
 .
 lightspark (0.3.2-ubuntu1) lucid; urgency=low
 .
   * Enable debug output in release
 .
 lightspark (0.3.1-ubuntu3) lucid; urgency=low
 .
   * Beta release
   * Improved robustness
   * Apply filtering to video
 .
 lightspark (0.2.1-ubuntu1) lucid; urgency=low
 .
   * Mouse input support
   * Better tesselation
   * Plugin packaged
 .
 lightspark (0.2.0-ubuntu1) lucid; urgency=low
 .
   * Youtube support
 .
 lightspark (0.techdemo2) unstable; urgency=low
 .
   * Initial Release.



More information about the Oneiric-changes mailing list