[ubuntu/oneiric] conky 1.8.1-2 (Accepted)

Tarun K. Mall c2tarun at gmail.com
Wed Aug 10 12:58:19 UTC 2011


conky (1.8.1-2) unstable; urgency=low

  * Add build dependency on libxnvctrl-dev | nvidia-settings to keep Conky
    in sync with Ubuntu.
  * Add debian/patches/fix-curl-ftbfs.patch to fix FTBFS with curl 7.21.7.
    (Closes: #636367)
  * Add debian/patches/fix-kfreebsd-ftbfs.patch to fix FTBFS on kfreebsd.

conky (1.8.1-1) unstable; urgency=low

  * Adopt package. (Closes: #632655)
  * Acknowledge NMU patch for #612033, which fixes a known vulnerability in
    Conky. Thanks to Luca Falavigna! (LP: #607309)
  * New upstream release. (Closes: #604921)
    - Fix bug in $if_existing. (Closes: #612904)
    - Fix various memory leaks. (Closes: #628527)
    - Fix battery_bar not parsing arguments correctly. (LP: #569195)
  * Fix ncurses being enabled for all binary packages (upstream default).
  * Rename "70b6f35a.patch" to "fix-race-condition.patch", and add a full
    DEP-3 formatted header.
  * Add debian/patches/fix-acpitemp.patch to let $acpitemp use /sys instead
    of /proc. (Closes: #609745, #628519; LP: #810667)
  * Change section of source package from "contrib/utils" to "utils".
    (Closes: #579102)
    - Change section of binary package conky-all to "contrib/utils".
    - Remove build-dependency on nvidia-settings; add build-dependency on
      libxnvctrl-dev instead to conky-all, due to the move of the
      NVCtrl/NVCtrl.h header file to libxnvctrl-dev.
    - Update debian/NEWS and debian/README.source to reflect the changes to
      Conky packaging in Debian.
  * Change dependency of transitional conky package to
    "conky-all | conky-std".
  * debian/copyright: Remove reference to deprecated BSD license file
    (/usr/share/common-licenses/BSD).
  * Change Vcs-* entries in debian/control to point to collab-maint.
  * Update Standards version from 3.8.4 to 3.9.2, no changes required.
  * Update debhelper compatiblity level from 5 to 8.

conky (1.8.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * debian/patches/70b6f35a.patch:
    - Cherrypick a patch from upstream to avoid rewriting an arbitrary
      user file (Closes: #612033).

Date: Wed,  10 Aug 2011 11:43:59 +0000
Changed-By: Tarun K. Mall <c2tarun at gmail.com>
Maintainer: Vincent Cheng <Vincentc1208 at gmail.com>
Origin: Debian/unstable
https://launchpad.net/ubuntu/oneiric/+source/conky/1.8.1-2
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Wed,  10 Aug 2011 11:43:59 +0000
Source: conky
Binary: conky, conky-std, conky-cli, conky-all
Architecture: source
Version: 1.8.1-2
Distribution: oneiric
Urgency: medium
Maintainer: Vincent Cheng <Vincentc1208 at gmail.com>
Changed-By: Tarun K. Mall <c2tarun at gmail.com>
Description:
 conky      - highly configurable system monitor (transitional package)
Closes: 579102 604921 609745 612033 612904 628519 628527 632655 636367
Launchpad-bugs-fixed: 569195 607309 810667
Files:
 366dc6a5c2ebebfbe6f53da25061b5d6 612481 utils optional conky_1.8.1.orig.tar.bz2
 8225ec82859ca369e4700fd019d98e70 17592 utils optional conky_1.8.1-2.debian.tar.bz2
 4410fa1c3fb4ec6849aa17e27c525238 1875 utils optional conky_1.8.1-2.dsc
Changes:
 conky (1.8.1-2) unstable; urgency=low
 .
   * Add build dependency on libxnvctrl-dev | nvidia-settings to keep Conky
     in sync with Ubuntu.
   * Add debian/patches/fix-curl-ftbfs.patch to fix FTBFS with curl 7.21.7.
     (Closes: #636367)
   * Add debian/patches/fix-kfreebsd-ftbfs.patch to fix FTBFS on kfreebsd.
 .
 conky (1.8.1-1) unstable; urgency=low
 .
   * Adopt package. (Closes: #632655)
   * Acknowledge NMU patch for #612033, which fixes a known vulnerability in
     Conky. Thanks to Luca Falavigna! (LP: #607309)
   * New upstream release. (Closes: #604921)
     - Fix bug in $if_existing. (Closes: #612904)
     - Fix various memory leaks. (Closes: #628527)
     - Fix battery_bar not parsing arguments correctly. (LP: #569195)
   * Fix ncurses being enabled for all binary packages (upstream default).
   * Rename "70b6f35a.patch" to "fix-race-condition.patch", and add a full
     DEP-3 formatted header.
   * Add debian/patches/fix-acpitemp.patch to let $acpitemp use /sys instead
     of /proc. (Closes: #609745, #628519; LP: #810667)
   * Change section of source package from "contrib/utils" to "utils".
     (Closes: #579102)
     - Change section of binary package conky-all to "contrib/utils".
     - Remove build-dependency on nvidia-settings; add build-dependency on
       libxnvctrl-dev instead to conky-all, due to the move of the
       NVCtrl/NVCtrl.h header file to libxnvctrl-dev.
     - Update debian/NEWS and debian/README.source to reflect the changes to
       Conky packaging in Debian.
   * Change dependency of transitional conky package to
     "conky-all | conky-std".
   * debian/copyright: Remove reference to deprecated BSD license file
     (/usr/share/common-licenses/BSD).
   * Change Vcs-* entries in debian/control to point to collab-maint.
   * Update Standards version from 3.8.4 to 3.9.2, no changes required.
   * Update debhelper compatiblity level from 5 to 8.
 .
 conky (1.8.0-1.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * debian/patches/70b6f35a.patch:
     - Cherrypick a patch from upstream to avoid rewriting an arbitrary
       user file (Closes: #612033).



More information about the Oneiric-changes mailing list