[ubuntu/oneiric] libgphoto2 2.4.11-3 (Accepted)

Jean-Louis Dupond jean-louis at dupond.be
Tue Aug 9 00:49:21 UTC 2011


libgphoto2 (2.4.11-3) unstable; urgency=low

  * Add support for GD, by Build-Depending on libgd2-noxpm-dev
    (Closes: #609120)

libgphoto2 (2.4.11-2) unstable; urgency=low

  * Fix usage of dpkg-maintscript-helper

libgphoto2 (2.4.11-1) unstable; urgency=low

  [ David Paleino ]
  * New upstream release
    - Fix unset permissions with the generic PTP rule
      (Closes: #616648, #620941)
  * Fix README.Debian regarding the new udev rules location
    (Closes: #620937)
  * debian/libgphoto2-2.{preinst,postinst,postrm}: properly
    remove old configuration files using dpkg-maintscript-helper
    (Closes: #622569)
  * Patch 80_avchd_support.patch removed, merged upstream
  * Standards-Version bump to 3.9.2, no changes needed

  [ Andreas Metzler ]
  * Stop shipping libtool la files in development package.
    http://wiki.debian.org/ReleaseGoals/LAFileRemoval
    (Closes: #621619)

libgphoto2 (2.4.10.1-5) unstable; urgency=low

  * Add missing package relationships for the package split
  * Install development documentation into more appropriate place
  * Merge libgphoto2-doc back into libgphoto2-2
  * Add a new libgphoto2-l10n package, recommended by libgphoto2-2,
    to move the localized messages in a Arch:all package
  * Rename libgphoto2-dev back to libgphoto2-2-dev: I'm not really
    in the mood of breaking everything right now :) -- jokes aside,
    it makes more sense to do this when the first SONAME bump happens.
    Thanks Andreas Metzler for discussing this on pkg-phototools' list.
    Also, this didn't touch anyone, since -4 was REJECTED, and has
    never been public.
  * Drop useless Provides/Replaces/Conflicts/Breaks from libgphoto2-2-dev:
    those packages were present in 2004, so no need to still keep those
    relationships there.

libgphoto2 (2.4.10.1-4) unstable; urgency=low

  * Upload to unstable
  * Removing KiBi from Uploaders, as requested. Thanks for all your
    previous work!
  * HALectomy: remove libhal-dev from Build-Depends, and remove
    HAL FDI generation in debian/rules. (Closes: #580291)
  * Split documentation in other two binary packages: libgphoto2-dev-doc
    and libgphoto2-doc
  * Rename libgphoto2-2-dev to libgphoto2-dev: this will ease SONAME
    transitions through binNMUs.

libgphoto2 (2.4.10.1-3) experimental; urgency=low

  * Merge from Ubuntu:
    - debian/patches/80_avchd_support.patch: Report .MTS and .M2TS
      files on mass-storage devices as they are AVCHD video streams.
      Patch from upstream svn trunk.
    - debian/libgphoto2-2.install: Drop API docs, they are already
      shipped in the -dev package. Thanks to Martin Pitt
      (Closes: #606944)

Date: Mon,  08 Aug 2011 23:25:29 +0000
Changed-By: Jean-Louis Dupond <jean-louis at dupond.be>
Maintainer: Debian PhotoTools Maintainers <pkg-phototools-devel at lists.alioth.debian.org>
Origin: Debian/unstable
https://launchpad.net/ubuntu/oneiric/+source/libgphoto2/2.4.11-3
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Mon,  08 Aug 2011 23:25:29 +0000
Source: libgphoto2
Binary: libgphoto2-2-dev, libgphoto2-dev-doc, libgphoto2-port0, libgphoto2-2, libgphoto2-l10n
Architecture: source
Version: 2.4.11-3
Distribution: oneiric
Urgency: low
Maintainer: Debian PhotoTools Maintainers <pkg-phototools-devel at lists.alioth.debian.org>
Changed-By: Jean-Louis Dupond <jean-louis at dupond.be>
Closes: 580291 606944 609120 616648 620937 620941 621619 622569
Files:
 cadd29e56914620b1f99188bfcacbfbe 1666 libs optional libgphoto2_2.4.11-3.dsc
 a2230c31e320acb7ececd90bc02fe515 5521265 libs optional libgphoto2_2.4.11.orig.tar.gz
 f26a00331bd88c69abf44f86fe5a77fc 26927 libs optional libgphoto2_2.4.11-3.debian.tar.gz
Changes:
 libgphoto2 (2.4.11-3) unstable; urgency=low
 .
   * Add support for GD, by Build-Depending on libgd2-noxpm-dev
     (Closes: #609120)
 .
 libgphoto2 (2.4.11-2) unstable; urgency=low
 .
   * Fix usage of dpkg-maintscript-helper
 .
 libgphoto2 (2.4.11-1) unstable; urgency=low
 .
   [ David Paleino ]
   * New upstream release
     - Fix unset permissions with the generic PTP rule
       (Closes: #616648, #620941)
   * Fix README.Debian regarding the new udev rules location
     (Closes: #620937)
   * debian/libgphoto2-2.{preinst,postinst,postrm}: properly
     remove old configuration files using dpkg-maintscript-helper
     (Closes: #622569)
   * Patch 80_avchd_support.patch removed, merged upstream
   * Standards-Version bump to 3.9.2, no changes needed
 .
   [ Andreas Metzler ]
   * Stop shipping libtool la files in development package.
     http://wiki.debian.org/ReleaseGoals/LAFileRemoval
     (Closes: #621619)
 .
 libgphoto2 (2.4.10.1-5) unstable; urgency=low
 .
   * Add missing package relationships for the package split
   * Install development documentation into more appropriate place
   * Merge libgphoto2-doc back into libgphoto2-2
   * Add a new libgphoto2-l10n package, recommended by libgphoto2-2,
     to move the localized messages in a Arch:all package
   * Rename libgphoto2-dev back to libgphoto2-2-dev: I'm not really
     in the mood of breaking everything right now :) -- jokes aside,
     it makes more sense to do this when the first SONAME bump happens.
     Thanks Andreas Metzler for discussing this on pkg-phototools' list.
     Also, this didn't touch anyone, since -4 was REJECTED, and has
     never been public.
   * Drop useless Provides/Replaces/Conflicts/Breaks from libgphoto2-2-dev:
     those packages were present in 2004, so no need to still keep those
     relationships there.
 .
 libgphoto2 (2.4.10.1-4) unstable; urgency=low
 .
   * Upload to unstable
   * Removing KiBi from Uploaders, as requested. Thanks for all your
     previous work!
   * HALectomy: remove libhal-dev from Build-Depends, and remove
     HAL FDI generation in debian/rules. (Closes: #580291)
   * Split documentation in other two binary packages: libgphoto2-dev-doc
     and libgphoto2-doc
   * Rename libgphoto2-2-dev to libgphoto2-dev: this will ease SONAME
     transitions through binNMUs.
 .
 libgphoto2 (2.4.10.1-3) experimental; urgency=low
 .
   * Merge from Ubuntu:
     - debian/patches/80_avchd_support.patch: Report .MTS and .M2TS
       files on mass-storage devices as they are AVCHD video streams.
       Patch from upstream svn trunk.
     - debian/libgphoto2-2.install: Drop API docs, they are already
       shipped in the -dev package. Thanks to Martin Pitt
       (Closes: #606944)



More information about the Oneiric-changes mailing list