[ubuntu/oneiric] perl 5.12.4-2 (Accepted)

Matthias Klose doko at ubuntu.com
Mon Aug 8 10:19:17 UTC 2011


perl (5.12.4-2) unstable; urgency=low

  [ Niko Tyni ]
  * debian/config.over: Force the multiarch directory /usr/lib/<triplet>
    into $Config{libpth} even if doesn't exist yet. This should guarantee
    that ExtUtils::Embed works on multiarch enabled system even when
    the package isn't built on one. Thanks to Jonathan Nieder.
    (Closes: #630399)
    + needs a build dependency on dpkg-dev (>= 1.16.0) for
      "dpkg-architecture -qDEB_HOST_MULTIARCH".
  * Fix tainting with index() of a constant. (Closes: #291450)
  * Break older versions of doc-base to avoid a Storable binary
    incompatibility issue in partial upgrades. (Closes: #633076)
  * No longer prune -lnsl and -lutil in debian/config.over, this was
    obsoleted by a related change in 5.6.1-7 (!)
  * Match bzip2 archives in debian/watch.

Date: Mon,  08 Aug 2011 10:16:23 +0000
Changed-By: Matthias Klose <doko at ubuntu.com>
Maintainer: Niko Tyni <ntyni at debian.org>
Origin: Debian/unstable
https://launchpad.net/ubuntu/oneiric/+source/perl/5.12.4-2
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Mon,  08 Aug 2011 10:16:23 +0000
Source: perl
Binary: perl-base, libcgi-fast-perl, perl-doc, perl-modules, perl-debug, libperl5.12, libperl-dev, perl
Architecture: source
Version: 5.12.4-2
Distribution: oneiric
Urgency: low
Maintainer: Niko Tyni <ntyni at debian.org>
Changed-By: Matthias Klose <doko at ubuntu.com>
Description:
 perl       - Larry Wall's Practical Extraction and Report Language
Closes: 291450 630399 633076
Files:
 17cce49adadc354856daa267cdbd4466 97146 perl standard perl_5.12.4-2.debian.tar.gz
 4788ba26bf53f8ea99582f3b6ad26a2c 1412 perl standard perl_5.12.4-2.dsc
Changes:
 perl (5.12.4-2) unstable; urgency=low
 .
   [ Niko Tyni ]
   * debian/config.over: Force the multiarch directory /usr/lib/<triplet>
     into $Config{libpth} even if doesn't exist yet. This should guarantee
     that ExtUtils::Embed works on multiarch enabled system even when
     the package isn't built on one. Thanks to Jonathan Nieder.
     (Closes: #630399)
     + needs a build dependency on dpkg-dev (>= 1.16.0) for
       "dpkg-architecture -qDEB_HOST_MULTIARCH".
   * Fix tainting with index() of a constant. (Closes: #291450)
   * Break older versions of doc-base to avoid a Storable binary
     incompatibility issue in partial upgrades. (Closes: #633076)
   * No longer prune -lnsl and -lutil in debian/config.over, this was
     obsoleted by a related change in 5.6.1-7 (!)
   * Match bzip2 archives in debian/watch.



More information about the Oneiric-changes mailing list