[ubuntu/natty-security] python2.7 2.7.1-5ubuntu2.2 (Accepted)

Jamie Strandboge jamie at ubuntu.com
Tue Oct 2 19:28:13 UTC 2012


python2.7 (2.7.1-5ubuntu2.2) natty-security; urgency=low

  * SECURITY UPDATE: fix hash randomization DoS
    - debian/patches/CVE-2012-1150.diff: add -R command-line option and
      PYTHONHASHSEED environment variable, to provide an opt-in way to protect
      against denial of service attacks due to hash collisions within the dict
      and set types.
    - CVE-2012-1150
  * SECURITY UPDATE: xmlrpc: Fix an endless loop in SimpleXMLRPCServer upon
    malformed POST request
    - debian/patches/CVE-2012-0845.diff: break if don't receive EOF in
      Lib/SimpleXMLRPCServer.py
    - CVE-2012-0845
  * SECURITY UPDATE: update urllib and urllib2 for invalid redirections
    - debian/patches/CVE-2011-1521.diff: only process Location headers for
      http, https, and ftp
    - http://bugs.python.org/issue11662
    - CVE-2011-1521
  * SECURITY UPDATE: fix XSS in SimpleHTTPServer
    - debian/patches/CVE-2011-4940.diff: add a charset parameter to the
      Content-type
    - CVE-2011-4940
  * SECURE UPDATE: http://bugs.python.org/issue13512
    - debian/patches/CVE-2011-4944.diff: create ~/.pypirc securely
    - CVE-2011-4944

Date: 2012-09-27 20:50:10.898416+00:00
Changed-By: Jamie Strandboge <jamie at ubuntu.com>
https://launchpad.net/ubuntu/natty/+source/python2.7/2.7.1-5ubuntu2.2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Natty-changes mailing list