A little clarity

Daniel van Vugt daniel.van.vugt at canonical.com
Wed Jul 17 02:48:44 UTC 2013


All,

I see a lot of code landing even now, where classes are named:
   FooStrategy
   FooCriteria
   FooSequence
   FooMechanism
   FooBundle
   FooPackage

These suffixes are all too abstract to help the reader understand what's 
going on.

If the suffix is redundant, then please leave it out. If it's not 
redundant then please stop to think of a better name for your class.

This should result in more readable code, which helps everyone, forever 
more.

- Daniel



More information about the Mir-devel mailing list