[ubuntu/maverick-proposed] postgresql-8.4 8.4.8-0ubuntu0.10.10 (Accepted)

Martin Pitt martin.pitt at ubuntu.com
Wed Apr 20 14:17:25 UTC 2011


postgresql-8.4 (8.4.8-0ubuntu0.10.10) maverick-proposed; urgency=low

  * New upstream bug fix release: (LP: #767165)
    - If your installation was upgraded from a previous major release by
      running pg_upgrade, you should take action to prevent possible data loss
      due to a now-fixed bug in pg_upgrade. The recommended solution is to run
      "VACUUM FREEZE" on all TOAST tables.  More information is available at
      http://wiki.postgresql.org/wiki/20110408pg_upgrade_fix.
    - Fix pg_upgrade's handling of TOAST tables.
      This error poses a significant risk of data loss for installations
      that have been upgraded with pg_upgrade. This patch corrects the
      problem for future uses of pg_upgrade, but does not in itself cure
      the issue in installations that have been processed with a buggy
      version of pg_upgrade.
    - Suppress incorrect "PD_ALL_VISIBLE flag was incorrectly set"
      warning.
    - Disallow including a composite type in itself.
    - Avoid potential deadlock during catalog cache initialization.
    - Fix dangling-pointer problem in BEFORE ROW UPDATE trigger handling
      when there was a concurrent update to the target tuple.
    - Disallow "DROP TABLE" when there are pending deferred trigger
      events for the table.
      Formerly the "DROP" would go through, leading to "could not open
      relation with OID nnn" errors when the triggers were eventually
      fired.
    - Prevent crash triggered by constant-false WHERE conditions during
      GEQO optimization.
    - Improve planner's handling of semi-join and anti-join cases.
    - Fix selectivity estimation for text search to account for NULLs.
    - Improve PL/pgSQL's ability to handle row types with dropped columns.
    - Fix PL/Python memory leak involving array slices.
    - Fix pg_restore to cope with long lines (over 1KB) in TOC files.
    - Put in more safeguards against crashing due to division-by-zero
      with overly enthusiastic compiler optimization. (Closes: #616180)

Date: Wed, 20 Apr 2011 15:33:25 +0200
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Maintainer: Martin Pitt <mpitt at debian.org>
https://launchpad.net/ubuntu/maverick/+source/postgresql-8.4/8.4.8-0ubuntu0.10.10
-------------- next part --------------
Format: 1.8
Date: Wed, 20 Apr 2011 15:33:25 +0200
Source: postgresql-8.4
Binary: libpq-dev libpq5 libecpg6 libecpg-dev libecpg-compat3 libpgtypes3 postgresql-8.4 postgresql-client-8.4 postgresql-server-dev-8.4 postgresql-doc-8.4 postgresql-contrib-8.4 postgresql-plperl-8.4 postgresql-plpython-8.4 postgresql-pltcl-8.4 postgresql postgresql-client postgresql-doc postgresql-contrib
Architecture: source
Version: 8.4.8-0ubuntu0.10.10
Distribution: maverick-proposed
Urgency: low
Maintainer: Martin Pitt <mpitt at debian.org>
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Description: 
 libecpg-compat3 - older version of run-time library for ECPG programs
 libecpg-dev - development files for ECPG (Embedded PostgreSQL for C)
 libecpg6   - run-time library for ECPG programs
 libpgtypes3 - shared library libpgtypes for PostgreSQL 8.4
 libpq-dev  - header files for libpq5 (PostgreSQL library)
 libpq5     - PostgreSQL C client library
 postgresql - object-relational SQL database (supported version)
 postgresql-8.4 - object-relational SQL database, version 8.4 server
 postgresql-client - front-end programs for PostgreSQL (supported version)
 postgresql-client-8.4 - front-end programs for PostgreSQL 8.4
 postgresql-contrib - additional facilities for PostgreSQL (supported version)
 postgresql-contrib-8.4 - additional facilities for PostgreSQL
 postgresql-doc - documentation for the PostgreSQL database management system
 postgresql-doc-8.4 - documentation for the PostgreSQL database management system
 postgresql-plperl-8.4 - PL/Perl procedural language for PostgreSQL 8.4
 postgresql-plpython-8.4 - PL/Python procedural language for PostgreSQL 8.4
 postgresql-pltcl-8.4 - PL/Tcl procedural language for PostgreSQL 8.4
 postgresql-server-dev-8.4 - development files for PostgreSQL 8.4 server-side programming
Closes: 616180
Launchpad-Bugs-Fixed: 767165
Changes: 
 postgresql-8.4 (8.4.8-0ubuntu0.10.10) maverick-proposed; urgency=low
 .
   * New upstream bug fix release: (LP: #767165)
     - If your installation was upgraded from a previous major release by
       running pg_upgrade, you should take action to prevent possible data loss
       due to a now-fixed bug in pg_upgrade. The recommended solution is to run
       "VACUUM FREEZE" on all TOAST tables.  More information is available at
       http://wiki.postgresql.org/wiki/20110408pg_upgrade_fix.
     - Fix pg_upgrade's handling of TOAST tables.
       This error poses a significant risk of data loss for installations
       that have been upgraded with pg_upgrade. This patch corrects the
       problem for future uses of pg_upgrade, but does not in itself cure
       the issue in installations that have been processed with a buggy
       version of pg_upgrade.
     - Suppress incorrect "PD_ALL_VISIBLE flag was incorrectly set"
       warning.
     - Disallow including a composite type in itself.
     - Avoid potential deadlock during catalog cache initialization.
     - Fix dangling-pointer problem in BEFORE ROW UPDATE trigger handling
       when there was a concurrent update to the target tuple.
     - Disallow "DROP TABLE" when there are pending deferred trigger
       events for the table.
       Formerly the "DROP" would go through, leading to "could not open
       relation with OID nnn" errors when the triggers were eventually
       fired.
     - Prevent crash triggered by constant-false WHERE conditions during
       GEQO optimization.
     - Improve planner's handling of semi-join and anti-join cases.
     - Fix selectivity estimation for text search to account for NULLs.
     - Improve PL/pgSQL's ability to handle row types with dropped columns.
     - Fix PL/Python memory leak involving array slices.
     - Fix pg_restore to cope with long lines (over 1KB) in TOC files.
     - Put in more safeguards against crashing due to division-by-zero
       with overly enthusiastic compiler optimization. (Closes: #616180)
Checksums-Sha1: 
 39c24e3166b43f8ab9b59167a42a8fdc6dd7409c 2542 postgresql-8.4_8.4.8-0ubuntu0.10.10.dsc
 2f9fd441098753f9ccaef8cffbd596e40afea379 17658079 postgresql-8.4_8.4.8.orig.tar.gz
 c44eda72b0b952dad839d9fc96401b42e983626d 42096 postgresql-8.4_8.4.8-0ubuntu0.10.10.diff.gz
Checksums-Sha256: 
 ead99de09984f2df839f9a7ef99c7a0dadc5754942f96d65f04f3de2fa5763db 2542 postgresql-8.4_8.4.8-0ubuntu0.10.10.dsc
 774c0d1f06a216d9534e3724630a96b063009ad1f4ece3fa92ce1f26457bfea4 17658079 postgresql-8.4_8.4.8.orig.tar.gz
 64cf4429bf8f7638b9e69e407424cd4c6481320490b38d9c3e80c0ee7e83dff5 42096 postgresql-8.4_8.4.8-0ubuntu0.10.10.diff.gz
Files: 
 52c318b99f175fb0284169e8fac79d96 2542 database optional postgresql-8.4_8.4.8-0ubuntu0.10.10.dsc
 a387ef3727e62b6e082fd2dd02d7a374 17658079 database optional postgresql-8.4_8.4.8.orig.tar.gz
 79841c03fa5fce0537e3c9fa81a238d0 42096 database optional postgresql-8.4_8.4.8-0ubuntu0.10.10.diff.gz


More information about the Maverick-changes mailing list