[ubuntu/maverick] libxslt 1.1.26-6 (Accepted)

Ubuntu Installer archive at ubuntu.com
Mon Sep 6 11:40:59 BST 2010


libxslt (1.1.26-6) unstable; urgency=low

  * debian/python-libxslt1-dbg.preinst: Add preinst snippet to remove
    /usr/share/doc/python-libxslt1-dbg symlink on Ubuntu. This is an
    Ubuntu-only fix, but allows Ubuntu to just use the Debian package
    without further modifications.
    Closes: #587910

libxslt (1.1.26-5) unstable; urgency=low

  * debian/rules: Avoid possible renaming of _d.so files to _d_d.so files in
    the install-python%-dbg rules.
  * debian/control:
    - Add missing dependency on python-libxml2-dbg to python-libxslt1-dbg.
    - Remove old Conflicts/Replaces for packages that have disappeared before
      etch.
    - Bump Standards-Version to 3.9.0.0.
    - Add Homepage.
    - Add Vcs-{Git,Browser} fields.

libxslt (1.1.26-4) unstable; urgency=low

  * debian/rules:
    - Refactor configure-% and build-% rules.
    - Hack to link with -Wl,--as-needed.
  * debian/python-libxslt1.install: Don't hardcode site-/dist-packages in
    .install. Cope with builds which don't have any dist-packages (or
    site-packages) based python versions. Thanks Loïc Minier.
  * debian/control:
    - Add missing XB-Python-Version to python-libxslt1.
    - Mention the version of XSLT implemented. Closes: #579244.
    - Fix typo in libxslt1-dev package description. Closes: #579241.
  * debian/control, debian/python-libxslt1-dbg.install, debian/rules: Add a
    python-libxslt1-dbg package.
  * doc/xsltproc.xml, doc/xsltproc.1: Document what happens when there is
    no output and -o is specified. Closes: #539890.

libxslt (1.1.26-3) unstable; urgency=low

  * debian/compat: Switch to debhelper compat level 7.
  * debian/control: Build depend on debhelper >= 7.0.50~.
  * debian/rules:
    + Remove old source and diff rules. They only displayed a message
      inviting to use dpkg-source -b.
    + Remove workarounds for modified and deleted files. The modified file
      is not modified anymore, and as we're not using svn-buildpackage we
      also don't care about deleted files anymore.
    + Trust dpkg-buildpackage to set the CFLAGS.
    + Change the way python libs are built. We now use configure to set
      different environment with and without python, and arrange things so
      that we don't have to build the base libxslt library several times.
    + Use a common cache for main and python configure passes.
    + Modify libexslt.la in place in debian/tmp.
    + Switch to dh.
    + Deduplicate in /usr/lib/pyshared, not
      /usr/lib/python-support/python-libxslt1.
  * debian/python-libxslt1.install: Install python files from
    /usr/lib/python*/dist-packages.
  * python/Makefile.am, python/Makefile.in, python/generator.py: Don't
    generate python API intermediate files in $srcdir.
  * debian/libxslt1-dev.install: Install libexslt.la with dh_install.

libxslt (1.1.26-2) unstable; urgency=low

  * debian/control:
    + Add missing ${misc:Depends}.
    + Bump Standards-Version to 3.8.4.0.
    + Put libxslt1-dbg in section debug.
  * debian/libxslt1-dev.install: Install /usr/share/aclocal files.
    Closes: #569066.
  * debian/rules, debian/libxslt1.1.symbols: Add symbols file and bump
    shlibs. Closes: #563399.

Date: Mon,  06 Sep 2010 11:37:52 +0100
Changed-By: Artur Rona <ari-tczew at tlen.pl>
Maintainer: Debian XML/SGML Group <debian-xml-sgml-pkgs at lists.alioth.debian.org>
Origin: Debian/unstable
https://launchpad.net/ubuntu/maverick/+source/libxslt/1.1.26-6
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Mon,  06 Sep 2010 11:37:52 +0100
Source: libxslt
Binary: libxslt1.1, libxslt1-dev, libxslt1-dbg, xsltproc, python-libxslt1, python-libxslt1-dbg
Architecture: source
Version: 1.1.26-6
Distribution: maverick
Urgency: low
Maintainer: Debian XML/SGML Group <debian-xml-sgml-pkgs at lists.alioth.debian.org>
Changed-By: Artur Rona <ari-tczew at tlen.pl>
Closes: 539890 563399 569066 579241 579244 587910
Changes: 
 libxslt (1.1.26-6) unstable; urgency=low
 .
   * debian/python-libxslt1-dbg.preinst: Add preinst snippet to remove
     /usr/share/doc/python-libxslt1-dbg symlink on Ubuntu. This is an
     Ubuntu-only fix, but allows Ubuntu to just use the Debian package
     without further modifications.
     Closes: #587910
 .
 libxslt (1.1.26-5) unstable; urgency=low
 .
   * debian/rules: Avoid possible renaming of _d.so files to _d_d.so files in
     the install-python%-dbg rules.
   * debian/control:
     - Add missing dependency on python-libxml2-dbg to python-libxslt1-dbg.
     - Remove old Conflicts/Replaces for packages that have disappeared before
       etch.
     - Bump Standards-Version to 3.9.0.0.
     - Add Homepage.
     - Add Vcs-{Git,Browser} fields.
 .
 libxslt (1.1.26-4) unstable; urgency=low
 .
   * debian/rules:
     - Refactor configure-% and build-% rules.
     - Hack to link with -Wl,--as-needed.
   * debian/python-libxslt1.install: Don't hardcode site-/dist-packages in
     .install. Cope with builds which don't have any dist-packages (or
     site-packages) based python versions. Thanks Loïc Minier.
   * debian/control:
     - Add missing XB-Python-Version to python-libxslt1.
     - Mention the version of XSLT implemented. Closes: #579244.
     - Fix typo in libxslt1-dev package description. Closes: #579241.
   * debian/control, debian/python-libxslt1-dbg.install, debian/rules: Add a
     python-libxslt1-dbg package.
   * doc/xsltproc.xml, doc/xsltproc.1: Document what happens when there is
     no output and -o is specified. Closes: #539890.
 .
 libxslt (1.1.26-3) unstable; urgency=low
 .
   * debian/compat: Switch to debhelper compat level 7.
   * debian/control: Build depend on debhelper >= 7.0.50~.
   * debian/rules:
     + Remove old source and diff rules. They only displayed a message
       inviting to use dpkg-source -b.
     + Remove workarounds for modified and deleted files. The modified file
       is not modified anymore, and as we're not using svn-buildpackage we
       also don't care about deleted files anymore.
     + Trust dpkg-buildpackage to set the CFLAGS.
     + Change the way python libs are built. We now use configure to set
       different environment with and without python, and arrange things so
       that we don't have to build the base libxslt library several times.
     + Use a common cache for main and python configure passes.
     + Modify libexslt.la in place in debian/tmp.
     + Switch to dh.
     + Deduplicate in /usr/lib/pyshared, not
       /usr/lib/python-support/python-libxslt1.
   * debian/python-libxslt1.install: Install python files from
     /usr/lib/python*/dist-packages.
   * python/Makefile.am, python/Makefile.in, python/generator.py: Don't
     generate python API intermediate files in $srcdir.
   * debian/libxslt1-dev.install: Install libexslt.la with dh_install.
 .
 libxslt (1.1.26-2) unstable; urgency=low
 .
   * debian/control:
     + Add missing ${misc:Depends}.
     + Bump Standards-Version to 3.8.4.0.
     + Put libxslt1-dbg in section debug.
   * debian/libxslt1-dev.install: Install /usr/share/aclocal files.
     Closes: #569066.
   * debian/rules, debian/libxslt1.1.symbols: Add symbols file and bump
     shlibs. Closes: #563399.
Files: 
 5268c3827a9b291c3a90b683fc22e235 1434 text optional libxslt_1.1.26-6.dsc
 294aa72d34316a8355308d89e55ae765 91102 text optional libxslt_1.1.26-6.diff.gz


More information about the Maverick-changes mailing list