[ubuntu/maverick] csound 1:5.12.1~dfsg-2ubuntu1 (Accepted)

Alessio Treglia quadrispro at ubuntu.com
Thu May 27 22:50:16 BST 2010


csound (1:5.12.1~dfsg-2ubuntu1) maverick; urgency=low

  * Merge from debian unstable, Ubuntu remaining changes:
    - Build with all supported python versions.
    - Update build-dependency on python-all-dev to provide python.mk rule.

csound (1:5.12.1~dfsg-2) unstable; urgency=low

  * Revert unpatch hack: upsets build daemons.

csound (1:5.12.1~dfsg-1) unstable; urgency=low

  [ Jonas Smedegaard ]
  * Fix Mac-encoded apostrophe in copyright, thanks to lintian.
  * Bump Standards-Version to 3.8.4.
  * Wrap long descriptions at 72 characters.
  * Fix capitalization of PureData in a long description.
  * Packaging moved to Debian Multimedia Maintainers: Update Maintainer
    and Vcs-* stanzas in control file.
  * Drop implementing DEB_MAINTAINER_MODE in rules file: handled in cdbs
    now. Drop related lintian override as well.
  * Drop package-relations.mk (last remaining local CDBS snippet):
    included in cdbs itself now.
  * Use CDBS class python-module.mk, and simplify local Python hacks in
    rules file.
  * Refresh patches, using shortening quilt options --no-timestamps
    --no-index -pab.
  * Update copyright file (new author, no new licenses).
  * Fix use DEB_UPSTREAM_REPACKAGE_EXCLUDES (not abandoned
    DEB_UPSTREAM_REPACKAGE_EXCLUDE) in rules file.
  * Tighten repackaging hints to match current (slightly cleaner)
    upstream release, in rules and copyright files.

  [ Felipe Sateler ]
  * New upstream release
    - Update patches for new upstream release
    - Install crossfm opcode
    - Update symbols file
  * Drop local CDBS snippets that have been integrated in the main CDBS
    package
  * Reorder scons options
  * Reorder build-dependencies
  * Make every build option explicit
  * Fix a segfault when an ending \ is used to split a line in the
    orchestra
  * Do not set buildSDFT option, it was dropped upstream
  * Detect default tcl version and enforce it
  * Enable STK opcodes
  * Invoke the java archs resolution script in debian/rules
  * Update debian/control

csound (1:5.11.1~dfsg-4) unstable; urgency=low

  [ Felipe Sateler ]
  * Change luacsnd package name in control files (this caused -3 luacsnd to be
    empty).
  * Make the lua package provide the old name.
  * Install to /usr/lib/dist-packages with python 2.6 or higher.
    Closes: #571270
  * Add DM-Upload-Allowed field.

  [ Jonas Smedegaard ]
  * Stop mentioning quilt in README.source.
  * Update local CDBS snippets:
    + package-relations.mk:
      - Merge mixture of versioned and unversioned dependencies
      - Use unversioned dependencies when satisfied in oldstable
      - Improve whitespace cleanup
      - Rewrite and silence applying dependencies
      - Handle cdbs 0.4.53 dependency (needed when using debhelper v7)
    + upstream-tarball.mk:
      - Depend unversioned on cdbs (the needed 0.4.39 is in oldstable)
      - Preserve bzip2 tarballs with source format '3.0 (quilt)'.
    + copyright-check.mk:
      - More aggressive scanning (check top 99999 lines, not just 60)
      - Simplify more licensing notices and preserve non-ASCII chars
      - Group hints by sorted owner list (ignoring years)
      - Limit console output both horisontally and vertically
      - Use rev123 of draft DEP5 for hints file
  * Refer to FSF website (not postal address) in debian/rules header.
  * Rewrite copyright file using in DEP5 rev. 135 format.
  * Add DM-Upload-Allowed field to control.in.
  * Refresh patches with quilt option --no-timestamp.
  * Add rudimentary DEP3 patch headers.
  * Build-depend unversioned on cdbs.

csound (1:5.11.1~dfsg-3) unstable; urgency=low

  [ Felipe Sateler ]
  * Be more verbose on mv-inside-for-loops
  * Rename the lua module (Closes: #561131)
  * Do not link against the lua library (Closes: #561128)
  * Rename the lua module as per the lua policy
  * Correct SONAME and package name of the lua bindings
  * Regenerate control file

csound (1:5.11.1~dfsg-2) unstable; urgency=low

  * Fix extend local scons config.py to Include
    /usr/lib/jvm/default-java/include/linux. Thanks to
    Carlos O'Donell for thorough investigations.
  * Switch to source format 3.0 (quilt):
    + Unfuzz patches, and apply them to packaging source.
    + Stop including cdbs snippet patchsys-quilt.mk.
    + Stop build-depending on quilt or patchutils.
    + Add source format hint to packaging source.
  * Drop backportability for Etch:
    + Drop fallback build-dependencies on java-gcj-compat-dev and
      versioned tcl and tk libraries,
    + Cleanup local scons config.py to not include
      /usr/lib/jvm/java-gcj/include or /usr/include/tcl8.4.

csound (1:5.11.1~dfsg-1) unstable; urgency=low

  [ Felipe Sateler ]
  * New upstream release
    - Large build-system changes
    - Update patches:
     - Fix csPerfThread.hpp path for installation
     - Fix python interface build failure.
     - Fix build failure in wrappers
     - Make scons install the interfaces library
    - Install ScoreModel.hpp
    - Install new opcodes
  * Add more -Wl,--as-needed
  * Change lua package to arch: any now that it is a proper library
  * Rely on dh_lintian for the lintian overrides
  * Use a symbols file for libcsound64
  * Bump Standards-Version, no changes needed

  [ Jonas Smedegaard ]
  * Tighten -dev packages dependency on their lib package as per Debian
    Policy §8.5, thanks to lintian.

csound (1:5.10.1~dfsg1-4) unstable; urgency=low

  [ Jonas Smedegaard ]
  * Strip old notes from watch file.
  * Simplify debian/copyright (based on newest DEP5 draft).
  * Fix typo in README.source: new new.
  * Update local CDBS snippets:
    + Update package-relations.mk: Cleanup unversioned+versioned
      dependency mix. Improve whitespace cleanup. Rewrite and silence
      applying dependencies.
    + Implement fail-source-not-repackaged rule in upstream-tarball.mk.
    + Update URL to draft DEP5 format in copyright-check.mk output.
  * Extend java-related (build-)dependencies to include architecures
    hppa, kfreebsd-amd64 and kfreebsd-i386.

  [ Felipe Sateler ]
  * At build, import the whole environment (Closes: #522414)

Date: Thu, 27 May 2010 21:47:52 +0200
Changed-By: Alessio Treglia <quadrispro at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/maverick/+source/csound/1:5.12.1~dfsg-2ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 27 May 2010 21:47:52 +0200
Source: csound
Binary: csound csound-gui csound-utils libcsound64-5.2 libcsnd-java libcsound64-dev libcsnd-dev libcsoundac-dev pd-csound python-csound libcsnd5.2 liblua5.1-luacsnd5.2 tclcsound libcsoundac5.2 python-csoundac csladspa libcsound64-doc
Architecture: source
Version: 1:5.12.1~dfsg-2ubuntu1
Distribution: maverick
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Alessio Treglia <quadrispro at ubuntu.com>
Description: 
 csladspa   - LADSPA plugin for Csound
 csound     - powerful and versatile sound synthesis software
 csound-gui - GUI interfaces and opcodes for Csound
 csound-utils - miscellaneous utilities for the Csound system
 libcsnd-dev - development files for Csound -- C++ API
 libcsnd-java - Java bindings for the Csound API
 libcsnd5.2 - C++ bindings for the Csound API
 libcsound64-5.2 - main library for Csound
 libcsound64-dev - development files for Csound
 libcsound64-doc - Csound API documentation
 libcsoundac-dev - development files for CsoundAC
 libcsoundac5.2 - the Csound Algorithmic Composition library
 liblua5.1-luacsnd5.2 - Lua bindings for the Csound API
 pd-csound  - Csound external for PureData
 python-csound - Python bindings for Csound
 python-csoundac - Python bindings for CsoundAC
 tclcsound  - Tcl bindings and interpreters for Csound
Closes: 522414 561128 561131 571270
Changes: 
 csound (1:5.12.1~dfsg-2ubuntu1) maverick; urgency=low
 .
   * Merge from debian unstable, Ubuntu remaining changes:
     - Build with all supported python versions.
     - Update build-dependency on python-all-dev to provide python.mk rule.
 .
 csound (1:5.12.1~dfsg-2) unstable; urgency=low
 .
   * Revert unpatch hack: upsets build daemons.
 .
 csound (1:5.12.1~dfsg-1) unstable; urgency=low
 .
   [ Jonas Smedegaard ]
   * Fix Mac-encoded apostrophe in copyright, thanks to lintian.
   * Bump Standards-Version to 3.8.4.
   * Wrap long descriptions at 72 characters.
   * Fix capitalization of PureData in a long description.
   * Packaging moved to Debian Multimedia Maintainers: Update Maintainer
     and Vcs-* stanzas in control file.
   * Drop implementing DEB_MAINTAINER_MODE in rules file: handled in cdbs
     now. Drop related lintian override as well.
   * Drop package-relations.mk (last remaining local CDBS snippet):
     included in cdbs itself now.
   * Use CDBS class python-module.mk, and simplify local Python hacks in
     rules file.
   * Refresh patches, using shortening quilt options --no-timestamps
     --no-index -pab.
   * Update copyright file (new author, no new licenses).
   * Fix use DEB_UPSTREAM_REPACKAGE_EXCLUDES (not abandoned
     DEB_UPSTREAM_REPACKAGE_EXCLUDE) in rules file.
   * Tighten repackaging hints to match current (slightly cleaner)
     upstream release, in rules and copyright files.
 .
   [ Felipe Sateler ]
   * New upstream release
     - Update patches for new upstream release
     - Install crossfm opcode
     - Update symbols file
   * Drop local CDBS snippets that have been integrated in the main CDBS
     package
   * Reorder scons options
   * Reorder build-dependencies
   * Make every build option explicit
   * Fix a segfault when an ending \ is used to split a line in the
     orchestra
   * Do not set buildSDFT option, it was dropped upstream
   * Detect default tcl version and enforce it
   * Enable STK opcodes
   * Invoke the java archs resolution script in debian/rules
   * Update debian/control
 .
 csound (1:5.11.1~dfsg-4) unstable; urgency=low
 .
   [ Felipe Sateler ]
   * Change luacsnd package name in control files (this caused -3 luacsnd to be
     empty).
   * Make the lua package provide the old name.
   * Install to /usr/lib/dist-packages with python 2.6 or higher.
     Closes: #571270
   * Add DM-Upload-Allowed field.
 .
   [ Jonas Smedegaard ]
   * Stop mentioning quilt in README.source.
   * Update local CDBS snippets:
     + package-relations.mk:
       - Merge mixture of versioned and unversioned dependencies
       - Use unversioned dependencies when satisfied in oldstable
       - Improve whitespace cleanup
       - Rewrite and silence applying dependencies
       - Handle cdbs 0.4.53 dependency (needed when using debhelper v7)
     + upstream-tarball.mk:
       - Depend unversioned on cdbs (the needed 0.4.39 is in oldstable)
       - Preserve bzip2 tarballs with source format '3.0 (quilt)'.
     + copyright-check.mk:
       - More aggressive scanning (check top 99999 lines, not just 60)
       - Simplify more licensing notices and preserve non-ASCII chars
       - Group hints by sorted owner list (ignoring years)
       - Limit console output both horisontally and vertically
       - Use rev123 of draft DEP5 for hints file
   * Refer to FSF website (not postal address) in debian/rules header.
   * Rewrite copyright file using in DEP5 rev. 135 format.
   * Add DM-Upload-Allowed field to control.in.
   * Refresh patches with quilt option --no-timestamp.
   * Add rudimentary DEP3 patch headers.
   * Build-depend unversioned on cdbs.
 .
 csound (1:5.11.1~dfsg-3) unstable; urgency=low
 .
   [ Felipe Sateler ]
   * Be more verbose on mv-inside-for-loops
   * Rename the lua module (Closes: #561131)
   * Do not link against the lua library (Closes: #561128)
   * Rename the lua module as per the lua policy
   * Correct SONAME and package name of the lua bindings
   * Regenerate control file
 .
 csound (1:5.11.1~dfsg-2) unstable; urgency=low
 .
   * Fix extend local scons config.py to Include
     /usr/lib/jvm/default-java/include/linux. Thanks to
     Carlos O'Donell for thorough investigations.
   * Switch to source format 3.0 (quilt):
     + Unfuzz patches, and apply them to packaging source.
     + Stop including cdbs snippet patchsys-quilt.mk.
     + Stop build-depending on quilt or patchutils.
     + Add source format hint to packaging source.
   * Drop backportability for Etch:
     + Drop fallback build-dependencies on java-gcj-compat-dev and
       versioned tcl and tk libraries,
     + Cleanup local scons config.py to not include
       /usr/lib/jvm/java-gcj/include or /usr/include/tcl8.4.
 .
 csound (1:5.11.1~dfsg-1) unstable; urgency=low
 .
   [ Felipe Sateler ]
   * New upstream release
     - Large build-system changes
     - Update patches:
      - Fix csPerfThread.hpp path for installation
      - Fix python interface build failure.
      - Fix build failure in wrappers
      - Make scons install the interfaces library
     - Install ScoreModel.hpp
     - Install new opcodes
   * Add more -Wl,--as-needed
   * Change lua package to arch: any now that it is a proper library
   * Rely on dh_lintian for the lintian overrides
   * Use a symbols file for libcsound64
   * Bump Standards-Version, no changes needed
 .
   [ Jonas Smedegaard ]
   * Tighten -dev packages dependency on their lib package as per Debian
     Policy §8.5, thanks to lintian.
 .
 csound (1:5.10.1~dfsg1-4) unstable; urgency=low
 .
   [ Jonas Smedegaard ]
   * Strip old notes from watch file.
   * Simplify debian/copyright (based on newest DEP5 draft).
   * Fix typo in README.source: new new.
   * Update local CDBS snippets:
     + Update package-relations.mk: Cleanup unversioned+versioned
       dependency mix. Improve whitespace cleanup. Rewrite and silence
       applying dependencies.
     + Implement fail-source-not-repackaged rule in upstream-tarball.mk.
     + Update URL to draft DEP5 format in copyright-check.mk output.
   * Extend java-related (build-)dependencies to include architecures
     hppa, kfreebsd-amd64 and kfreebsd-i386.
 .
   [ Felipe Sateler ]
   * At build, import the whole environment (Closes: #522414)
Checksums-Sha1: 
 01c6945485aa55e76085d9f5d1e56feff2ccac96 2307 csound_5.12.1~dfsg-2ubuntu1.dsc
 3adb5358386c08a0b32666e05f1feb207cead1ef 5593826 csound_5.12.1~dfsg.orig.tar.gz
 0c8d00fa4e41629ddd24ea108475d786d2049642 45970 csound_5.12.1~dfsg-2ubuntu1.debian.tar.gz
Checksums-Sha256: 
 8c30a1eea6df512fb3c2e978ff1213cfcdde1dc54f4b4b3b8ce47bc7957ab265 2307 csound_5.12.1~dfsg-2ubuntu1.dsc
 954412448a27c6c40ac9b928f405555266620798df4b0c5f78f338104912373f 5593826 csound_5.12.1~dfsg.orig.tar.gz
 1d50de46a2afd2d50feeec65d518fb6bab5bab781f92b537f8ddde319a2596e4 45970 csound_5.12.1~dfsg-2ubuntu1.debian.tar.gz
Files: 
 e8fde22eaee88cce48bd301c20399a9d 2307 sound optional csound_5.12.1~dfsg-2ubuntu1.dsc
 e4188440df9c75ae196e226be21220a5 5593826 sound optional csound_5.12.1~dfsg.orig.tar.gz
 43e8453bd1aad9430939ae94754466bf 45970 sound optional csound_5.12.1~dfsg-2ubuntu1.debian.tar.gz
Original-Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkv+54EACgkQRdSMfNz8P9BWIACeNZnjmsBnNrl+EfsQQ+z2zLse
ZZcAn3P1Ih6B9uZJ1uZggzjEGfJ6h0kA
=o23s
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list