[ubuntu/maverick] evolution 2.30.1.2-1ubuntu1 (Accepted)

Didier Roche didrocks at ubuntu.com
Tue May 18 10:45:54 BST 2010


evolution (2.30.1.2-1ubuntu1) maverick; urgency=low

  * Merge from debian experimental:
    + debian/control:
      - add Vcs-Bzr tag
      - don't build depends on pilot-link it's not required
      - don't use po-debconf there either
      - build-depends on libpst, python and shared-mime-info
      - set gnome-pilot-conduits as suggests
      - don't split documentation since it goes to langpacks
      - evolution replaces evolution-plugins (<< 2.22.2-1)
        since the bogofilter plugin has been moved there
      - evolution-plugins-experimental replaces evolution-plugins (<< 2.27)
      - updated descriptions to reflect binary installs
      - remove libgtkimageview-dev build-dep: not in main, seems crashy right
        now
    + debian/docs:
      - renamed evolution-common.docs
    + debian/evolution-2.2.desktop:
      - compatibility .desktop for users upgrading
    + debian/evolution.gconf-defaults:
      - don't display unstable warning on startup (Ubuntu: #91799)
    + debian/evolution.install:
      - install the autostart and compatibility desktop entries
      - install webdav and python but not hula and print-message there
    + debian/evolution-mail.desktop:
      - don't reapply this ubuntu change and use only one menu entry
    + debian/evolution-alarm-notify.desktop,
      debian/evolution-alarm-notify.desktop.in,
      #debian/patches/64_translate_autostart_strings.patch: #
      - autostart desktop file to start evolution-alarm-notify with the session,
        translate the entry
    + debian/evolution-dev.install:
      - detail the .so to install
    + debian/evolution-plugins.install,
      debian/evolution-plugins-experimental.install:
      - install the .so in binaries corresponding to the upstream options
    + debian/patches/01_dont-ship-evo-mail-notifier.png.patch:
      - don't ship that change that debian added without reason
    + debian/evolution.preinst, debian/evolution.templates:
      - don't display debconf template on upgrade
    + debian/patches/03_lpi.patch:
      - launchpad-integration patch
    + debian/patches/62_no_upstream_email_notification_by_default.patch:
      - don't enable the notification icon by default since the message indicator
        is running
    + debian/patches/10_desktop_shortcuts.patch
      - Adds desktop shortcuts for the messaging menu.
    + debian/rules:
      - don't use -Bsymbolic-functions to workaround memos crashing
      - don't use debconf translation there
      - use --disable-scrollkeeper --enable-python configure option
      - use --disable-inline-plugin: dep not in main, seems crashy right now
    + debian/patches/90_autoconf.patch:
      - refresh autotool

evolution (2.30.1.2-1) experimental; urgency=low

  * New upstream bugfix release.
  * debian/patches:
    - 03_fix-face-plugin-linking dropped, included upstream.

evolution (2.30.1.1-1) experimental; urgency=low

  * New upstream bugfix release. (LP: #154752)
  * debian/patches:
    - 03_fix-face-plugin-linking, fix ftbfs with face plugin.
  * debian/control:
    - bump (build-)deps to gtkhtml/eds 2.30.1.

evolution (2.30.0.1-1) experimental; urgency=low

  * New upstream release.
  * debian/watch updated to track stable releases.
  * debian/control:
    - bump eds and gtkhtml build-deps to 2.30.
  * debian/evolution-mail.desktop: update components version to 2.30.
  * debian/lintian/evolution-common:
    - add an override for evolution-settings command not being in the package.
  * debian/lintian:
    - evolution-plugins dropped, useless now.
    - evolution-plugins-experimental dropped as well.
  * debian/evolution-plugins-experimental.install,
      debian/evolution-plugins.install: don't install lintian overrides.

evolution (2.29.92.1-1) experimental; urgency=low

  * New upstream release candidate.
  * debian/copyright updated.

evolution (2.29.92-1) experimental; urgency=low

  * New upstream release candidate. (LP: #433674, #198392)
  * debian/control:
    - bump build-deps on eds and gtkhtml.
  * debian/rules:
    - remove deprecated --enable-nntp arg to configure.

evolution (2.29.91-1) experimental; urgency=low

  * New upstream release candidate. (LP: #478976, #409795,
  * debian/control:
    - bump build-deps on eds and gtkhtml.

evolution (2.29.90-1) experimental; urgency=low

  * New upstream release candidate.
  * debian/control:
    - bump build-deps on eds et gtkhtml.
    - add build-dep on libunique-dev.
    - bump standards version to 3.8.4.

evolution (2.29.6-1) experimental; urgency=low

  * New upstream development release.
  * debian/control:
    - bump eds and gtkhtml versions to 2.29.6.
  * debian/rules:
    - disable nm on non Linux builds, fix FTBFS on kFreeBSD.    closes: #566928
  * debian/patches
    - 02_fix-gtkdoc dropped.

evolution (2.29.5-1) experimental; urgency=low

  * New upstream development release. (LP: #471825)
  * debian/control:
    - drop build-dep on libgnomeprint.
    - bump eds and gtkhtml versions to 2.29.5.
    - bump GTK+ build-dep to 2.18.
    - drop build-dep on hal.
    - drop build-dep on gnome-pilot.
  * debian/patches:
    - drop 02_fix-ftbfs-pilot_charset.
    - 02_fix-gtkdoc added, fix FTBFS with gtk-doc 1.13.
  * drop gnome-pilot support.  *

evolution (2.29.3.2-1) experimental; urgency=low

  * New upstream release.
  * debian/control:
    - add libgtkhtml3.14-dev to evolution-dev dependencies.
    - bump glib build-dep to 2.22.

evolution (2.29.3-1) experimental; urgency=low

  * New upstream release. (LP: #414666, #289205)
  * debian/control:
    - update build deps for gtkhtml 3.29.3 and eds 2.29.3.
    - drop libglade build-dep.
  * debian/rules:
    - don't build contact-map plugin for now.
  * debian/patches:
    - 02_fix-ftbfs-pilot_charset added, fix FTBFS because of unknown component
      in structure by reverting the culprit commit (GNOME #603452).
  * debian/*.install:
    - don't install non existent .glade files.
  * debian/libevolution.install: install killev in the package.

evolution (2.29.2-1) experimental; urgency=low

  [2.29.1]
  * New upstream development release. (LP: #452044, #145132, #470169, #319910)
    (LP: #251417, #460054, #429008, #444493, #365037, #182575, #431899)
    (LP: #105849, #530255, #115039, #376523, #487655, #145354)
  * debian/watch updated to track development releases.
  * debian/control:
    - add a new libevolution package to separate the libs from the main
      package.
    - update build deps:
      + drop bonobo, gnomeui, and libexchange-storage ;
      + add libunique-dev, libcanberra-dev, libcanberra-gtk-dev ;
      + update gtkhtml and eds to 2.29.1.
  * debian/{lib,}evolution.install: ship libs in the libevolution package.
  * debian/rules:
    - update ELIBDIR to 2.30.
    - don't build exchange plugin now inexistant.
    - drop unknown configure options:
      + --without-openssl-includes, --without-openssl-libs, --disable-openssl
      + --enable-cairo-calendar,
      + --without-krb4,
      + --enable-ipv6,
    - don't build pstimport plugin since we don't have libpst in Debian.
  * debian/lintian: update paths to 2.29.
  * debian/*.install:
    - update paths to 2.30 ;
    - move vcard, custom-headers, webdav and templates plugin from
      experimental to base package.
  * debian/evolution-dev.install:
    - drop bonobo interface folder.

  [2.29.2]
  * New upstream development release.
  * debian/control:
    - update build-deps for 2.29.2.
    - add build-deps on libgtkimageview-dev.
  * debian/evolution-plugins.install:
    - add inline image viewer plugin.
  * debian/links:
    - drop manpage symlink.
    - add evolution-addressbook-clean and evolution-backup synlinks to
      /usr/bin.

evolution (2.28.3-1) unstable; urgency=low

  * New upstream bugfix release.
  * debian/patches:
    - 03_evo-addr-export-segfault dropped, included upstream.
  * debian/control:
    - update build-deps to 2.28.3 for eds and gtkhtml.
    - update standards version to 3.8.4.

Date: Mon, 17 May 2010 13:54:05 +0200
Changed-By: Didier Roche <didrocks at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Didier Roche <didier.roche at canonical.com>
https://launchpad.net/ubuntu/maverick/+source/evolution/2.30.1.2-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 17 May 2010 13:54:05 +0200
Source: evolution
Binary: evolution libevolution evolution-common evolution-dev evolution-dbg evolution-plugins evolution-plugins-experimental
Architecture: source
Version: 2.30.1.2-1ubuntu1
Distribution: maverick
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Didier Roche <didrocks at ubuntu.com>
Description: 
 evolution  - groupware suite with mail client and organizer
 evolution-common - architecture independent files for Evolution
 evolution-dbg - debugging symbols for Evolution
 evolution-dev - development library files for Evolution
 evolution-plugins - standard plugins for Evolution
 evolution-plugins-experimental - experimental plugins for Evolution
 libevolution - evolution libraries
Closes: 566928
Launchpad-Bugs-Fixed: 105849 115039 145132 145354 154752 182575 198392 251417 289205 319910 365037 376523 409795 414666 429008 431899 433674 444493 452044 460054 470169 471825 478976 487655 530255
Changes: 
 evolution (2.30.1.2-1ubuntu1) maverick; urgency=low
 .
   * Merge from debian experimental:
     + debian/control:
       - add Vcs-Bzr tag
       - don't build depends on pilot-link it's not required
       - don't use po-debconf there either
       - build-depends on libpst, python and shared-mime-info
       - set gnome-pilot-conduits as suggests
       - don't split documentation since it goes to langpacks
       - evolution replaces evolution-plugins (<< 2.22.2-1)
         since the bogofilter plugin has been moved there
       - evolution-plugins-experimental replaces evolution-plugins (<< 2.27)
       - updated descriptions to reflect binary installs
       - remove libgtkimageview-dev build-dep: not in main, seems crashy right
         now
     + debian/docs:
       - renamed evolution-common.docs
     + debian/evolution-2.2.desktop:
       - compatibility .desktop for users upgrading
     + debian/evolution.gconf-defaults:
       - don't display unstable warning on startup (Ubuntu: #91799)
     + debian/evolution.install:
       - install the autostart and compatibility desktop entries
       - install webdav and python but not hula and print-message there
     + debian/evolution-mail.desktop:
       - don't reapply this ubuntu change and use only one menu entry
     + debian/evolution-alarm-notify.desktop,
       debian/evolution-alarm-notify.desktop.in,
       #debian/patches/64_translate_autostart_strings.patch: #
       - autostart desktop file to start evolution-alarm-notify with the session,
         translate the entry
     + debian/evolution-dev.install:
       - detail the .so to install
     + debian/evolution-plugins.install,
       debian/evolution-plugins-experimental.install:
       - install the .so in binaries corresponding to the upstream options
     + debian/patches/01_dont-ship-evo-mail-notifier.png.patch:
       - don't ship that change that debian added without reason
     + debian/evolution.preinst, debian/evolution.templates:
       - don't display debconf template on upgrade
     + debian/patches/03_lpi.patch:
       - launchpad-integration patch
     + debian/patches/62_no_upstream_email_notification_by_default.patch:
       - don't enable the notification icon by default since the message indicator
         is running
     + debian/patches/10_desktop_shortcuts.patch
       - Adds desktop shortcuts for the messaging menu.
     + debian/rules:
       - don't use -Bsymbolic-functions to workaround memos crashing
       - don't use debconf translation there
       - use --disable-scrollkeeper --enable-python configure option
       - use --disable-inline-plugin: dep not in main, seems crashy right now
     + debian/patches/90_autoconf.patch:
       - refresh autotool
 .
 evolution (2.30.1.2-1) experimental; urgency=low
 .
   * New upstream bugfix release.
   * debian/patches:
     - 03_fix-face-plugin-linking dropped, included upstream.
 .
 evolution (2.30.1.1-1) experimental; urgency=low
 .
   * New upstream bugfix release. (LP: #154752)
   * debian/patches:
     - 03_fix-face-plugin-linking, fix ftbfs with face plugin.
   * debian/control:
     - bump (build-)deps to gtkhtml/eds 2.30.1.
 .
 evolution (2.30.0.1-1) experimental; urgency=low
 .
   * New upstream release.
   * debian/watch updated to track stable releases.
   * debian/control:
     - bump eds and gtkhtml build-deps to 2.30.
   * debian/evolution-mail.desktop: update components version to 2.30.
   * debian/lintian/evolution-common:
     - add an override for evolution-settings command not being in the package.
   * debian/lintian:
     - evolution-plugins dropped, useless now.
     - evolution-plugins-experimental dropped as well.
   * debian/evolution-plugins-experimental.install,
       debian/evolution-plugins.install: don't install lintian overrides.
 .
 evolution (2.29.92.1-1) experimental; urgency=low
 .
   * New upstream release candidate.
   * debian/copyright updated.
 .
 evolution (2.29.92-1) experimental; urgency=low
 .
   * New upstream release candidate. (LP: #433674, #198392)
   * debian/control:
     - bump build-deps on eds and gtkhtml.
   * debian/rules:
     - remove deprecated --enable-nntp arg to configure.
 .
 evolution (2.29.91-1) experimental; urgency=low
 .
   * New upstream release candidate. (LP: #478976, #409795,
   * debian/control:
     - bump build-deps on eds and gtkhtml.
 .
 evolution (2.29.90-1) experimental; urgency=low
 .
   * New upstream release candidate.
   * debian/control:
     - bump build-deps on eds et gtkhtml.
     - add build-dep on libunique-dev.
     - bump standards version to 3.8.4.
 .
 evolution (2.29.6-1) experimental; urgency=low
 .
   * New upstream development release.
   * debian/control:
     - bump eds and gtkhtml versions to 2.29.6.
   * debian/rules:
     - disable nm on non Linux builds, fix FTBFS on kFreeBSD.    closes: #566928
   * debian/patches
     - 02_fix-gtkdoc dropped.
 .
 evolution (2.29.5-1) experimental; urgency=low
 .
   * New upstream development release. (LP: #471825)
   * debian/control:
     - drop build-dep on libgnomeprint.
     - bump eds and gtkhtml versions to 2.29.5.
     - bump GTK+ build-dep to 2.18.
     - drop build-dep on hal.
     - drop build-dep on gnome-pilot.
   * debian/patches:
     - drop 02_fix-ftbfs-pilot_charset.
     - 02_fix-gtkdoc added, fix FTBFS with gtk-doc 1.13.
   * drop gnome-pilot support.  *
 .
 evolution (2.29.3.2-1) experimental; urgency=low
 .
   * New upstream release.
   * debian/control:
     - add libgtkhtml3.14-dev to evolution-dev dependencies.
     - bump glib build-dep to 2.22.
 .
 evolution (2.29.3-1) experimental; urgency=low
 .
   * New upstream release. (LP: #414666, #289205)
   * debian/control:
     - update build deps for gtkhtml 3.29.3 and eds 2.29.3.
     - drop libglade build-dep.
   * debian/rules:
     - don't build contact-map plugin for now.
   * debian/patches:
     - 02_fix-ftbfs-pilot_charset added, fix FTBFS because of unknown component
       in structure by reverting the culprit commit (GNOME #603452).
   * debian/*.install:
     - don't install non existent .glade files.
   * debian/libevolution.install: install killev in the package.
 .
 evolution (2.29.2-1) experimental; urgency=low
 .
   [2.29.1]
   * New upstream development release. (LP: #452044, #145132, #470169, #319910)
     (LP: #251417, #460054, #429008, #444493, #365037, #182575, #431899)
     (LP: #105849, #530255, #115039, #376523, #487655, #145354)
   * debian/watch updated to track development releases.
   * debian/control:
     - add a new libevolution package to separate the libs from the main
       package.
     - update build deps:
       + drop bonobo, gnomeui, and libexchange-storage ;
       + add libunique-dev, libcanberra-dev, libcanberra-gtk-dev ;
       + update gtkhtml and eds to 2.29.1.
   * debian/{lib,}evolution.install: ship libs in the libevolution package.
   * debian/rules:
     - update ELIBDIR to 2.30.
     - don't build exchange plugin now inexistant.
     - drop unknown configure options:
       + --without-openssl-includes, --without-openssl-libs, --disable-openssl
       + --enable-cairo-calendar,
       + --without-krb4,
       + --enable-ipv6,
     - don't build pstimport plugin since we don't have libpst in Debian.
   * debian/lintian: update paths to 2.29.
   * debian/*.install:
     - update paths to 2.30 ;
     - move vcard, custom-headers, webdav and templates plugin from
       experimental to base package.
   * debian/evolution-dev.install:
     - drop bonobo interface folder.
 .
   [2.29.2]
   * New upstream development release.
   * debian/control:
     - update build-deps for 2.29.2.
     - add build-deps on libgtkimageview-dev.
   * debian/evolution-plugins.install:
     - add inline image viewer plugin.
   * debian/links:
     - drop manpage symlink.
     - add evolution-addressbook-clean and evolution-backup synlinks to
       /usr/bin.
 .
 evolution (2.28.3-1) unstable; urgency=low
 .
   * New upstream bugfix release.
   * debian/patches:
     - 03_evo-addr-export-segfault dropped, included upstream.
   * debian/control:
     - update build-deps to 2.28.3 for eds and gtkhtml.
     - update standards version to 3.8.4.
Checksums-Sha1: 
 1a3ac4102b9faf710d3037fa6bb2a12adf513e20 3087 evolution_2.30.1.2-1ubuntu1.dsc
 f7e1b4c5d99c6645113a2fc710cb8d5f13769dc4 37558791 evolution_2.30.1.2.orig.tar.gz
 da6c779d2ba52ad488d46c22c2c1d8148a12ecd1 38841 evolution_2.30.1.2-1ubuntu1.diff.gz
Checksums-Sha256: 
 7204a218e6b131d912bd521ec912a2416ddba4a343e1b846b7b2e8308112de72 3087 evolution_2.30.1.2-1ubuntu1.dsc
 6de26e05cadc141c95254314a3ce7328318c76d5117433d9984d3ff1c6d52045 37558791 evolution_2.30.1.2.orig.tar.gz
 a0a5cfafa2353ff321b95a1334e5e2b7322fff57a1fc32fb96a6884dbd235a16 38841 evolution_2.30.1.2-1ubuntu1.diff.gz
Files: 
 45b221778e34d6f39f5451d1a868882c 3087 gnome optional evolution_2.30.1.2-1ubuntu1.dsc
 c7811e840914a95aaa88f7d58cc9abb9 37558791 gnome optional evolution_2.30.1.2.orig.tar.gz
 6306186da3aab059ecf65f638c274880 38841 gnome optional evolution_2.30.1.2-1ubuntu1.diff.gz
Original-Maintainer: Debian Evolution Maintainers <pkg-evolution-maintainers at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkvyXugACgkQmLJKnOSsII67qwCfUvfsTVbjjX2l+uXUWeoEw4rv
Z0kAnjm9hvSfAQtcWgkaUmgRGRiPuzMZ
=op/9
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list