[ubuntu/maverick] ghostscript 8.71.dfsg.2-0ubuntu3 (Accepted)

Marc Deslauriers marc.deslauriers at ubuntu.com
Thu Jul 22 11:45:28 BST 2010


ghostscript (8.71.dfsg.2-0ubuntu3) maverick; urgency=low

  * SECURITY UPDATE: arbitrary code execution via unlimited recursive
    procedure invocations (LP: #546009)
    - debian/patches/CVE-2010-1628.dpatch: only initialize structures if
      all allocations were successful in psi/ialloc.c, psi/idosave.h,
      psi/isave.c.
    - CVE-2010-1628

Date: Thu, 22 Jul 2010 12:19:37 +0200
Changed-By: Marc Deslauriers <marc.deslauriers at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/maverick/+source/ghostscript/8.71.dfsg.2-0ubuntu3
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 22 Jul 2010 12:19:37 +0200
Source: ghostscript
Binary: ghostscript gs gs-esp gs-gpl gs-aladdin gs-common ghostscript-cups ghostscript-x gs-esp-x ghostscript-doc libgs8 libgs-dev libgs-esp-dev
Architecture: source
Version: 8.71.dfsg.2-0ubuntu3
Distribution: maverick
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Marc Deslauriers <marc.deslauriers at ubuntu.com>
Description: 
 ghostscript - The GPL Ghostscript PostScript/PDF interpreter
 ghostscript-cups - The GPL Ghostscript PostScript/PDF interpreter - CUPS filters
 ghostscript-doc - The GPL Ghostscript PostScript/PDF interpreter - Documentation
 ghostscript-x - The GPL Ghostscript PostScript/PDF interpreter - X Display suppor
 gs         - Transitional package
 gs-aladdin - Transitional package
 gs-common  - Dummy package depending on ghostscript
 gs-esp     - Transitional package
 gs-esp-x   - Transitional package
 gs-gpl     - Transitional package
 libgs-dev  - The Ghostscript PostScript Library - Development Files
 libgs-esp-dev - Transitional package
 libgs8     - The Ghostscript PostScript/PDF interpreter Library
Launchpad-Bugs-Fixed: 546009
Changes: 
 ghostscript (8.71.dfsg.2-0ubuntu3) maverick; urgency=low
 .
   * SECURITY UPDATE: arbitrary code execution via unlimited recursive
     procedure invocations (LP: #546009)
     - debian/patches/CVE-2010-1628.dpatch: only initialize structures if
       all allocations were successful in psi/ialloc.c, psi/idosave.h,
       psi/isave.c.
     - CVE-2010-1628
Checksums-Sha1: 
 ab5ad76e157b1c14d6a17a119474f004c9da96ae 1833 ghostscript_8.71.dfsg.2-0ubuntu3.dsc
 ba72b5ea68c5d2a375803312b288a349eb8ff429 61301 ghostscript_8.71.dfsg.2-0ubuntu3.diff.gz
Checksums-Sha256: 
 90b33b2ebda3e966ecf838bcfe880633830a014ecff4e3330850a436e04fe689 1833 ghostscript_8.71.dfsg.2-0ubuntu3.dsc
 734505beb615b00c18f15aab412b3c9f220be41c0ab2192ea857de98ee13c61b 61301 ghostscript_8.71.dfsg.2-0ubuntu3.diff.gz
Files: 
 fb134e1265b3174d0577a78abc9d7a58 1833 text optional ghostscript_8.71.dfsg.2-0ubuntu3.dsc
 0efd5bd8b691a351e074228833d07d33 61301 text optional ghostscript_8.71.dfsg.2-0ubuntu3.diff.gz
Original-Maintainer: Masayuki Hatta (mhatta) <mhatta at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkxIHwgACgkQLMAs/0C4zNps8QCguEPZSeuqS7fFB8X9gSruHG8J
EmkAnjbelUDcgoi4TUjMU5XqxRgNdHSM
=sUVE
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list