[ubuntu/maverick] alsa-utils 1.0.23-2ubuntu1 (Accepted)

Luke Yelavich themuso at ubuntu.com
Mon Jul 19 09:40:30 BST 2010


alsa-utils (1.0.23-2ubuntu1) maverick; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/init:
      + wait until /usr/bin and /var/lib/alsa exist
      + only display an error when dealing with alsactl if there is no card
        specified
      + Set sane level for 'Speaker' and 'Headphone', needed for Dell Mini 9
        and Dell E series
      + ute PC Beep on hda cards that support it during initial volume setup
      + update lsb header to indicate no running of the script unless the
        udev rule is run
      + Mute *Analog/Digital Control for Creative cards by default
      + Default Digital Input Source to be Digital Mic 1 so that users
        with digital mic will be able to use it out of the box
      + Mute "IEC958 Optical Raw" by default
      + Set sane level for headphone 1 for Dell Studio XPS with 2.6.30
      + Don't muck with sound card state if alsactl restore fails
      + Don't wait for 1 second after alsactl store
      + Stop muting on reboot/shutdown
      + Prefer built-in digital mics on newer Dells
      + Unmute 'Line HP Swap' for Dove boards
    - debian/rules:
      + ship udev rules file in /lib/udev/rules.d
      + Do not install start symlinks for the alsa-utils init script, it gets
        run from a udev rule
    - debian/udev.script: do not use hotplug functions
    - debian/README.init.cs4236: Include in /usr/share/doc/alsa-utils so that
      users of snd-cs4236 (e.g., ThinkPad 600) can have audible sound
    - debian/patches/unset_pulse_internal.patch: We don't want alsamixer to
      show the pulse mixer by default, since it can be controlled from
      pulseaudio itself
    - debian/patches/fix_misspelling_speaker-test_man_page.patch: Fix
      misspelling in speaker-test(1)
    - Remove alsaconf from build system and remove po files
    - Create an upstart job specifically saving mixer levels to resolve race
    - Version build-dep to upstart-aware debhelper.
    - Move the initscript into /sbin. We now have an upstart job just for
      handling alsactl store
  * debian/init: Revert Debian's change to allow alsamixer/amixer and aumix to
    cooperate. OSS is going away in Maverick, so we don't care about OSS mixer
    applications any more

alsa-utils (1.0.23-2) unstable; urgency=low

  [ Elimar Riesebieter ]
  * Let dh_installinit install the LSB defaults. Thanks Sven Joachim for the
    hint. (closes: #584311)

  [ Jordi Mallach ]
  * Add a trailing newline to debian/NEWS to placate lintian.

alsa-utils (1.0.23-1) unstable; urgency=low

  * New upstream release.

  [ Elimar Riesebieter ]
  * Add powerpcspe to the list of supported architectures. Hint by Sebastian
    Andrzej Siewior. (closes: #583617)
  * Introduced DEP-3 patch headers.

  [ Jordi Mallach ]
  * Bump Standards-Version to 3.8.4, no changes required.
  * Add sparc64 to the list of supported architectures.
  * Remove lpia from the list of supported architectures, as it's not used
    by Ubuntu anymore.

Date: Mon, 19 Jul 2010 10:24:10 +0200
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Luke Yelavich <luke.yelavich at canonical.com>
https://launchpad.net/ubuntu/maverick/+source/alsa-utils/1.0.23-2ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 19 Jul 2010 10:24:10 +0200
Source: alsa-utils
Binary: alsa-utils
Architecture: source
Version: 1.0.23-2ubuntu1
Distribution: maverick
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Description: 
 alsa-utils - Utilities for configuring and using ALSA
Closes: 583617 584311
Changes: 
 alsa-utils (1.0.23-2ubuntu1) maverick; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     - debian/init:
       + wait until /usr/bin and /var/lib/alsa exist
       + only display an error when dealing with alsactl if there is no card
         specified
       + Set sane level for 'Speaker' and 'Headphone', needed for Dell Mini 9
         and Dell E series
       + ute PC Beep on hda cards that support it during initial volume setup
       + update lsb header to indicate no running of the script unless the
         udev rule is run
       + Mute *Analog/Digital Control for Creative cards by default
       + Default Digital Input Source to be Digital Mic 1 so that users
         with digital mic will be able to use it out of the box
       + Mute "IEC958 Optical Raw" by default
       + Set sane level for headphone 1 for Dell Studio XPS with 2.6.30
       + Don't muck with sound card state if alsactl restore fails
       + Don't wait for 1 second after alsactl store
       + Stop muting on reboot/shutdown
       + Prefer built-in digital mics on newer Dells
       + Unmute 'Line HP Swap' for Dove boards
     - debian/rules:
       + ship udev rules file in /lib/udev/rules.d
       + Do not install start symlinks for the alsa-utils init script, it gets
         run from a udev rule
     - debian/udev.script: do not use hotplug functions
     - debian/README.init.cs4236: Include in /usr/share/doc/alsa-utils so that
       users of snd-cs4236 (e.g., ThinkPad 600) can have audible sound
     - debian/patches/unset_pulse_internal.patch: We don't want alsamixer to
       show the pulse mixer by default, since it can be controlled from
       pulseaudio itself
     - debian/patches/fix_misspelling_speaker-test_man_page.patch: Fix
       misspelling in speaker-test(1)
     - Remove alsaconf from build system and remove po files
     - Create an upstart job specifically saving mixer levels to resolve race
     - Version build-dep to upstart-aware debhelper.
     - Move the initscript into /sbin. We now have an upstart job just for
       handling alsactl store
   * debian/init: Revert Debian's change to allow alsamixer/amixer and aumix to
     cooperate. OSS is going away in Maverick, so we don't care about OSS mixer
     applications any more
 .
 alsa-utils (1.0.23-2) unstable; urgency=low
 .
   [ Elimar Riesebieter ]
   * Let dh_installinit install the LSB defaults. Thanks Sven Joachim for the
     hint. (closes: #584311)
 .
   [ Jordi Mallach ]
   * Add a trailing newline to debian/NEWS to placate lintian.
 .
 alsa-utils (1.0.23-1) unstable; urgency=low
 .
   * New upstream release.
 .
   [ Elimar Riesebieter ]
   * Add powerpcspe to the list of supported architectures. Hint by Sebastian
     Andrzej Siewior. (closes: #583617)
   * Introduced DEP-3 patch headers.
 .
   [ Jordi Mallach ]
   * Bump Standards-Version to 3.8.4, no changes required.
   * Add sparc64 to the list of supported architectures.
   * Remove lpia from the list of supported architectures, as it's not used
     by Ubuntu anymore.
Checksums-Sha1: 
 e71f04fec1acde2b71cbf4469b688bc01106246f 1724 alsa-utils_1.0.23-2ubuntu1.dsc
 ea88bbcac023ef6828aa8175b4311fdd1c2de726 122520 alsa-utils_1.0.23-2ubuntu1.debian.tar.bz2
Checksums-Sha256: 
 6f6dc42624ea316cf47f4ce117ca1257c1ebaee93578f9fcd185036d12308e34 1724 alsa-utils_1.0.23-2ubuntu1.dsc
 cb388efe2e2d0792c73420d9eff0caa50377bd41fa91c796fc30519813eff3d3 122520 alsa-utils_1.0.23-2ubuntu1.debian.tar.bz2
Files: 
 86d06fef6fcc9d72cbd6172104f64fc8 1724 sound optional alsa-utils_1.0.23-2ubuntu1.dsc
 367e2824768725e2dc1f465bad2d64d6 122520 sound optional alsa-utils_1.0.23-2ubuntu1.debian.tar.bz2
Original-Maintainer: Debian ALSA Maintainers <pkg-alsa-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkxEC+UACgkQjVefwtBjIM6ZvgCg0ElfOOrPmZwCVrxz6jHBoVEz
5gMAnR6sB0/KX4aa+ezNMfo1lIVHTtwj
=Wx86
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list