[ubuntu/maverick] kernel-wedge 2.63ubuntu1 (Accepted)

Colin Watson cjwatson at ubuntu.com
Thu Jul 15 17:15:23 BST 2010


kernel-wedge (2.63ubuntu1) maverick; urgency=low

  * Resynchronise with Debian.  Remaining changes:
    - Firmware udeb handling (copy-firmware and related changes).

kernel-wedge (2.63) unstable; urgency=low

  [ Frans Pop ]
  * Updates for 2.6.32.
    - Add dependency on nls-core-modules to usb-modules.
    - Add dependency on usb-modules to sound-modules.
    - New udeb for basic i2c modules. Currently only contains i2c-core, which
      is needed by nic-extra and sound on amd64.
  * Cleanup; reduces compatibility with old kernel versions.
    - Drop generic modules that have been renamed or no longer exist. And
      remove the "optional" indicator for some of the replacement modules.
    - Drop no longer used udebs isa-pnp-modules and socket-modules.
    - Drop the cdrom-modules udeb for linux. No architecture kernel provides
      any of the modules listed in it any more.
    - Drop various obsolete modules:
      - ide-modules: adma100, hpt34x, ataraid, hptraid, medley, pdcraid, silraid
      - multipath-modules: dm-emc
      - nic-extra-modules: eepro100, sk98lin, dgrs, arl1
      - nic-pcmcia-modules: xircom_tulip_cb
      - nic-wireless-modules: bcm43xx, iwl4965
      - sata-modules: carmel
      - scsi-modules: NCR53C9x, eata_pio, mca_53c9x, psi240i, qlogicfc,
        qla2100, qla2200, qla2300, qla2322, qla6312, qlogicisp
      - usb-serial-modules: whiteheat, cp2101
  * core-modules: drop firmware_class as it's compiled in for recent kernels.
  * Define standard input-modules and mouse-modules. For input-modules add
    selected modules with vendor-specific hid quirks needed to support some
    keyboards (see e.g. #561036). Closes: #567431.
  * Change priority of reiserfs-modules from standard to extra.
  * Add mmc-core-modules udeb as the b44 driver in nic-pcmcia-modules has a
    dependency on mmc_core (because of Sonics Silicon Backplane support).

  [ Frederik Schüler ]
  * Add mpt2sas module to scsi-extra-modules.
  * Add 3w-sas module to scsi-extra-modules.

  [ Otavio Salvador ]
  * Bump Standards-Version; no changes needed.
  * net-wireless-modules: add b43. Closes: #547731.
  * debian/control: add ${misc:Depends}.

kernel-wedge (2.62) unstable; urgency=low

  [ Colin Watson ]
  * In case of error, try to list more failures before bailing out.
    Requested by Tim Gardner (LP: #410221).
  * Upgrade to debhelper v7.

  [ Aurelien Jarno ]
  * On kfreebsd-i386, consider acpi.ko as part of the kernel as it has
    to be loaded by the bootloader.
  * Rework all kfreebsd modules.
  * Change "Linux kernel" into "kernel" in the descriptions so that they
    can be used on kFreeBSD too.

kernel-wedge (2.61) unstable; urgency=low

  * package-list: drop atl2-modules areen't used anymore.
  * nic-extra-modules: add atl1c and atl2 modules.

kernel-wedge (2.60) unstable; urgency=low

  * ppp-modules, isofs-modules, jffs2-module, squashfs-modules: do not
    depends on zlib-modules anymore since it is built-in in most
    architectures.
  * zlib-modules: droped since no package in official architecture uses
    it anymore.

kernel-wedge (2.59) unstable; urgency=low

  [ Samuel Thibault ]
  * sound-modules: Add 2.6.30 modules.

  [ Luca Favatella ]
  * Add ntfs-modules on kFreeBSD.

  [ Otavio Salvador ]
  * nic-wireless-modules: hermes is now optional.

kernel-wedge (2.58) unstable; urgency=low

  * ext4-modules: depends on core-modules.

kernel-wedge (2.57) unstable; urgency=low

  * ext4-modules: add package description.

kernel-wedge (2.56) unstable; urgency=low

  * squashfs-modules: depends on zlib-modules.

kernel-wedge (2.55) unstable; urgency=low

  [ Samuel Thibault ]
  * Add sound-modules. Closes: #524531.

kernel-wedge (2.54) unstable; urgency=low

  [ Colin Watson ]
  * Add ext4-modules.

  [ Otavio Salvador ]
  * core-modules: firmware_class is no longer available.
  * nic-extra-modules: remove duplicated acenic entry.
  * scsi-core-modules: add scsi_dh.
  * multipath-modules: depends on scsi-core-modules since it uses scsi_dh.
  * crypto-core-modules: dropped.
  * Update standards version to 3.8.1.
  * atl2-modules: dropped since they're available on 2.6.29.

  [ Martin Michlmayr ]
  * ide-modules: Include ide-gd_mod (for ATA/ATAPI disks and floppy;
    ide-disk got renamed.)

  [ Kenshi Muto ]
  * nic-extra-modules: make eepro100 optional.
                       add jme, enic, be2net, myri10ge, sc92031.
  * nic-wireless-modules: add ath9k, iwlagn.
  * nic-usb-modules: add rtl8187.
  * core-modules: add led-class.
  * mmc-modules: depends on core-modules.

  [ Ian Campbell ]
  * Add Xen disk and network modules.

kernel-wedge (2.53) unstable; urgency=low

  [ Samuel Thibault ]
  * Add uinput-modules.

kernel-wedge (2.52) unstable; urgency=low

  [ Frans Pop ]
  * Add mmc-modules udeb to support MMC and SD cards.

kernel-wedge (2.51) unstable; urgency=low

  * Move pata-sis to sata-modules since sata-sis depends on pata-sis and
    we wouldn't like to handle that dependency change so late on release

kernel-wedge (2.50) unstable; urgency=low

  * Add it8213 to ide-modules. Closes: #496644.

kernel-wedge (2.49) unstable; urgency=low

  * Add atl2 modules. Closes: #490354.
  * Add pata-sch to pata-modules.
  * Move sata-sis from pata-modules to sata-modules (uh?).
  * Add acenic, atl1e and sfc to nic-extra-modules.
  * Add spcp8x5 to usb-serial-modules.
  * Replace rtc with rtc-cmos on rtc-modules.

kernel-wedge (2.48) unstable; urgency=low

  * Add raid10 to md-modules.

kernel-wedge (2.47) unstable; urgency=low

  * Remove nls_iso8859-1 module, add nls_utf8. The latter is the new default
    for fat on 2.6.25. Closes: #490562

kernel-wedge (2.46) unstable; urgency=low

  [ Jérémy Bobbio ]
  * Add virtio-modules package used to improve I/O when run inside a
    compatible emulator.

  [ Ian Campbell ]
  * Make generic_serial optional to allow 686-bigmem udebs.

  [ Frans Pop ]
  * Apply patch from Per Andersson to add a jffs2 modules udeb.
  * Update standards version to 3.8.0.

kernel-wedge (2.45) unstable; urgency=low

  [ Frans Pop ]
  * Updates for 2.6.25.
  * scsi-modules: atp870u is no longer available.
  * crypto-core-modules: blkcipher has been renamed to crypto_blkcipher.
  * Move the dm-crypt module from md-modules to a new udeb crypto-dm-modules
    to avoid having md-modules depend on crypto-core-modules; dependencies on
    crypto-core-modules are now defined in kernel-wedge.
  * Move the isofs module from ide-modules to a new udeb isofs-modules because
    of its dependency on the new nls_base module; let cdrom-core-modules
    depend on isofs-modules.
  * Add an nls-core-modules udeb for the nls_base module. All nls_* modules
    and several filesystem modules depend on it.

  [ Otavio Salvador ]
  * cdrom-core-modules: add ide-cd_mod since it replaces ide-cd now.
  * nic-extra-modules: add enc28j60, igb and r6040.
  * nic-usb-modules: add rndis_wlan and rtl8180.
  * scsi-extra-modules: add mvsas.
  * speakup-modules: created. Thanks to Samuel Thibault
    <samuel.thibault at ens-lyon.org> for the patch. Closes: #479227.
  * nic-wireless-modules: add iwl3945 and iwl4965 since we now support
    firmware loading during installation process. Thanks to Glenn Saberton
    <gsaberton at foomagic.org> for the patch. Closes: #485440.
  * Add myself as uploader.

kernel-wedge (2.44) unstable; urgency=low

  [ Otavio Salvador ]
  * Add rt2500pci, rt2400pci and rt2500usb to nic-wireless-modules.

  [ Frans Pop ]
  * Including 'loop-aes' instead of 'loop' in loop-aes-modules as required
    with linux-modules-extra packaging of loop-aes-modules.

kernel-wedge (2.43) unstable; urgency=low

  * Add new Atheros wireless module (ath5k) to nic-wireless-modules.
  * Move ecb from crypto-modules to nic-wireless-modules (and fix typo: ebc
    should be ecb), and add arc4 to nic-wireless-modules. These crypto modules
    are only relevant for WEP. Closes: #448393.
  * Split blkcipher out into separate crypto-core-modules as it is needed for
    both wireless and other crypto usage.

kernel-wedge (2.42) unstable; urgency=low

  [ Otavio Salvador ]
  * Replace dpt_i2o with i2o_block to avoid diverting from installed
    system with regard to RAID with Adaptec 2100S. Closes: #440161.
  * Add ipg, niu, ixgbe, e1000e, sky2 and skge to nic-extra-modules.
    Closes: #469143
  * Move b44 to nic-pcmcia-modules.
  * Add zlib-modules udeb to provide zlib_inflate to ide and ppp
    modules.
  * Add p54pci and p54usb to nic-wireless-modules.

  [ Stephen R. Marenka ]
  * add aes_generic, make aes optional to accommodate 2.6.24.
  * add sha256_generic, make sha256 optional to accommodate 2.6.24.
  * make ppp_async and ppp_synctty optional to accommodate m68k/mac.

kernel-wedge (2.41) unstable; urgency=low

  * Add dependency of usb-modules on nic-wireless

kernel-wedge (2.40) unstable; urgency=low

  * Correct multipath-modules.

kernel-wedge (2.39) unstable; urgency=low

  [ Joey Hess ]
  * Add rtc-modules.

  [ Otavio Salvador ]
  * Add atl1 to nic-extra-modules;
  * Add sata_inic162x to sata-modules;
  * Add delkin_cb and tc86c001 to ide-modules;
  * Add orinoco_nortel and usb8xxx to nic-wireless-modules;
  * Applied patch from Guido Guenther <agx at debian.org> to add
    multipath-modules definition. Closes: #439410

  [ Joey Hess ]
  * With 2.6.22, the firewire modules are renamed to firewire-ohci and
    firewire-sbp2.

kernel-wedge (2.38) unstable; urgency=low

  [ Joey Hess ]
  * Add bitrev to core-modules, optionally. Some arches may build this as a
    module if nothing in the kernel itself uses it.

  [ Wouter Verhelst ]
  * Create an nbd-modules package with just the 'nbd' module in it that
    together with nbd-client-udeb and an as of yet to be written partman
    module should allow installing to an NBD device.

  [ Frans Pop ]
  * Add the definitions for loop-aes-modules (linux-modules-*).

  [ Otavio Salvador ]
  * Add squashfs-modules definition.

kernel-wedge (2.37) unstable; urgency=low

  [ Martin Michlmayr ]
  * Make nic-modules depend on core-modules. Closes: #421352

  [ Joey Hess ]
  * Split wireless modules out of nic-extra-modules into nic-wireless-modules.
    This new package will contain wireless modules that arn't USB or pcmcia;
    those stay in their respective packages.
  * nic-pcmcia-modules now depends on nic-wireless-modules instead of
    nic-extra-modules.
  * Add zd1211rw to nic-usb-modules, and ipw2100 and ipw2200 to
    nic-wireless-modules. These had been left off due to needing nonfree
    firmware, but maybe we'll work out a way to provide that, and users can
    always provide it on their own, so I think including these in d-i is
    worthwhile.
  * nic-usb-modules now depends on nic-wireless-modules for 80211 modules.

kernel-wedge (2.36) unstable; urgency=low

  * Updates for 2.6.21:
    - Add atl1 and cxgb3 to nic-extra-modules
    - Add dm9601 to nic-usb-modules
    - sata_sis now depends on pata_sis, so I moved sata_sis to pata-modules,
      which is not really ideal

kernel-wedge (2.35) unstable; urgency=low

  [ Joey Hess ]
  * Make nic-usb-modules depend on core-modules. Closes: #421352
  * It's generally fine to make any modules package depend on core-modules,
    even if the dependency is specific to one architecture. core-modules is
    priority standard so is always available anyway

  [ Frans Pop ]
  * Add cbc and ecb to crypto-modules (split out from another module in
    2.6.20).

kernel-wedge (2.34) unstable; urgency=low

  * Really add qla3xx to nic-extra-modules.
  * Remove 3c359 from nic-extra-modules, it was added accidentially, as it's a
    token ring driver.
  * Move qla4xxxx and qla2xxxx to scsi-extra-modules as scsi-modules is too
    large for the i386 cd-drivers floppy and these modules are unlikely to be
    used for CD drives.

kernel-wedge (2.33) unstable; urgency=low

  * Move eth1394 to nic-modules, this change was only made in i386 and amd64
    before.
  * Mark cpqarray optional, it is not available in amd64 as of 2.6.20.
    (This may be a bug in the kernel package.)
  * Rename firmware-modules to core-modules, so that it can be used for
    other modules besides firmware. Should only be used for very core modules.

kernel-wedge (2.32) unstable; urgency=low

  * Add ipr, qlogicfas408, and dc395x to scsi-modules, and pd6729 to
    pcmcia-modules. These were only listed in i386's files for some
    reason before.
  * 2.6.20 support: (Closes: #418707)
    - add dgrs, netxen_nic, qla3xxx to nic-extra-modules
      NB: netxen_nic may need external firmware; dgrs seems to contain a
      binary blob in the kernel.
    - didn't add new tokenring modules for 3c359 and smctr, guessing noone
      will need them?
    - add aic94xx and qla4xxx, and stex to scsi-modules.
    - add mcs7830 to nic-usb-modules.
    - didn't add aircable to usb-serial-modules, as I'm guessing noone will
      use it in d-i (ditto for mos7720 and mos7840)
    - Add pata_* to pata-modules. This is quite likely wrong, since all the
      old ide modules are also still being built, and most of them register
      the same pci ida as the pata modules. Which one wins I don't know. I'm
      just following the kernel team here so that d-i behaves the same as a
      system running the 2.6.20 kernel package. Expect that this will be
      worked out in the future and only one version of each module included.
    - Factor out libata to a new ata-modules, since both sata-modules and
      pata-modules need it.
    - scsi-modules also needs to depend on ata-modules now, since ipr has a
      new dependency on libata.
    - pata_pcmcia to pcmcia-storage-modules

kernel-wedge (2.31) unstable; urgency=low

  * Add jmicron to ide-modules.

kernel-wedge (2.30) unstable; urgency=low

  [ Joey Hess ]
  * Add strip-modules subcommand, which is called by install-files
    and strips all kernel modules. This saves a small amount of
    memory and space, and the kernel modules in d-i initrds were
    already stripped, so we know it's safe.
  * .. but disabled it anyway.

  [ Colin Watson ]
  * Fix typo in efi-modules package description.

  [ Joey Hess ]
  * Add ieee80211_crypt_wep to nic-extra-modules, this is needed to use WEP.
    Closes: #407492

  [ Frederik Schüler ]
  * Mark sk98lin optional in nic-extra-modules.

Date: Thu, 15 Jul 2010 17:07:05 +0100
Changed-By: Colin Watson <cjwatson at ubuntu.com>
Maintainer: Ubuntu Installer Team <ubuntu-installer at lists.ubuntu.com>
Signed-By: Colin Watson <cjwatson at canonical.com>
https://launchpad.net/ubuntu/maverick/+source/kernel-wedge/2.63ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Thu, 15 Jul 2010 17:07:05 +0100
Source: kernel-wedge
Binary: kernel-wedge
Architecture: source
Version: 2.63ubuntu1
Distribution: maverick
Urgency: low
Maintainer: Ubuntu Installer Team <ubuntu-installer at lists.ubuntu.com>
Changed-By: Colin Watson <cjwatson at ubuntu.com>
Description: 
 kernel-wedge - udeb package builder for Debian-Installer
Closes: 407492 418707 421352 439410 440161 448393 469143 479227 485440 490354 490562 496644 524531 547731 567431
Launchpad-Bugs-Fixed: 410221
Changes: 
 kernel-wedge (2.63ubuntu1) maverick; urgency=low
 .
   * Resynchronise with Debian.  Remaining changes:
     - Firmware udeb handling (copy-firmware and related changes).
 .
 kernel-wedge (2.63) unstable; urgency=low
 .
   [ Frans Pop ]
   * Updates for 2.6.32.
     - Add dependency on nls-core-modules to usb-modules.
     - Add dependency on usb-modules to sound-modules.
     - New udeb for basic i2c modules. Currently only contains i2c-core, which
       is needed by nic-extra and sound on amd64.
   * Cleanup; reduces compatibility with old kernel versions.
     - Drop generic modules that have been renamed or no longer exist. And
       remove the "optional" indicator for some of the replacement modules.
     - Drop no longer used udebs isa-pnp-modules and socket-modules.
     - Drop the cdrom-modules udeb for linux. No architecture kernel provides
       any of the modules listed in it any more.
     - Drop various obsolete modules:
       - ide-modules: adma100, hpt34x, ataraid, hptraid, medley, pdcraid, silraid
       - multipath-modules: dm-emc
       - nic-extra-modules: eepro100, sk98lin, dgrs, arl1
       - nic-pcmcia-modules: xircom_tulip_cb
       - nic-wireless-modules: bcm43xx, iwl4965
       - sata-modules: carmel
       - scsi-modules: NCR53C9x, eata_pio, mca_53c9x, psi240i, qlogicfc,
         qla2100, qla2200, qla2300, qla2322, qla6312, qlogicisp
       - usb-serial-modules: whiteheat, cp2101
   * core-modules: drop firmware_class as it's compiled in for recent kernels.
   * Define standard input-modules and mouse-modules. For input-modules add
     selected modules with vendor-specific hid quirks needed to support some
     keyboards (see e.g. #561036). Closes: #567431.
   * Change priority of reiserfs-modules from standard to extra.
   * Add mmc-core-modules udeb as the b44 driver in nic-pcmcia-modules has a
     dependency on mmc_core (because of Sonics Silicon Backplane support).
 .
   [ Frederik Schüler ]
   * Add mpt2sas module to scsi-extra-modules.
   * Add 3w-sas module to scsi-extra-modules.
 .
   [ Otavio Salvador ]
   * Bump Standards-Version; no changes needed.
   * net-wireless-modules: add b43. Closes: #547731.
   * debian/control: add ${misc:Depends}.
 .
 kernel-wedge (2.62) unstable; urgency=low
 .
   [ Colin Watson ]
   * In case of error, try to list more failures before bailing out.
     Requested by Tim Gardner (LP: #410221).
   * Upgrade to debhelper v7.
 .
   [ Aurelien Jarno ]
   * On kfreebsd-i386, consider acpi.ko as part of the kernel as it has
     to be loaded by the bootloader.
   * Rework all kfreebsd modules.
   * Change "Linux kernel" into "kernel" in the descriptions so that they
     can be used on kFreeBSD too.
 .
 kernel-wedge (2.61) unstable; urgency=low
 .
   * package-list: drop atl2-modules areen't used anymore.
   * nic-extra-modules: add atl1c and atl2 modules.
 .
 kernel-wedge (2.60) unstable; urgency=low
 .
   * ppp-modules, isofs-modules, jffs2-module, squashfs-modules: do not
     depends on zlib-modules anymore since it is built-in in most
     architectures.
   * zlib-modules: droped since no package in official architecture uses
     it anymore.
 .
 kernel-wedge (2.59) unstable; urgency=low
 .
   [ Samuel Thibault ]
   * sound-modules: Add 2.6.30 modules.
 .
   [ Luca Favatella ]
   * Add ntfs-modules on kFreeBSD.
 .
   [ Otavio Salvador ]
   * nic-wireless-modules: hermes is now optional.
 .
 kernel-wedge (2.58) unstable; urgency=low
 .
   * ext4-modules: depends on core-modules.
 .
 kernel-wedge (2.57) unstable; urgency=low
 .
   * ext4-modules: add package description.
 .
 kernel-wedge (2.56) unstable; urgency=low
 .
   * squashfs-modules: depends on zlib-modules.
 .
 kernel-wedge (2.55) unstable; urgency=low
 .
   [ Samuel Thibault ]
   * Add sound-modules. Closes: #524531.
 .
 kernel-wedge (2.54) unstable; urgency=low
 .
   [ Colin Watson ]
   * Add ext4-modules.
 .
   [ Otavio Salvador ]
   * core-modules: firmware_class is no longer available.
   * nic-extra-modules: remove duplicated acenic entry.
   * scsi-core-modules: add scsi_dh.
   * multipath-modules: depends on scsi-core-modules since it uses scsi_dh.
   * crypto-core-modules: dropped.
   * Update standards version to 3.8.1.
   * atl2-modules: dropped since they're available on 2.6.29.
 .
   [ Martin Michlmayr ]
   * ide-modules: Include ide-gd_mod (for ATA/ATAPI disks and floppy;
     ide-disk got renamed.)
 .
   [ Kenshi Muto ]
   * nic-extra-modules: make eepro100 optional.
                        add jme, enic, be2net, myri10ge, sc92031.
   * nic-wireless-modules: add ath9k, iwlagn.
   * nic-usb-modules: add rtl8187.
   * core-modules: add led-class.
   * mmc-modules: depends on core-modules.
 .
   [ Ian Campbell ]
   * Add Xen disk and network modules.
 .
 kernel-wedge (2.53) unstable; urgency=low
 .
   [ Samuel Thibault ]
   * Add uinput-modules.
 .
 kernel-wedge (2.52) unstable; urgency=low
 .
   [ Frans Pop ]
   * Add mmc-modules udeb to support MMC and SD cards.
 .
 kernel-wedge (2.51) unstable; urgency=low
 .
   * Move pata-sis to sata-modules since sata-sis depends on pata-sis and
     we wouldn't like to handle that dependency change so late on release
 .
 kernel-wedge (2.50) unstable; urgency=low
 .
   * Add it8213 to ide-modules. Closes: #496644.
 .
 kernel-wedge (2.49) unstable; urgency=low
 .
   * Add atl2 modules. Closes: #490354.
   * Add pata-sch to pata-modules.
   * Move sata-sis from pata-modules to sata-modules (uh?).
   * Add acenic, atl1e and sfc to nic-extra-modules.
   * Add spcp8x5 to usb-serial-modules.
   * Replace rtc with rtc-cmos on rtc-modules.
 .
 kernel-wedge (2.48) unstable; urgency=low
 .
   * Add raid10 to md-modules.
 .
 kernel-wedge (2.47) unstable; urgency=low
 .
   * Remove nls_iso8859-1 module, add nls_utf8. The latter is the new default
     for fat on 2.6.25. Closes: #490562
 .
 kernel-wedge (2.46) unstable; urgency=low
 .
   [ Jérémy Bobbio ]
   * Add virtio-modules package used to improve I/O when run inside a
     compatible emulator.
 .
   [ Ian Campbell ]
   * Make generic_serial optional to allow 686-bigmem udebs.
 .
   [ Frans Pop ]
   * Apply patch from Per Andersson to add a jffs2 modules udeb.
   * Update standards version to 3.8.0.
 .
 kernel-wedge (2.45) unstable; urgency=low
 .
   [ Frans Pop ]
   * Updates for 2.6.25.
   * scsi-modules: atp870u is no longer available.
   * crypto-core-modules: blkcipher has been renamed to crypto_blkcipher.
   * Move the dm-crypt module from md-modules to a new udeb crypto-dm-modules
     to avoid having md-modules depend on crypto-core-modules; dependencies on
     crypto-core-modules are now defined in kernel-wedge.
   * Move the isofs module from ide-modules to a new udeb isofs-modules because
     of its dependency on the new nls_base module; let cdrom-core-modules
     depend on isofs-modules.
   * Add an nls-core-modules udeb for the nls_base module. All nls_* modules
     and several filesystem modules depend on it.
 .
   [ Otavio Salvador ]
   * cdrom-core-modules: add ide-cd_mod since it replaces ide-cd now.
   * nic-extra-modules: add enc28j60, igb and r6040.
   * nic-usb-modules: add rndis_wlan and rtl8180.
   * scsi-extra-modules: add mvsas.
   * speakup-modules: created. Thanks to Samuel Thibault
     <samuel.thibault at ens-lyon.org> for the patch. Closes: #479227.
   * nic-wireless-modules: add iwl3945 and iwl4965 since we now support
     firmware loading during installation process. Thanks to Glenn Saberton
     <gsaberton at foomagic.org> for the patch. Closes: #485440.
   * Add myself as uploader.
 .
 kernel-wedge (2.44) unstable; urgency=low
 .
   [ Otavio Salvador ]
   * Add rt2500pci, rt2400pci and rt2500usb to nic-wireless-modules.
 .
   [ Frans Pop ]
   * Including 'loop-aes' instead of 'loop' in loop-aes-modules as required
     with linux-modules-extra packaging of loop-aes-modules.
 .
 kernel-wedge (2.43) unstable; urgency=low
 .
   * Add new Atheros wireless module (ath5k) to nic-wireless-modules.
   * Move ecb from crypto-modules to nic-wireless-modules (and fix typo: ebc
     should be ecb), and add arc4 to nic-wireless-modules. These crypto modules
     are only relevant for WEP. Closes: #448393.
   * Split blkcipher out into separate crypto-core-modules as it is needed for
     both wireless and other crypto usage.
 .
 kernel-wedge (2.42) unstable; urgency=low
 .
   [ Otavio Salvador ]
   * Replace dpt_i2o with i2o_block to avoid diverting from installed
     system with regard to RAID with Adaptec 2100S. Closes: #440161.
   * Add ipg, niu, ixgbe, e1000e, sky2 and skge to nic-extra-modules.
     Closes: #469143
   * Move b44 to nic-pcmcia-modules.
   * Add zlib-modules udeb to provide zlib_inflate to ide and ppp
     modules.
   * Add p54pci and p54usb to nic-wireless-modules.
 .
   [ Stephen R. Marenka ]
   * add aes_generic, make aes optional to accommodate 2.6.24.
   * add sha256_generic, make sha256 optional to accommodate 2.6.24.
   * make ppp_async and ppp_synctty optional to accommodate m68k/mac.
 .
 kernel-wedge (2.41) unstable; urgency=low
 .
   * Add dependency of usb-modules on nic-wireless
 .
 kernel-wedge (2.40) unstable; urgency=low
 .
   * Correct multipath-modules.
 .
 kernel-wedge (2.39) unstable; urgency=low
 .
   [ Joey Hess ]
   * Add rtc-modules.
 .
   [ Otavio Salvador ]
   * Add atl1 to nic-extra-modules;
   * Add sata_inic162x to sata-modules;
   * Add delkin_cb and tc86c001 to ide-modules;
   * Add orinoco_nortel and usb8xxx to nic-wireless-modules;
   * Applied patch from Guido Guenther <agx at debian.org> to add
     multipath-modules definition. Closes: #439410
 .
   [ Joey Hess ]
   * With 2.6.22, the firewire modules are renamed to firewire-ohci and
     firewire-sbp2.
 .
 kernel-wedge (2.38) unstable; urgency=low
 .
   [ Joey Hess ]
   * Add bitrev to core-modules, optionally. Some arches may build this as a
     module if nothing in the kernel itself uses it.
 .
   [ Wouter Verhelst ]
   * Create an nbd-modules package with just the 'nbd' module in it that
     together with nbd-client-udeb and an as of yet to be written partman
     module should allow installing to an NBD device.
 .
   [ Frans Pop ]
   * Add the definitions for loop-aes-modules (linux-modules-*).
 .
   [ Otavio Salvador ]
   * Add squashfs-modules definition.
 .
 kernel-wedge (2.37) unstable; urgency=low
 .
   [ Martin Michlmayr ]
   * Make nic-modules depend on core-modules. Closes: #421352
 .
   [ Joey Hess ]
   * Split wireless modules out of nic-extra-modules into nic-wireless-modules.
     This new package will contain wireless modules that arn't USB or pcmcia;
     those stay in their respective packages.
   * nic-pcmcia-modules now depends on nic-wireless-modules instead of
     nic-extra-modules.
   * Add zd1211rw to nic-usb-modules, and ipw2100 and ipw2200 to
     nic-wireless-modules. These had been left off due to needing nonfree
     firmware, but maybe we'll work out a way to provide that, and users can
     always provide it on their own, so I think including these in d-i is
     worthwhile.
   * nic-usb-modules now depends on nic-wireless-modules for 80211 modules.
 .
 kernel-wedge (2.36) unstable; urgency=low
 .
   * Updates for 2.6.21:
     - Add atl1 and cxgb3 to nic-extra-modules
     - Add dm9601 to nic-usb-modules
     - sata_sis now depends on pata_sis, so I moved sata_sis to pata-modules,
       which is not really ideal
 .
 kernel-wedge (2.35) unstable; urgency=low
 .
   [ Joey Hess ]
   * Make nic-usb-modules depend on core-modules. Closes: #421352
   * It's generally fine to make any modules package depend on core-modules,
     even if the dependency is specific to one architecture. core-modules is
     priority standard so is always available anyway
 .
   [ Frans Pop ]
   * Add cbc and ecb to crypto-modules (split out from another module in
     2.6.20).
 .
 kernel-wedge (2.34) unstable; urgency=low
 .
   * Really add qla3xx to nic-extra-modules.
   * Remove 3c359 from nic-extra-modules, it was added accidentially, as it's a
     token ring driver.
   * Move qla4xxxx and qla2xxxx to scsi-extra-modules as scsi-modules is too
     large for the i386 cd-drivers floppy and these modules are unlikely to be
     used for CD drives.
 .
 kernel-wedge (2.33) unstable; urgency=low
 .
   * Move eth1394 to nic-modules, this change was only made in i386 and amd64
     before.
   * Mark cpqarray optional, it is not available in amd64 as of 2.6.20.
     (This may be a bug in the kernel package.)
   * Rename firmware-modules to core-modules, so that it can be used for
     other modules besides firmware. Should only be used for very core modules.
 .
 kernel-wedge (2.32) unstable; urgency=low
 .
   * Add ipr, qlogicfas408, and dc395x to scsi-modules, and pd6729 to
     pcmcia-modules. These were only listed in i386's files for some
     reason before.
   * 2.6.20 support: (Closes: #418707)
     - add dgrs, netxen_nic, qla3xxx to nic-extra-modules
       NB: netxen_nic may need external firmware; dgrs seems to contain a
       binary blob in the kernel.
     - didn't add new tokenring modules for 3c359 and smctr, guessing noone
       will need them?
     - add aic94xx and qla4xxx, and stex to scsi-modules.
     - add mcs7830 to nic-usb-modules.
     - didn't add aircable to usb-serial-modules, as I'm guessing noone will
       use it in d-i (ditto for mos7720 and mos7840)
     - Add pata_* to pata-modules. This is quite likely wrong, since all the
       old ide modules are also still being built, and most of them register
       the same pci ida as the pata modules. Which one wins I don't know. I'm
       just following the kernel team here so that d-i behaves the same as a
       system running the 2.6.20 kernel package. Expect that this will be
       worked out in the future and only one version of each module included.
     - Factor out libata to a new ata-modules, since both sata-modules and
       pata-modules need it.
     - scsi-modules also needs to depend on ata-modules now, since ipr has a
       new dependency on libata.
     - pata_pcmcia to pcmcia-storage-modules
 .
 kernel-wedge (2.31) unstable; urgency=low
 .
   * Add jmicron to ide-modules.
 .
 kernel-wedge (2.30) unstable; urgency=low
 .
   [ Joey Hess ]
   * Add strip-modules subcommand, which is called by install-files
     and strips all kernel modules. This saves a small amount of
     memory and space, and the kernel modules in d-i initrds were
     already stripped, so we know it's safe.
   * .. but disabled it anyway.
 .
   [ Colin Watson ]
   * Fix typo in efi-modules package description.
 .
   [ Joey Hess ]
   * Add ieee80211_crypt_wep to nic-extra-modules, this is needed to use WEP.
     Closes: #407492
 .
   [ Frederik Schüler ]
   * Mark sk98lin optional in nic-extra-modules.
Checksums-Sha1: 
 78267485cbf66cfb528044bf179ccd8f8eb5d567 1727 kernel-wedge_2.63ubuntu1.dsc
 7642e4734b4208837713aae689028e075a0841a9 42322 kernel-wedge_2.63ubuntu1.tar.gz
Checksums-Sha256: 
 014f8fa794e46c66b89436df7c38e003282c432a06ebe47cb4afd3774310f340 1727 kernel-wedge_2.63ubuntu1.dsc
 158ea35290fe5e202c59919b09398b31d7bd0e331e554c29f8be0062e192f68d 42322 kernel-wedge_2.63ubuntu1.tar.gz
Files: 
 b3e2f32535b10f2b948773cf76cef596 1727 utils optional kernel-wedge_2.63ubuntu1.dsc
 e831042db47aaf276f8b0a37e7feecf2 42322 utils optional kernel-wedge_2.63ubuntu1.tar.gz
Original-Maintainer: Debian Install System Team <debian-boot at lists.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Colin Watson <cjwatson at debian.org> -- Debian developer

iQIVAwUBTD8yezk1h9l9hlALAQgZ6hAAjPmWtLx0zNhSPVu/TnIJu9cLHpJtd+LP
louR/R42lWIMHdqcZthEjhRZ4Ldw1DcR733UknlJMkfn1TtqN5mrVxpOh17x3wZn
zJxxasu7A5OIe9R+p+JQXnScAZY099Ohv63LWbPGc6AdcvvlA3HGh34eJrZNS25Y
5RfyV2RVO5BXTwXEPFlmYX+kZNRQrbJZjomg0MHnSKJl4EmlS6YvwdN6qfUZC6p6
gdJJP+HNdp8BOtTGPXl7os+IzLo6m1a9fiv68wUWPjPphp03Puk77/9ns1K1Fmtr
+NT0gIaUri02BWV+W3ENQ2FVptgLOM1owQAGf3UfT4BGIliSXbRBs2CrwOJQDv2X
0CryfgSZhvaMxuTXyGJBHB23+c1oO6KBzJRTPRjWqTwe/CfgTkKylNuRwX0pKwAy
vTnYJQ2fvzBfoLxjnNv7pz70/cssvmLrDwAUvPI5Iz0+JbF3B7fn27XFBAvWGLI4
EBzeh08CtKpNuM4P+0/rJFutGFJ2wK43Ya27rbgMgkBkLa/TcM40RkJmKmZ20LDr
iM+OXFU20791rxaMG6qV9k8FGPrf91iTtmI+crtPNtbGKOi8XzGBeSWvxmEYcCZK
wSdslPhnTG97lkAaA7Vevtd0zLitcTHDQak2pPUUqjGUT9TSVwi6kqSJ5KA3+zaT
0+7XE8hZCoo=
=sTug
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list