[ubuntu/maverick] javatools 0.32 (Accepted)

ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) aelmahmoudy at sabily.org
Tue Aug 10 11:30:24 BST 2010


javatools (0.32) unstable; urgency=low

  [ Niels Thykier ]
  * Fixed quoting issue in jh_compilefeatures.
  * Renamed a function in the Eclipse module.
  * fetch-eclipse-source script to create tarballs from some eclipse
    upstreams. Its requirements have been added to javahelper's
    suggests.
  * Replaced jh_libs with jh_installlibs in the description of
    javahelper.
  * Bumped Standards-Versions to 3.9.0 - no changes required.
  * jh_depends now treats "headless" for the --jvm option differently.
    if "headless" is present then all JREs will be specified using
    their headless version. If headless is the only value, it will be
    read as "headless default".
  * jh_depends no longer recognises "sun5" as a valid JVM, since this
    has been removed from the archive. "sun" is now an alias of "sun6".
  * The --jvm "gcj" value for jh_depends now uses gcj-jre and not
    java-gcj-compat, since the latter is now a virtual package.
  * Made jh_depends produce (>= ${source:Version}) instead of
    (= ${binary:Version}). The latter would break with binNMUs.
  * jh_depends now generates a dependency list for javadocs based on
    which system javadocs they have been linked against. These packages
    are added to the new ${java:Recommends} variable.
  * jh_installeclipse now always emits ${orbit:Depends} even if it
    would be empty.
  * Fixed a formatting issue in the eclipse helpers.
  * Rewrote jh_manifest using debhelper as backend.
    - it now produces deterministic output (Closes: #574029)
    - removed all depends on python.
    - comments are now allowed in d/manifest files.
    - it will now produce a warning if a jar file listed in a d/manifest-
      file cannot be found (unless the jar was excluded).
  * Reordered the javahelper sequence so that jh_installlibs is now run
    before jh_classpath and jh_manifest.

  [ Matthew Johnson ]
  * If jars aren't specified by absolute path try finding them under
    /usr/share/java (Closes: #586783)
  * jh_build will now -link any javadoc in a package that you build-depend
    on
  * fix jh_build documentation

Date: Sun, 04 Jul 2010 10:04:17 +0000
Changed-By: أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy at sabily.org>
Maintainer: Debian Java Maintainers <pkg-java-maintainers at lists.alioth.debian.org>
Signed-By: Benjamin Drung <benjamin.drung at gmail.com>
Origin: debian/unstable
https://launchpad.net/ubuntu/maverick/+source/javatools/0.32
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 04 Jul 2010 10:04:17 +0000
Source: javatools
Binary: jarwrapper javahelper java-propose-classpath
Architecture: source
Version: 0.32
Distribution: maverick
Urgency: low
Maintainer: Debian Java Maintainers <pkg-java-maintainers at lists.alioth.debian.org>
Changed-By: أحمد المحمودي (Ahmed El-Mahmoudy) <aelmahmoudy at sabily.org>
Description: 
 jarwrapper - Run executable Java .jar files
 java-propose-classpath - Helper script to suggest a classpath for jar files
 javahelper - Helper scripts for packaging Java programs
Closes: 574029 586783
Changes: 
 javatools (0.32) unstable; urgency=low
 .
   [ Niels Thykier ]
   * Fixed quoting issue in jh_compilefeatures.
   * Renamed a function in the Eclipse module.
   * fetch-eclipse-source script to create tarballs from some eclipse
     upstreams. Its requirements have been added to javahelper's
     suggests.
   * Replaced jh_libs with jh_installlibs in the description of
     javahelper.
   * Bumped Standards-Versions to 3.9.0 - no changes required.
   * jh_depends now treats "headless" for the --jvm option differently.
     if "headless" is present then all JREs will be specified using
     their headless version. If headless is the only value, it will be
     read as "headless default".
   * jh_depends no longer recognises "sun5" as a valid JVM, since this
     has been removed from the archive. "sun" is now an alias of "sun6".
   * The --jvm "gcj" value for jh_depends now uses gcj-jre and not
     java-gcj-compat, since the latter is now a virtual package.
   * Made jh_depends produce (>= ${source:Version}) instead of
     (= ${binary:Version}). The latter would break with binNMUs.
   * jh_depends now generates a dependency list for javadocs based on
     which system javadocs they have been linked against. These packages
     are added to the new ${java:Recommends} variable.
   * jh_installeclipse now always emits ${orbit:Depends} even if it
     would be empty.
   * Fixed a formatting issue in the eclipse helpers.
   * Rewrote jh_manifest using debhelper as backend.
     - it now produces deterministic output (Closes: #574029)
     - removed all depends on python.
     - comments are now allowed in d/manifest files.
     - it will now produce a warning if a jar file listed in a d/manifest-
       file cannot be found (unless the jar was excluded).
   * Reordered the javahelper sequence so that jh_installlibs is now run
     before jh_classpath and jh_manifest.
 .
   [ Matthew Johnson ]
   * If jars aren't specified by absolute path try finding them under
     /usr/share/java (Closes: #586783)
   * jh_build will now -link any javadoc in a package that you build-depend
     on
   * fix jh_build documentation
Checksums-Sha1: 
 f853cde109ceffb74145f6a0ca7a1ac9b3604b14 1650 javatools_0.32.dsc
 6b7a1acc238faff8c9a7b82cddab4b28b377c0f0 58056 javatools_0.32.tar.gz
Checksums-Sha256: 
 78cf11c4ad3a46ae5d5f9c6cb262e8f1a4307ea5f760ae6abb5d20b22eb9c996 1650 javatools_0.32.dsc
 8ca9ba5992ebaa58a635cb94d8df1d69fefc9e6a441b16e3a0a53770cb305280 58056 javatools_0.32.tar.gz
Files: 
 28c25be2828738633feed22a8d83188c 1650 java optional javatools_0.32.dsc
 d07d5bbf2ed22e3244418eacd8cef347 58056 java optional javatools_0.32.tar.gz
Origin: debian/unstable
Launchpad-Bugs-Fixed: 614210

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCgAGBQJMYSS3AAoJEBWetcTvyHdMn7IP/00vBJcWFqt3EQhjHFZeqehF
/6g5xE15oumD1W/Cl6QNEzLSTIUMdthDvXC3GEPRzBqHPPxV33l+/jpqPxgnGd0M
JGb9nCJ9mcFIlclsGUwDb+qwXP/aEhXfm+yrEMLfbUF3nolXi/4UbQv4xVAc5tXJ
z7/burfXTvOgCsY8y9YM7WrVo3+cTgR114bR+C/0X82LHLUlHbCOBTJebsVDnDu9
s+gbv0a8FGAgMj0+m95tDzgdopy688UgxpwYE2fKRZvDPpPTx1aUjMSxp3CStjEX
0D4ZEiQfkfUa5hdLQaegnbg6kgEYH8Du8a5O1Wt8Q528qPnydObUaWJTVw+E7SL1
vdYYxGoaNPKR96kr4BGLU+PQHDGt3uQzwa1puOXduiU2fAqdo+l/223aR3jPVWjG
axDbfbdEzoTFJFYbqf8imWsjYEojP5f6tsciBXppotXYkxjHhzHCWfJZyEtsA/7f
Nf21PEMVBq4JG5RZHEFClWE5uncEoy9cX95KB/p/nB/EEAW1pHVRkQN88P+2mpFn
G+cDwysddazfp9VNJM+J4viHOwJelMfvst4+JqX/goCJ9rCYeIRJTW2OVnkoDCK1
Csgl973ytdl7roOxb5/crPQxLXxZfAw3ZxlDAYZ8rrbAXYeTx+5GcMkeGOYblHn9
LJ8XOIBz3XX0PptuQdfe
=HVzT
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list