[ubuntu/maverick] rrdtool 1.4.3-1ubuntu1 (Accepted)

Clint Byrum clint at ubuntu.com
Thu Aug 5 18:10:24 BST 2010


rrdtool (1.4.3-1ubuntu1) maverick; urgency=low

  * Merge from debian unstable, Remaining changes:
    - debian/control: Don't build against ruby1.9 as we don't want
      it in main.
  * require libdbi >= 0.8.3 to prevent aborts when using dbi datasources

rrdtool (1.4.3-1) unstable; urgency=low

  * New upstream release.
  * debian/patches:
    - Removed bts573638-rrdcgi-segfault and bts573299-rrdgraph-M -- included
      upstream.

rrdtool (1.4.2-2) unstable; urgency=low

  * debian/patches:
    - Added bts573638-rrdcgi-segfault: upstream patch fixing a segfault in
      rrdcgi's printlasttime() (and possibly others); thanks to Robert Luberda
      for reporting this (Closes: #573638).
    - Added bts573299-rrdgraph-M: fix short option parsing in rrd_graph() --
      added support for '-M' as documented in the manpage; thanks to Ralf
      Hildebrandt for reporting this (Closes: #573299).
  * debian/control:
    - Updated Standards-Version to 3.8.4 -- no changes.

rrdtool (1.4.2-1) unstable; urgency=low

  [ Bernd Zeimetz ]
  * debian/rules:
    - Prepare to build with Python 2.6.

  [ Sebastian Harl ]
  * New upstream release; thanks to Antoine Beaupre for reporting this
    (Closes: #559370):
    - Fixed some typos in the manpages; thanks to Justin T. Pryzby for
      reporting this (Closes: #550919).
  * Uploading to unstable as this is not an SVN snapshot any more.
  * debian/README.Debian:
    - Added a note about <http://oss.oetiker.ch/rrdtool/pub/contrib/> as
      requested in #323969 and lost in 1.2.26-1.
  * debian/control, debian/rules:
    - Switched from Ruby 1.9 to Ruby 1.9.1 (affecting the librrd-ruby1.9 and
      rrdtool-dbg packages); thanks to Lucas Nussbaum for reporting this
      (Closes: #565833, #565835).
  * debian/control:
    - Let librrd-ruby depend on ${misc:Depends} (to shut up lintian, mostly).
  * Added debian/rrdtool.doc-base:
    - … pointing to /u/s/d/rrdtool/html/.
  * Added debian/rrdcached.doc-base:
    - … pointing to /u/s/d/rrdcached/html/.

rrdtool (1.4~rc2+20091004-1) experimental; urgency=low

  [ Sebastian Harl ]
  * New upstream SVN snapshot based on trunk at revision 1930.
  * Uploading to experimental.
  * debian/control:
    - Build-depend on gettext instead of intltool following the switch made by
      upstream.
    - Build-depend on libdbi0-dev, required by rrdgraph to read values from an
      SQL database.
    - Updated Standards-Version to 3.8.3.
    - Let the synopsis start with a small letter (as suggested in dev-ref
      6.2.2).
    - Let rrdtool-dbg recommend liblua5.1-rrd0.
  * debian/rules:
    - Remove config.h in the 'clean' target - this is created by configure but
      not cleaned up by any Makefile.
    - Use DEB_HOST_ARCH_CPU instead of DEB_HOST_GNU_TYPE to check for the
      build host.
    - Set examples/rrdcached/RRDCached.pm's file mode to 0644.
    - Run dh_installinit for the "rrdcached" package.
  * debian/patches:
    - Removed bts494874-gnu-kfreebsd - included upstream.
    - Removed bts332766-negative-timestamps - included upstream.
    - Removed compiler-warning-fixes - included upstream.
    - Updated bts428778-floating-point-exception for RRDtool 1.4.
  * Added debian/README.source:
    - The file includes a pointer to /usr/share/doc/quilt/README.source.
  * debian/librrd4.symbols:
    - Added symbols introduced in 1.4~rc2.
  * Added new binary package 'rrdcached' for the newly introduced "data
    caching daemon".
  * debian/rrdcached.init.d, debian/rrdcached.default:
    - Added an init script for rrdcached supporting start, stop, status,
      restart, force-reload. The script is based on the collectd init script.
  * debian/rrdtool.install:
    - Install manpages in section 3 as well.
  * debian/rrdcached.postrm:
    - Remove /var/lib/rrdcached/ on purge.

  [ Bernd Zeimetz ]
  * debian/rules, debian/control:
    - Build Lua bindings and put them into appropriate packages.
  * Added debian/lua-rrd.h.
  * debian/rules:
    - Tell dh_makeshlibs to not modify postinst/postrm of the lua packages -
      we do not need to run ldconfig when installing them.

Date: Thu, 22 Jul 2010 08:07:01 -0700
Changed-By: Clint Byrum <clint at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Mathias Gug <mathiaz at ubuntu.com>
https://launchpad.net/ubuntu/maverick/+source/rrdtool/1.4.3-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 22 Jul 2010 08:07:01 -0700
Source: rrdtool
Binary: rrdtool rrdcached rrdtool-dbg librrd4 librrd-dev librrds-perl librrdp-perl rrdtool-tcl python-rrdtool librrd-ruby librrd-ruby1.8 liblua5.1-rrd0 liblua5.1-rrd-dev
Architecture: source
Version: 1.4.3-1ubuntu1
Distribution: maverick
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Clint Byrum <clint at ubuntu.com>
Description: 
 liblua5.1-rrd-dev - time-series data storage and display system (Lua 5.1 development)
 liblua5.1-rrd0 - time-series data storage and display system (Lua 5.1 interface)
 librrd-dev - time-series data storage and display system (development)
 librrd-ruby - time-series data storage and display system (Ruby interface)
 librrd-ruby1.8 - time-series data storage and display system (Ruby 1.8 interface)
 librrd4    - time-series data storage and display system (runtime library)
 librrdp-perl - time-series data storage and display system (Perl interface, pipe
 librrds-perl - time-series data storage and display system (Perl interface, shar
 python-rrdtool - time-series data storage and display system (Python interface)
 rrdcached  - data caching daemon for RRDtool
 rrdtool    - time-series data storage and display system (programs)
 rrdtool-dbg - Time-series data storage and display system (debugging symbols)
 rrdtool-tcl - time-series data storage and display system (Tcl interface)
Closes: 550919 559370 565833 565835 573299 573638
Changes: 
 rrdtool (1.4.3-1ubuntu1) maverick; urgency=low
 .
   * Merge from debian unstable, Remaining changes:
     - debian/control: Don't build against ruby1.9 as we don't want
       it in main.
   * require libdbi >= 0.8.3 to prevent aborts when using dbi datasources
 .
 rrdtool (1.4.3-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/patches:
     - Removed bts573638-rrdcgi-segfault and bts573299-rrdgraph-M -- included
       upstream.
 .
 rrdtool (1.4.2-2) unstable; urgency=low
 .
   * debian/patches:
     - Added bts573638-rrdcgi-segfault: upstream patch fixing a segfault in
       rrdcgi's printlasttime() (and possibly others); thanks to Robert Luberda
       for reporting this (Closes: #573638).
     - Added bts573299-rrdgraph-M: fix short option parsing in rrd_graph() --
       added support for '-M' as documented in the manpage; thanks to Ralf
       Hildebrandt for reporting this (Closes: #573299).
   * debian/control:
     - Updated Standards-Version to 3.8.4 -- no changes.
 .
 rrdtool (1.4.2-1) unstable; urgency=low
 .
   [ Bernd Zeimetz ]
   * debian/rules:
     - Prepare to build with Python 2.6.
 .
   [ Sebastian Harl ]
   * New upstream release; thanks to Antoine Beaupre for reporting this
     (Closes: #559370):
     - Fixed some typos in the manpages; thanks to Justin T. Pryzby for
       reporting this (Closes: #550919).
   * Uploading to unstable as this is not an SVN snapshot any more.
   * debian/README.Debian:
     - Added a note about <http://oss.oetiker.ch/rrdtool/pub/contrib/> as
       requested in #323969 and lost in 1.2.26-1.
   * debian/control, debian/rules:
     - Switched from Ruby 1.9 to Ruby 1.9.1 (affecting the librrd-ruby1.9 and
       rrdtool-dbg packages); thanks to Lucas Nussbaum for reporting this
       (Closes: #565833, #565835).
   * debian/control:
     - Let librrd-ruby depend on ${misc:Depends} (to shut up lintian, mostly).
   * Added debian/rrdtool.doc-base:
     - … pointing to /u/s/d/rrdtool/html/.
   * Added debian/rrdcached.doc-base:
     - … pointing to /u/s/d/rrdcached/html/.
 .
 rrdtool (1.4~rc2+20091004-1) experimental; urgency=low
 .
   [ Sebastian Harl ]
   * New upstream SVN snapshot based on trunk at revision 1930.
   * Uploading to experimental.
   * debian/control:
     - Build-depend on gettext instead of intltool following the switch made by
       upstream.
     - Build-depend on libdbi0-dev, required by rrdgraph to read values from an
       SQL database.
     - Updated Standards-Version to 3.8.3.
     - Let the synopsis start with a small letter (as suggested in dev-ref
       6.2.2).
     - Let rrdtool-dbg recommend liblua5.1-rrd0.
   * debian/rules:
     - Remove config.h in the 'clean' target - this is created by configure but
       not cleaned up by any Makefile.
     - Use DEB_HOST_ARCH_CPU instead of DEB_HOST_GNU_TYPE to check for the
       build host.
     - Set examples/rrdcached/RRDCached.pm's file mode to 0644.
     - Run dh_installinit for the "rrdcached" package.
   * debian/patches:
     - Removed bts494874-gnu-kfreebsd - included upstream.
     - Removed bts332766-negative-timestamps - included upstream.
     - Removed compiler-warning-fixes - included upstream.
     - Updated bts428778-floating-point-exception for RRDtool 1.4.
   * Added debian/README.source:
     - The file includes a pointer to /usr/share/doc/quilt/README.source.
   * debian/librrd4.symbols:
     - Added symbols introduced in 1.4~rc2.
   * Added new binary package 'rrdcached' for the newly introduced "data
     caching daemon".
   * debian/rrdcached.init.d, debian/rrdcached.default:
     - Added an init script for rrdcached supporting start, stop, status,
       restart, force-reload. The script is based on the collectd init script.
   * debian/rrdtool.install:
     - Install manpages in section 3 as well.
   * debian/rrdcached.postrm:
     - Remove /var/lib/rrdcached/ on purge.
 .
   [ Bernd Zeimetz ]
   * debian/rules, debian/control:
     - Build Lua bindings and put them into appropriate packages.
   * Added debian/lua-rrd.h.
   * debian/rules:
     - Tell dh_makeshlibs to not modify postinst/postrm of the lua packages -
       we do not need to run ldconfig when installing them.
Checksums-Sha1: 
 a84a50fc383be546f309fbdb49eba9665923c374 1879 rrdtool_1.4.3-1ubuntu1.dsc
 1e65de0192c149a30ee0d277e758a31ff7d6d6f0 1381821 rrdtool_1.4.3.orig.tar.gz
 4b6dc14579e61933481d40971be448c2214600e7 25719 rrdtool_1.4.3-1ubuntu1.diff.gz
Checksums-Sha256: 
 3e7dbd98414ac0b16b2c346688c5f472c1cf16628d6564e40aad99240efae82d 1879 rrdtool_1.4.3-1ubuntu1.dsc
 1aecfba0cb255aef6ae27534825022b83996abec0b7b94576e3b9d061ddf6d73 1381821 rrdtool_1.4.3.orig.tar.gz
 1cea027287cb0cbea2672a6f9e68b4418acea215ae0ca0d63976d516806003d3 25719 rrdtool_1.4.3-1ubuntu1.diff.gz
Files: 
 46d90f2bc97ec459c4bd6ef7a29b4543 1879 utils optional rrdtool_1.4.3-1ubuntu1.dsc
 492cf946c72f85987238faa2c311b7bb 1381821 utils optional rrdtool_1.4.3.orig.tar.gz
 82c82e41abf8774979700aaaf9502bb7 25719 utils optional rrdtool_1.4.3-1ubuntu1.diff.gz
Original-Maintainer: Debian RRDtool Team <rrdtool at ml.snow-crash.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkxa728ACgkQM0thG+z3pViOsQCgh47nWkbFw50KdbshM3DBHmno
MUoAnihFJFJlaz/V0uYXANdsoPeXp3Kt
=35Y5
-----END PGP SIGNATURE-----


More information about the Maverick-changes mailing list