[ubuntu/maverick] spring 0.81.2.1+dfsg1-6 (Accepted)

Ubuntu Installer archive at ubuntu.com
Wed Aug 4 20:43:40 BST 2010


spring (0.81.2.1+dfsg1-6) unstable; urgency=low

  * debian/control: remove dependency on python-dev-2.5

spring (0.81.2.1+dfsg1-5) unstable; urgency=low

  * debian/patches/0002-use-Debian-java-libs.patch:
    - remove empty ${myJLibDir} from classpath in
      AI/Interfaces/Java/CMakeLists.txt and
      AI/Skirmish/HughAI/CMakeLists.txt
    - use -classpath instead of -cp
  * refresh debian/patches/0001-Minor-spelling-fix.patch
  * debian/control: restrict supported architectures to i386 and amd64
    because building fails on kfreebsd-* due to no capable enough JDK
    and hardware accellerated OpenGL requirement
  * debian/rules: fail in override_dh_auto_configure if architecture is
    not amd64 or i386

spring (0.81.2.1+dfsg1-4) unstable; urgency=low

  * add debian/spring-javaai.links to add links to jna.jar and vecmath.jar

spring (0.81.2.1+dfsg1-3) unstable; urgency=low

  * enable Java-AI-Interface
   - debian/control: add libvecmath-java and libjna-java to Build-Depends
   - debian/rules: remove -DAI_TYPES=NATIVE configure argument, add
     -DAI_FIND_QUIETLY=FALSE
   - add debian/patches/0002-use-Debian-java-libs.patch to use jar files
     from libvecmath-java and libjna-java
   - add debian/patches/0003-fix-cmake-2_8-java-build.patch to fix cmake 2.8
     java compilation issue
  * add new binary package spring-javaai
   - add package stanza to debian/control
   - add paths to debian/spring-javaai.install
  * add spring-javaai to spring binary package's Suggests in debian/control
  * refine debian/spring-common.install to exclude Java AI files from
    spring-common
  * debian/control: remove libgcj9-dev from Build-Depends, it is not
    available anymore and not necessary (Closes: #577885)

spring (0.81.2.1+dfsg1-2) unstable; urgency=low

  * use FreeSansBold.otf from otf-freefont (Closes: #575512)
   - debian/control: depend on otf-freefont instead of ttf-freefont
   - debian/rules: symlink to otf version of FreeSansBold

spring (0.81.2.1+dfsg1-1) unstable; urgency=low

  * New upstream version

spring (0.81.2+dfsg1-1) unstable; urgency=low

  * New upstream version
  * debian/rules, debian/watch: use +dfsg instead of ~dfsg for correct
    sorting

spring (0.81.1.3~dfsg1-1) unstable; urgency=low

  [ Marco Amadori ]
  * Imported Upstream version 0.81.1.3
  * Set -march=i686 only on i386 (Helps: #563686).
  * Adapted DATADIR paths to relative ones
  * Bumped Standards-Version to 3.8.4.

  [ Jan Dittberner ]
  * repack tarball in a get-orig-source rule
  * add dversionmangle to debian/watch
  * move information from debian-removed.txt to debian/README.source
  * debian/control:
   - add myself to Uploaders
   - set Architecture for spring and spring-dbg to i386 amd64
     kfreebsd-i386 kfreebsd-amd64 hurd-i386 because of x86 only assembly in
     rts/lib/streflop/streflopC.cpp
   - remove Build-Depends quilt
  * add doc-base registration files debian/spring.doc-base.devguide and
    debian/spring.doc-base.minihelp for included HTML documentation
  * add debian/source/format with content "3.0 (quilt)"
  * remove quilt information from debian/README.source
  * debian/rules: remove " --with quilt"

Date: Wed,  04 Aug 2010 20:30:10 +0100
Changed-By: Artur Rona <ari-tczew at tlen.pl>
Maintainer: Debian Games Team <pkg-games-devel at lists.alioth.debian.org>
Origin: Debian/unstable
https://launchpad.net/ubuntu/maverick/+source/spring/0.81.2.1+dfsg1-6
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Wed,  04 Aug 2010 20:30:10 +0100
Source: spring
Binary: spring, spring-common, spring-dbg, spring-javaai
Architecture: source
Version: 0.81.2.1+dfsg1-6
Distribution: maverick
Urgency: low
Maintainer: Debian Games Team <pkg-games-devel at lists.alioth.debian.org>
Changed-By: Artur Rona <ari-tczew at tlen.pl>
Description: 
 spring     - a modern full-3D RTS game engine
Closes: 575512 577885
Changes: 
 spring (0.81.2.1+dfsg1-6) unstable; urgency=low
 .
   * debian/control: remove dependency on python-dev-2.5
 .
 spring (0.81.2.1+dfsg1-5) unstable; urgency=low
 .
   * debian/patches/0002-use-Debian-java-libs.patch:
     - remove empty ${myJLibDir} from classpath in
       AI/Interfaces/Java/CMakeLists.txt and
       AI/Skirmish/HughAI/CMakeLists.txt
     - use -classpath instead of -cp
   * refresh debian/patches/0001-Minor-spelling-fix.patch
   * debian/control: restrict supported architectures to i386 and amd64
     because building fails on kfreebsd-* due to no capable enough JDK
     and hardware accellerated OpenGL requirement
   * debian/rules: fail in override_dh_auto_configure if architecture is
     not amd64 or i386
 .
 spring (0.81.2.1+dfsg1-4) unstable; urgency=low
 .
   * add debian/spring-javaai.links to add links to jna.jar and vecmath.jar
 .
 spring (0.81.2.1+dfsg1-3) unstable; urgency=low
 .
   * enable Java-AI-Interface
    - debian/control: add libvecmath-java and libjna-java to Build-Depends
    - debian/rules: remove -DAI_TYPES=NATIVE configure argument, add
      -DAI_FIND_QUIETLY=FALSE
    - add debian/patches/0002-use-Debian-java-libs.patch to use jar files
      from libvecmath-java and libjna-java
    - add debian/patches/0003-fix-cmake-2_8-java-build.patch to fix cmake 2.8
      java compilation issue
   * add new binary package spring-javaai
    - add package stanza to debian/control
    - add paths to debian/spring-javaai.install
   * add spring-javaai to spring binary package's Suggests in debian/control
   * refine debian/spring-common.install to exclude Java AI files from
     spring-common
   * debian/control: remove libgcj9-dev from Build-Depends, it is not
     available anymore and not necessary (Closes: #577885)
 .
 spring (0.81.2.1+dfsg1-2) unstable; urgency=low
 .
   * use FreeSansBold.otf from otf-freefont (Closes: #575512)
    - debian/control: depend on otf-freefont instead of ttf-freefont
    - debian/rules: symlink to otf version of FreeSansBold
 .
 spring (0.81.2.1+dfsg1-1) unstable; urgency=low
 .
   * New upstream version
 .
 spring (0.81.2+dfsg1-1) unstable; urgency=low
 .
   * New upstream version
   * debian/rules, debian/watch: use +dfsg instead of ~dfsg for correct
     sorting
 .
 spring (0.81.1.3~dfsg1-1) unstable; urgency=low
 .
   [ Marco Amadori ]
   * Imported Upstream version 0.81.1.3
   * Set -march=i686 only on i386 (Helps: #563686).
   * Adapted DATADIR paths to relative ones
   * Bumped Standards-Version to 3.8.4.
 .
   [ Jan Dittberner ]
   * repack tarball in a get-orig-source rule
   * add dversionmangle to debian/watch
   * move information from debian-removed.txt to debian/README.source
   * debian/control:
    - add myself to Uploaders
    - set Architecture for spring and spring-dbg to i386 amd64
      kfreebsd-i386 kfreebsd-amd64 hurd-i386 because of x86 only assembly in
      rts/lib/streflop/streflopC.cpp
    - remove Build-Depends quilt
   * add doc-base registration files debian/spring.doc-base.devguide and
     debian/spring.doc-base.minihelp for included HTML documentation
   * add debian/source/format with content "3.0 (quilt)"
   * remove quilt information from debian/README.source
   * debian/rules: remove " --with quilt"
Files: 
 9fe6af58bf2ec435da28282a85088dd9 7639506 games optional spring_0.81.2.1+dfsg1.orig.tar.gz
 579beaa07c178ebd66ea43b68ebe6360 2369 games optional spring_0.81.2.1+dfsg1-6.dsc
 b89ac09068630abb52f197c53f2f692b 10697 games optional spring_0.81.2.1+dfsg1-6.debian.tar.gz


More information about the Maverick-changes mailing list