[ubuntu/mantic-updates] freerdp2 2.10.0+dfsg1-1.1ubuntu1.1 (Accepted)

Ubuntu Archive Robot ubuntu-archive-robot at lists.canonical.com
Wed Nov 29 14:58:59 UTC 2023


freerdp2 (2.10.0+dfsg1-1.1ubuntu1.1) mantic-security; urgency=medium

  * SECURITY UPDATE: OOB write via invalid offset validation
    - debian/patches/CVE-2023-39352.patch: add bound check in gdi_SolidFill
      in libfreerdp/gdi/gfx.c.
    - CVE-2023-39352
  * SECURITY UPDATE: OOB read via missing offset validation
    - debian/patches/CVE-2023-39356-1.patch: fix checks for multi opaque
      rect in libfreerdp/core/orders.c.
    - debian/patches/CVE-2023-39356-2.patch: fix reading order number field
      in libfreerdp/core/orders.c.
    - CVE-2023-39356

Date: 2023-11-27 18:11:23.531426+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
Signed-By: Ubuntu Archive Robot <ubuntu-archive-robot at lists.canonical.com>
https://launchpad.net/ubuntu/+source/freerdp2/2.10.0+dfsg1-1.1ubuntu1.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the mantic-changes mailing list