[ubuntu/lucid] gnome-power-manager 2.30.0-0ubuntu1 (Accepted)

Martin Pitt martin.pitt at ubuntu.com
Mon Mar 29 13:40:15 BST 2010


gnome-power-manager (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream release:
   - Check for libpanel only if building the applets
   - Check for XRR* functions using library version instead of proto version
   - Use pkg-config instead of autoconf macros to find X libs and protos
   - Declare GError in gpm_brightness_hal_init to fix build failure
   - Do not set a charge warning if the device is on AC
   - Do not use EggDbusProxy in GpmScreensaver
   - Don't query the capabilities of the notification daemon
   - Ensure we close any 'battery low' notifications when we switch to being
     on AC
   - Fix a problem where the critical action is not done in the case of a UPS
   - Fix a race condition where we can miss the idle reset alarm
   - Fix up a translation using ngettext rather than assuming the plural.
   - Fix wrong suspends with docked laptops
   - If a battery charge is low but not critical don't play the sound meant
     for a critical charge event
   - Play a sound loop if the charge of a laptop battery/ups reaches a
     critical level.
   - Remove the pointy-finger status icon when the idletime code fails to work
     correctly
   - Replace devkit-power call with upower in gnome-power-bugreport.sh
  * Drop patches which went upstream:
   - 01-suspend-on-vt-change.patch
   - 10-proxy-by-name.patch
   - 13-dont-query-notify-caps.patch
   - 14-critical-message-timeout.patch
   - 15-declare-gerror.patch
   - 16-upower-bugreport.patch
   - 18-fix-idletime-reset-race.patch
  * Drop 06-bugreport-debian.patch: It's actually wrong for Ubuntu, we use
    lsb_release, not /etc/debian_version.
  * 90-autotools.patch: Regenerate.
  * 08-desktop-bugreport-path.patch, 12-add-appindicators.patch: Update to
    current patch tagging guidelines.
  * debian/control.in: Set Maintainer from "Ted Gould" to "Ubuntu Developers".
  * Synchronize with Debian:
    - Build/binary dependency cleanup/shuffling.
    - Bump Standards-Version to 3.8.4.
    - Add debian/preinst for upgrade conffile cleanup.
    - Drop obsolete debian/README.Debian

Date: Mon, 29 Mar 2010 14:34:27 +0200
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/lucid/+source/gnome-power-manager/2.30.0-0ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 29 Mar 2010 14:34:27 +0200
Source: gnome-power-manager
Binary: gnome-power-manager
Architecture: source
Version: 2.30.0-0ubuntu1
Distribution: lucid
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Description: 
 gnome-power-manager - power management tool for the GNOME desktop
Changes: 
 gnome-power-manager (2.30.0-0ubuntu1) lucid; urgency=low
 .
   * New upstream release:
    - Check for libpanel only if building the applets
    - Check for XRR* functions using library version instead of proto version
    - Use pkg-config instead of autoconf macros to find X libs and protos
    - Declare GError in gpm_brightness_hal_init to fix build failure
    - Do not set a charge warning if the device is on AC
    - Do not use EggDbusProxy in GpmScreensaver
    - Don't query the capabilities of the notification daemon
    - Ensure we close any 'battery low' notifications when we switch to being
      on AC
    - Fix a problem where the critical action is not done in the case of a UPS
    - Fix a race condition where we can miss the idle reset alarm
    - Fix up a translation using ngettext rather than assuming the plural.
    - Fix wrong suspends with docked laptops
    - If a battery charge is low but not critical don't play the sound meant
      for a critical charge event
    - Play a sound loop if the charge of a laptop battery/ups reaches a
      critical level.
    - Remove the pointy-finger status icon when the idletime code fails to work
      correctly
    - Replace devkit-power call with upower in gnome-power-bugreport.sh
   * Drop patches which went upstream:
    - 01-suspend-on-vt-change.patch
    - 10-proxy-by-name.patch
    - 13-dont-query-notify-caps.patch
    - 14-critical-message-timeout.patch
    - 15-declare-gerror.patch
    - 16-upower-bugreport.patch
    - 18-fix-idletime-reset-race.patch
   * Drop 06-bugreport-debian.patch: It's actually wrong for Ubuntu, we use
     lsb_release, not /etc/debian_version.
   * 90-autotools.patch: Regenerate.
   * 08-desktop-bugreport-path.patch, 12-add-appindicators.patch: Update to
     current patch tagging guidelines.
   * debian/control.in: Set Maintainer from "Ted Gould" to "Ubuntu Developers".
   * Synchronize with Debian:
     - Build/binary dependency cleanup/shuffling.
     - Bump Standards-Version to 3.8.4.
     - Add debian/preinst for upgrade conffile cleanup.
     - Drop obsolete debian/README.Debian
Checksums-Sha1: 
 0ff9c9decf39566b7833b637cac767f88a2333f7 1980 gnome-power-manager_2.30.0-0ubuntu1.dsc
 34f71bb3228e81e87a35ee470d826cdd0f5b257c 4849151 gnome-power-manager_2.30.0.orig.tar.gz
 429e36e074b59d2e291c108d85af4cb3c28e34ef 41008 gnome-power-manager_2.30.0-0ubuntu1.diff.gz
Checksums-Sha256: 
 ed7c9b011ce817ff24278a0f7a9c5c2760e515c020ac7a3e7a9265ac12b50450 1980 gnome-power-manager_2.30.0-0ubuntu1.dsc
 1a758bdc5e578ebac89283b8a11c5885f4917eed8e95a9a9c5f6a8792434c50a 4849151 gnome-power-manager_2.30.0.orig.tar.gz
 0092201e5aef5d6343659d8baf6b8c084bfaa1e16d2e26e35b8e377415425173 41008 gnome-power-manager_2.30.0-0ubuntu1.diff.gz
Files: 
 a338520f15fccb956db68e9d6eb01c94 1980 gnome optional gnome-power-manager_2.30.0-0ubuntu1.dsc
 3ec087e3db16ac0705439cd5061cf062 4849151 gnome optional gnome-power-manager_2.30.0.orig.tar.gz
 b28e8facd148f95a5473f2d2db08f2dc 41008 gnome optional gnome-power-manager_2.30.0-0ubuntu1.diff.gz
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers at lists.alioth.debian.org>
Original-Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkuwnmoACgkQDecnbV4Fd/JxngCg4w3ApVCTf635PRGKnxdE6cC6
ZWwAoNb5r3g9vNGOBP9cmiaTAeHLT5E2
=OWSz
-----END PGP SIGNATURE-----


More information about the Lucid-changes mailing list